Page 1 of 5 123 ... LastLast
Results 1 to 10 of 45

Thread: Vim is not working

  1. #1
    laskachien NNTP User

    Default Vim is not working

    Hello
    I can t use vim,I got the Uganda page and for help a very little txt.And a lot of help txt files cannot open any.I try insert nothing goes.
    I see in .bashrc that I have to choose and uncomment the vim editor used ?
    But how can I do that?

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,068

    Default Re: Vim is not working

    On Thu, 06 Jun 2013 15:46:02 +0000, laskachien wrote:

    > Hello I can t use vim,I got the Uganda page and for help a very little
    > txt.And a lot of help txt files cannot open any.I try insert nothing
    > goes.
    > I see in .bashrc that I have to choose and uncomment the vim editor used
    > ?
    > But how can I do that?


    What version of openSUSE are you using?

    To insert in vim, press 'i'.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3

    Default Re: Vim is not working

    In addition to Jim's suggestion, you may want to try this before trying to use Vim:

    Code:
    sh-4.2$ vimtutor
    .... this is the first step towards Nirvana .


  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Vim is not working

    On 06/06/2013 06:42 PM, flymail wrote:
    > this is the first step towards Nirvana


    maybe the first step on your machine, but on mine i get:

    Code:
    denverd@linux-os114:~> sh-4.2$ vimtutor
    If 'sh-4.2$' is not a typo you can use command-not-found to lookup
    the package that contains it, like this:
    cnf sh-4.2$
    denverd@linux-os114:~>
    i think the OP might use one or both of these, one at a time:

    Code:
    info vim
    vimtutor


    otoh, i'm not a masochist so i recommend mc instead of vim...of
    course i wouldn't wanna start a flame war, especially not with folks
    who might use the woefully deficient Vi IMproved :>

    --
    dd

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Vim is not working

    On 2013-06-06 17:46, laskachien wrote:
    >
    > Hello
    > I can t use vim,I got the Uganda page and for help a very little
    > txt.And a lot of help txt files cannot open any.I try insert nothing
    > goes.
    > I see in .bashrc that I have to choose and uncomment the vim editor
    > used ?
    > But how can I do that?



    You can use any editor you like to edit "~/.bashrc" and add an "EDITOR" environment var.

    Text mode: joe (and its callnames), mcedit, pico, nano. Also emacs and vi.

    Graphic mode: kedit, gedit, leafpad... not forgetting emacs (dunno if vi has a graphic counterpart)


    --
    Cheers / Saludos,

    Carlos E. R.
    (from oS 12.3 "Dartmouth" GM (rescate 1))

  6. #6

    Default Re: Vim is not working

    On 2013-06-06, dd <DenverD@no-mx.forums.opensuse.org> wrote:
    >
    Code:
    > denverd@linux-os114:~> sh-4.2$ vimtutor
    > If 'sh-4.2$' is not a typo you can use command-not-found to lookup
    > the package that contains it, like this:
    >      cnf sh-4.2$
    > denverd@linux-os114:~>
    >


    Just for you dd, try this:

    Code:
    denverd@linux-os114:~> /bin/sh
    and you will see what I mean.

    I use Vim for NNTP posts. And so sh-4.2$ is my standard shell prompt (after running :!/bin/sh/ in NORMAL mode). But I
    guess you knew that...






  7. #7

    Default Re: Vim is not working

    On 2013-06-06, Carlos E. R. <robin_listas@no-mx.forums.opensuse.org> wrote:
    > (dunno if vi has a graphic counterpart)


    The closest GUI version is gVim.

  8. #8

    Default Re: Vim is not working

    On 2013-06-06, Carlos E. R. <robin_listas@no-mx.forums.opensuse.org> wrote:
    > Graphic mode: kedit, gedit, leafpad... not forgetting emacs (dunno if vi has a graphic counterpart)


    I thought the graphical version of emacs is XEmacs?

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Vim is not working

    On 2013-06-06 20:01, flymail wrote:
    > On 2013-06-06, Carlos E. R. <robin_listas@no-mx.forums.opensuse.org> wrote:
    >> Graphic mode: kedit, gedit, leafpad... not forgetting emacs (dunno if vi has a graphic counterpart)

    >
    > I thought the graphical version of emacs is XEmacs?


    Possibly. I don't have it installed in this small test system, so I can't verify; but IIRC, calling
    "emacs" directly in GUI works. It is possibly redirected. Will try later if I remember.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from oS 12.3 "Dartmouth" GM (rescate 1))

  10. #10

    Default Re: Vim is not working

    On 2013-06-06, dd <DenverD@no-mx.forums.opensuse.org> wrote:
    > otoh, i'm not a masochist so i recommend mc instead of vim...of
    > course i wouldn't wanna start a flame war, especially not with folks
    > who might use the woefully deficient Vi IMproved :>


    It's interesting nowadays that the most disparaging comments made about Vim tend not to come so much from Emacs fans but
    from those who use neither. Perhaps it's a manifestion of some underlying insecurity complex .

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •