Results 1 to 8 of 8

Thread: MySQL in openSUSE 12.3

  1. #1
    Join Date
    Sep 2012
    Location
    Beijing | Nanjing
    Posts
    164

    Default MySQL in openSUSE 12.3

    I installed MySQL in my openSUSE 12.3 with zypper; but when I started it, I got errors below:
    Code:
    root@suse:~ # service mysql start
    Failed to issue method call: Unit mysql.service failed to load: No such file or directory. See system logs and 'systemctl status mysql.service' for details.
    and this:
    Code:
    ~ $ systemctl status mysql.servicemysql.service
              Loaded: error (Reason: No such file or directory)
              Active: inactive (dead)
    also:
    Code:
    ~ $ sudo systemctl enable mysql.service
    mysql.service is not a native service, redirecting to /sbin/chkconfig.
    Executing /sbin/chkconfig mysql on
    Code:
    ~ $ chkconfig | grep mysql
    mysql           on
    Anyone has the same problem?
    Thanks and BR
    Anything that can go wrong will go wrong~
    http://www.icocoa.me/

  2. #2

    Default Re: MySQL in openSUSE 12.3

    Quote Originally Posted by douglarek View Post
    I installed MySQL in my openSUSE 12.3 with zypper; but when I started it, I got errors below:
    Code:
    root@suse:~ # service mysql start
    Failed to issue method call: Unit mysql.service failed to load: No such file or directory. See system logs and 'systemctl status mysql.service' for details.
    and this:
    Code:
    ~ $ systemctl status mysql.servicemysql.service
              Loaded: error (Reason: No such file or directory)
              Active: inactive (dead)
    also:
    Code:
    ~ $ sudo systemctl enable mysql.service
    mysql.service is not a native service, redirecting to /sbin/chkconfig.
    Executing /sbin/chkconfig mysql on
    Code:
    ~ $ chkconfig | grep mysql
    mysql           on
    Anyone has the same problem?
    MySQL still has a sysv-style init script, so there is no mysql.service.
    Try to start it with "sudo systemctl start mysql".
    To get the status, run "systemctl status mysql".
    And to enable it on boot, run "sudo systemctl enable mysql" (although you seem to have it enabled already)

    And you can omit the ".service" in general, btw. systemctl will automatically add it if needed.

  3. #3

    Default Re: MySQL in openSUSE 12.3

    Quote Originally Posted by wolfi323 View Post
    MySQL still has a sysv-style init script, so there is no mysql.service.
    Try to start it with "sudo systemctl start mysql".
    To get the status, run "systemctl status mysql".
    And to enable it on boot, run "sudo systemctl enable mysql" (although you seem to have it enabled already)

    And you can omit the ".service" in general, btw. systemctl will automatically add it if needed.

    Doesn't work that... The problem still there

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: MySQL in openSUSE 12.3

    What does

    systemctl status mysql

    tell you

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: MySQL in openSUSE 12.3

    Quote Originally Posted by yelkopunx View Post
    Doesn't work that... The problem still there
    Welcome to the forums. As this is your first post, I suggest, if you have not already done it, that you go into YaST>System services and check that mysqld is enabled. Then open a terminal and enter
    Code:
    mysql_secure_installation
    In answer to the password question, give a secure root password and accept the defaults for everything else.
    After you have done all this, come back if you have any problems.

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,300
    Blog Entries
    2

    Default Re: MySQL in openSUSE 12.3

    [QUOTE=douglarek;2562994]
    Code:
    ~ $ systemctl status mysql.servicemysql.service
              Loaded: error (Reason: No such file or directory)
              Active: inactive (dead)
    QUOTE]

    If this is the exact command, it won't work(You've posted a command with mysql.service twice. You also don't need to type the suffix ".service" systemd will automatically append it unless you have multiple entries). You need to post the results of
    Code:
    systemctl status mysql
    That should return some important info, there may also be info in your system logs, eg
    Code:
    cat /var/log/messages | grep mysql
    To this point, there isn't enough information to know what the issue is, but IMO
    - It's unlikely you have an authentication problem starting the service
    - It's unlikely MySQL (or MariaDB) was installed incorrectly and can't start

    Just need basic info here...

    IMO,
    TSU

  7. #7

    Default Re: MySQL in openSUSE 12.3

    Quote Originally Posted by tsu2 View Post
    Quote Originally Posted by douglarek View Post
    Code:
    ~ $ systemctl status mysql.servicemysql.service
              Loaded: error (Reason: No such file or directory)
              Active: inactive (dead)
    If this is the exact command, it won't work(You've posted a command with mysql.service twice.
    That was the original poster, and that was posted nearly a year ago.

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,300
    Blog Entries
    2

    Default Re: MySQL in openSUSE 12.3

    Quote Originally Posted by wolfi323 View Post
    That was the original poster, and that was posted nearly a year ago.
    Hope it helps him if he's still got his ears on and hasn't snoozed off...


    TSU

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •