Results 1 to 6 of 6

Thread: Gimp complains on missing GTK themes

  1. #1
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Gimp complains on missing GTK themes

    Gimp will no longer run on my Opensuse 12.3 with KDE 4.10.3

    It complains about the following themes
    username@machine:~> gimp

    (gimp:24142): Gtk-WARNING **: Could not find theme engine in module_path: «ubuntulooks».

    (gimp:24142): Gtk-WARNING **: Could not find theme engine in module_path: «crux-engine».

    (gimp:24142): Gtk-WARNING **: Could not find theme engine in module_path: «ubuntulooks».

    (gimp:24142): Gtk-WARNING **: Could not find theme engine in module_path: «crux-engine».
    So i tried to install grk2-crux-engine and gtk2-crux-theme. Ubuntulook was nowhere to be found. So I tried these Ubuntulooks Pack GNOME-Look.org.

    It still complains about missing ubuntulooks. Aren't there any opensuse themes for Gimp?

    Gimp should work out-of-the-box with Opensuse...

  2. #2

    Default Re: Gimp complains on missing GTK themes

    Quote Originally Posted by DJViking View Post
    Gimp should work out-of-the-box with Opensuse...
    Normally it does.
    Also those are warnings, they shouldn't prevent gimp from starting.

    You could try to delete the files .gtkrc-2.0 and .gtkrc-2.0-kde4 and the directory .gimp-2.8 in your home directory.

    Or maybe it helps if you run KDE's Configure Desktop (systemsettings) and change the configuration in "Application Appearance"->GTK.

  3. #3
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: Gimp complains on missing GTK themes

    Quote Originally Posted by wolfi323 View Post
    Normally it does.
    Also those are warnings, they shouldn't prevent gimp from starting.

    You could try to delete the files .gtkrc-2.0 and .gtkrc-2.0-kde4 and the directory .gimp-2.8 in your home directory.

    Or maybe it helps if you run KDE's Configure Desktop (systemsettings) and change the configuration in "Application Appearance"->GTK.
    Deleting .gtkrc-2.0, .gtkrc-2.0-kde4 and .gimp-2.8 removed the warnings, but gimp does not start up. When I start from konsole there is no error messages.

    Changing GTK themes in KDE systemsettings had no effect.

    I cannot find any indications on why Gimp wont start up.

  4. #4

    Default Re: Gimp complains on missing GTK themes

    Quote Originally Posted by DJViking View Post
    Deleting .gtkrc-2.0, .gtkrc-2.0-kde4 and .gimp-2.8 removed the warnings, but gimp does not start up. When I start from konsole there is no error messages.

    Changing GTK themes in KDE systemsettings had no effect.

    I cannot find any indications on why Gimp wont start up.
    Hm. Maybe it is already running but the window is hidden somewhere?
    Try to kill it first:
    Code:
    killall gimp
    gimp

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,000
    Blog Entries
    14

    Default Re: Gimp complains on missing GTK themes

    Quote Originally Posted by DJViking View Post
    Deleting .gtkrc-2.0, .gtkrc-2.0-kde4 and .gimp-2.8 removed the warnings, but gimp does not start up. When I start from konsole there is no error messages.

    Changing GTK themes in KDE systemsettings had no effect.

    I cannot find any indications on why Gimp wont start up.
    Make GIMP crash, then immediately do
    Code:
    tail -100 ~/.xsession-errors | more
    And, since you're removing config files / folders, try removing gtk-3.0 from ~/.config
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: Gimp complains on missing GTK themes

    It never occurred to me that gimp might be running in the background. Actually the first thing I should have checked.
    Killed the old dead process gimp-2.8 and gimp started fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •