Results 1 to 2 of 2

Thread: QLandkarteGT on OS 12.3

  1. #1

    Default QLandkarteGT on OS 12.3

    After a direct distribution upgrade from 12.1 to 12.3 (via 12.2) by zypper I had to perform following steps to get QLandkarteGT (installed from repo GEO) running:

    Solve Start-up Error:


    • qlandkartegt does not start up
    • Start within terminal yields
      Code:
      > qlandkartegt 
      qlandkartegt: error while loading shared libraries: libhdf5_hl.so.7: cannot open shared object file: No such file or directory
    • Acc. https://code.google.com/p/protobuf/i...tail?id=213#c7

    a typical reason for this behavior is a stale ld.so.cache; try to run ldconfig to update it after making sure that /usr/local/lib is listed in /etc/ld.so.conf.So

    • So

    Code:
    # locate libhdf5_hl
    /usr/lib64/mpi/gcc/openmpi/lib64/libhdf5_hl.so.7
    /usr/lib64/mpi/gcc/openmpi/lib64/libhdf5_hl.so.7.0.4

    • and with

    Code:
    # cat /etc/ld.so.conf
    /usr/local/lib64
    /usr/local/lib
    include /etc/ld.so.conf.d/*.conf
    # /lib64, /lib, /usr/lib64 and /usr/lib gets added
    # automatically by ldconfig after parsing this file.
    # So, they do not need to be listed.

    • the solution was

    Code:
    # echo /usr/lib64/mpi/gcc/openmpi/lib64 >> /etc/ld.so.conf.d/qlandkartegt.conf
    # ldconfig
    qlandkartegt starts up, o.k.

    Solve Garmin Access Error:


    Code:
    # cat /etc/udev/rules.d/51-garmin.rules
    # outdated:
    # SYSFS{idVendor}=="091e", SYSFS{idProduct}=="0003", MODE="0666"
    #
    # fixed acc:
    # http://permalink.gmane.org/gmane.comp.gis.qlandkartegt.user/1157
    # SUBSYSTEM=="usb", ATTR{idVendor}=="091e", ATTR{idProduct}=="0003", MODE="0660", GROUP="plugdev"
    #
    SUBSYSTEM=="usb", ATTR{idVendor}=="091e", ATTR{idProduct}=="0003", MODE="0666"

    Code:
    # udevadm control --reload
    Now QLandkarteGT works as expected again!

  2. #2

    Default Re: QLandkarteGT on OS 12.3

    Quote Originally Posted by pinysuse View Post
    • So

    Code:
    # locate libhdf5_hl
    /usr/lib64/mpi/gcc/openmpi/lib64/libhdf5_hl.so.7
    /usr/lib64/mpi/gcc/openmpi/lib64/libhdf5_hl.so.7.0.4
    Hm, I have that in /usr/lib64/:
    Code:
    # locate libhdf5_hl
    /usr/lib64/libhdf5_hl.so.7
    /usr/lib64/libhdf5_hl.so.7.0.4
    /usr/lib64/libhdf5_hl_cpp.so.7
    /usr/lib64/libhdf5_hl_cpp.so.7.0.4
    It's contained in the package "libhdf5_hl0" from the standard OSS repo. Just install this and you shouldn't have to mess around with your ldconfig...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •