Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Ntp time is wrong, server can't be reached

  1. #1
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Question Ntp time is wrong, server can't be reached

    hi,

    I'm using kde, the clock applet time is wrong, it's UTC and thus lacking 2 hours.
    i'm using ntp and pool.server.org as default, if i want to change the server to europe.pool.server.org i can't, it can't be reached.

    ntpdate seems ok but kde clock is still wrong after reboot
    Code:
    ntpdate pool.ntp.org
    25 May 08:10:42 ntpdate[6723]: adjust time server 88.190.29.49 offset -0.001477 sec
    what else shall i do to fix this ? THanks
    openSUSE Leap 42.2 , KDE Plasma 5

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Ntp time is wrong, server can't be reached

    Quote Originally Posted by manchette_fr View Post
    hi,

    I'm using kde, the clock applet time is wrong, it's UTC and thus lacking 2 hours.
    i'm using ntp and pool.server.org as default, if i want to change the server to europe.pool.server.org i can't, it can't be reached.

    ntpdate seems ok but kde clock is still wrong after reboot
    Code:
    ntpdate pool.ntp.org
    25 May 08:10:42 ntpdate[6723]: adjust time server 88.190.29.49 offset -0.001477 sec
    what else shall i do to fix this ? THanks
    Are you doing this through YaST==> Date and time ==>"Change"==> Synchronize with NTTP...

    Also i can access europe.pool.server.org

    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  3. #3
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Default Re: Ntp time is wrong, server can't be reached

    synchronize does not work


    do i need to be UTC ? (hardware clock)

    what does it mean that ntp can be a daemon, in what is it helpful ?
    openSUSE Leap 42.2 , KDE Plasma 5

  4. #4

    Default AW: Re: Ntp time is wrong, server can't be reached

    Quote Originally Posted by manchette_fr View Post
    synchronize does not work


    do i need to be UTC ? (hardware clock)
    No, it should work with local time as well. That said, there was a bug in openSUSE 12.2 regarding local time:
    https://bugzilla.novell.com/show_bug.cgi?id=791106
    Do you use 12.2?

    what does it mean that ntp can be a daemon, in what is it helpful ?
    If it is a daemon, it runs all the time. You only need that if you want to be a ntp server in your LAN, f.e.
    Otherwise "rcntp ntptimeset" is called every 15 minutes by a cron job.

    Does running "rcntp ntptimeset" manually work for you?
    Do you have the correct timezone selected in YaST->System->Date and Time?
    Do you have cron running? "systemctl status cron.service"

  5. #5
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Default Re: Ntp time is wrong, server can't be reached

    hi,

    i'm with 12.3 already thus the bug should be no more, i'd like to be UTC + ntp if possible.
    I definitely do not need a daemon all the time (yet).

    time zone is ok in yast, yes

    it seems like synchro works but the kde applet still gives the wrong time :

    Code:
    rcntp ntptimeset
    25 May 13:57:57 sntp[6516]: Started sntp
    2013-05-25 13:57:57.551849 (-0100) -0.00745
    Time synchronized with  chronos.cru.fr
    
    
    # systemctl status cron.service
    cron.service - Command Scheduler
              Loaded: loaded (/usr/lib/systemd/system/cron.service; enabled)
              Active: active (running) since Sat, 2013-05-25 11:13:17 CEST; 2h 47min ago
            Main PID: 3384 (cron)
              CGroup: name=systemd:/system/cron.service
                      └ 3384 /usr/sbin/cron -n
    openSUSE Leap 42.2 , KDE Plasma 5

  6. #6

    Default Re: Ntp time is wrong, server can't be reached

    Quote Originally Posted by manchette_fr View Post
    i'd like to be UTC + ntp if possible.
    Hm? I thought you were on localtime. Because you asked "do i need to be UTC ? (hardware clock)".
    But anyway, this doesn't really matter, except for this bug in standard 12.2...

    it seems like synchro works but the kde applet still gives the wrong time :

    Code:
    rcntp ntptimeset
    25 May 13:57:57 sntp[6516]: Started sntp
    2013-05-25 13:57:57.551849 (-0100) -0.00745
    Time synchronized with  chronos.cru.fr
    OK, did you check that your system time is correct after synchronizing? Run "date" for that.
    And you can check the hwclock time by running "hwclock -r". Maybe add the "--debug" option as well to see more verbose output.

    And you can configure the kde clock which timezone(s) to show.
    Please right-click on it and select "Settings for Digital Clock" (or similar).
    Maybe this is set to UTC?

  7. #7
    Join Date
    Oct 2008
    Location
    near the Alps
    Posts
    567

    Default Re: Ntp time is wrong, server can't be reached

    i have this for system date and time :
    Code:
    sam. mai 25 14:42:19 CEST 2013
    is this not setting the time to the kde applet ?

    it seems the kde clock applet settings were wrong,timezone was set in UTC as you said, when i set it to Paris area time is finally ok .

    On the same screen i also have another choice : default set clock can be set to "Local" or " Europe/Paris". What's the difference ?
    openSUSE Leap 42.2 , KDE Plasma 5

  8. #8

    Default Re: Ntp time is wrong, server can't be reached

    Quote Originally Posted by manchette_fr View Post
    i have this for system date and time :
    Code:
    sam. mai 25 14:42:19 CEST 2013
    is this not setting the time to the kde applet ?
    The KDE applet reads the current system time, yes.

    it seems the kde clock applet settings were wrong,timezone was set in UTC as you said, when i set it to Paris area time is finally ok .
    So your problem is fixed now? Great!

    On the same screen i also have another choice : default set clock can be set to "Local" or " Europe/Paris". What's the difference ?
    "Local" should be the timezone you selected in YaST->Date and Time, I think. (Can't check right now)

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Ntp time is wrong, server can't be reached

    I'm seeing some funny business with too
    My desktop clock isn't changing

    The hardware clock and the settings in Yast are set correctly.
    But the time on the desktop isn't, it's one hour behind
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Ntp time is wrong, server can't be reached

    Quote Originally Posted by caf4926 View Post
    I'm seeing some funny business with too
    My desktop clock isn't changing

    The hardware clock and the settings in Yast are set correctly.
    But the time on the desktop isn't, it's one hour behind

    FYI
    Code:
    hwclock -r --debughwclock from util-linux 2.21.2
    Using /dev interface to clock.
    Last drift adjustment done at 1370233870 seconds after 1969
    Last calibration done at 1370233870 seconds after 1969
    Hardware clock is on local time
    Assuming hardware clock is kept in local time.
    Waiting for clock tick...
    ...got clock tick
    Time read from Hardware Clock: 2013/06/03 05:37:06
    Hw clock time : 2013/06/03 05:37:06 = 1370234226 seconds since 1969
    Mon 03 Jun 2013 05:37:06 BST  -0.485153 seconds
    Desktop is showing 04:37....
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •