Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: DejaDup refuses to accept password

  1. #1

    Default DejaDup refuses to accept password

    I am attempting to restore my machine from a dejadup backup which is encrypted. I enter the correct password and it continues to prompt me for the password.

    Relevant output in
    Code:
    /var/log/messages
    is

    Code:
    2013-05-24T08:27:59.976602+01:00 linux-nscv sudo: The gnome keyring socket is not owned with the same credentials as the user login: /run/user/1000/keyring-ZBH03s/control
    2013-05-24T08:27:59.977062+01:00 linux-nscv sudo: gkr-pam: couldn't unlock the login keyring.
    OpenSUSE 12.3 64 bit.
    Last edited by loki_88; 24-May-2013 at 00:35. Reason: opensuse version

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: DejaDup refuses to accept password

    On 05/24/2013 09:36 AM, loki 88 wrote:
    >
    > sudo: The gnome keyring socket is not owned with the same credentials as the user login: /run/user/1000/keyring-Z


    to me, it looks like your encrypted stuff is owned by user #1000
    (you!) while you are trying to dencrypt as root (whose number is not
    1000)

    so, try decrypting it as yourself...see if that works...(and let us know)

    --
    dd
    http://tinyurl.com/DD-Caveat

  3. #3

    Default Re: DejaDup refuses to accept password

    Unfortunately, I am running as user. I am not sudo'ing the command. I am only dealing with the gui as user. Another forum has requested I try using duplicity directly. I will report back later.

    Quote Originally Posted by DenverD View Post
    On 05/24/2013 09:36 AM, loki 88 wrote:
    >
    > sudo: The gnome keyring socket is not owned with the same credentials as the user login: /run/user/1000/keyring-Z


    to me, it looks like your encrypted stuff is owned by user #1000
    (you!) while you are trying to dencrypt as root (whose number is not
    1000)

    so, try decrypting it as yourself...see if that works...(and let us know)

    --
    dd
    http://tinyurl.com/DD-Caveat

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: DejaDup refuses to accept password

    On 2013-05-24 10:58, dd wrote:
    > On 05/24/2013 09:36 AM, loki 88 wrote:
    >>
    >> sudo: The gnome keyring socket is not owned with the same
    >> credentials as the user login: /run/user/1000/keyring-Z

    >
    > to me, it looks like your encrypted stuff is owned by user #1000 (you!)
    > while you are trying to dencrypt as root (whose number is not 1000)


    No, that's a side effect of using sudo; it is similar to issues with
    "su" as compared to "su -". I would try use "su -" in a terminal and
    call the program from there.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  5. #5

    Default Re: DejaDup refuses to accept password

    More information. I believe it's a GPG problem. This is the log from deja-dup:

    Code:
    DUPLICITY: ERROR 31 GPGError
    DUPLICITY: . GPGError: GPG Failed, see log below:
    DUPLICITY: . ===== Begin GnuPG log =====
    DUPLICITY: . gpg: WARNING: "--no-use-agent" is an obsolete option - it has no effect
    DUPLICITY: . gpg: CAST5 encrypted data
    DUPLICITY: . gpg: encrypted with 1 passphrase
    DUPLICITY: . gpg: decryption failed: Bad session key
    DUPLICITY: . gpg: block_filter 0x7f969a828e60: read error (size=15648,a->size=15648)
    DUPLICITY: . gpg: block_filter: pending bytes!
    DUPLICITY: . ===== End GnuPG log =====

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: DejaDup refuses to accept password

    On 2013-05-25 19:56, loki 88 wrote:
    >
    > More information. I believe it's a GPG problem. This is the log from
    > deja-dup:
    >
    >
    > Code:
    > --------------------
    > DUPLICITY: ERROR 31 GPGError
    > DUPLICITY: . GPGError: GPG Failed, see log below:
    > DUPLICITY: . ===== Begin GnuPG log =====
    > DUPLICITY: . gpg: WARNING: "--no-use-agent" is an obsolete option - it has no effect
    > DUPLICITY: . gpg: CAST5 encrypted data
    > DUPLICITY: . gpg: encrypted with 1 passphrase
    > DUPLICITY: . gpg: decryption failed: Bad session key
    > DUPLICITY: . gpg: block_filter 0x7f969a828e60: read error (size=15648,a->size=15648)
    > DUPLICITY: . gpg: block_filter: pending bytes!
    > DUPLICITY: . ===== End GnuPG log =====
    > --------------------


    Notice that in order for it to use the right keys, it needs access to
    the right home with the proper keys.

    Meaning:

    if you use "su" you access: /home/USER/.gnupg/
    if you use "su -" you access: /home/root/.gnupg/

    If you use sudo, what? :-?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: DejaDup refuses to accept password

    On 05/25/2013 08:28 PM, Carlos E. R. wrote:
    > If you use sudo, what? :-?


    denverd@linux-os114:~> echo $PATH
    /home/denverd/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games
    denverd@linux-os114:~> sudo echo $PATH
    root's password:
    /home/denverd/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games
    denverd@linux-os114:~> su
    Password:
    linux-os114:/home/denverd # echo $PATH
    /home/denverd/bin:/usr/local/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games
    linux-os114:/home/denverd # exit
    exit
    denverd@linux-os114:~> su -
    Password:
    linux-os114:~ # echo $PATH
    /sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games
    linux-os114:~ #

    it looks to me that these both of the user and sudo give the same
    environment/path

    su gives the root path but keeps the user's home & user number

    and only su- gives the full root environment and path....been like
    that for years and years..

    --
    dd


  8. #8

    Default Re: DejaDup refuses to accept password

    I am not sudoing and it still can't find the right key it seems

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: DejaDup refuses to accept password

    On 2013-05-25 21:46, loki 88 wrote:
    >
    > I am not sudoing and it still can't find the right key it seems


    I have never tried encrypting a backup with GPG, but I think that the
    secret key must be in running system keyring, so perhaps you have to
    restore the keyring first.

    But I might be completely wrong.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  10. #10

    Default Re: DejaDup refuses to accept password


Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •