Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: NUMLock pad is essentially inoperative in opensuse 12.3

  1. #1

    Default NUMLock pad is essentially inoperative in opensuse 12.3

    NumLock is operative only for a few minutes after opensuse 12.3 installs; then the numbers pad is inoperative. Only the numbers at the top of the keyboard are functional.
    It happened also with opensuse 12.2 and I expected it to get corrected but it never was.
    Will it get solved in 12.3?
    Any suggestions/ideas?

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,068

    Default Re: NUMLock pad is essentially inoperative in opensuse 12.3

    On Thu, 23 May 2013 21:06:01 +0000, scnovell wrote:

    > NumLock is operative only for a few minutes after opensuse 12.3
    > installs; then the numbers pad is inoperative. Only the numbers at the
    > top of the keyboard are functional.
    > It happened also with opensuse 12.2 and I expected it to get corrected
    > but it never was.
    > Will it get solved in 12.3?
    > Any suggestions/ideas?


    It works fine here, so it would be useful if you told us what kind of
    hardware you're using and what DE you're using.

    I use the numpad all the time on 12.2 here, multiple systems, and it's
    never just "switched off" never to return.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: NUMLock pad is essentially inoperative in opensuse 12.3

    Quote Originally Posted by scnovell View Post
    It happened also with opensuse 12.2 and I expected it to get corrected but it never was.
    If you think this is a bug in openSUSE, have you reported it? The developers can't fix something that's never mentioned to them, and they aren't psychics.

    https://en.opensuse.org/Bugzilla

    Jim's probably right though, no one else has mentioned this before. Have you tested a different keyboard to see if that's the source of the problem? What DE are you using?

  4. #4
    Join Date
    Jun 2008
    Location
    Stone Mountain, GA, USA
    Posts
    29

    Default Re: NUMLock pad is essentially inoperative in opensuse 12.3

    NUMLock working as designed here too.
    openSUSE 12.3 <-- (did that w/NUMLock)
    KDE

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,640
    Blog Entries
    3

    Default Re: NUMLock pad is essentially inoperative in opensuse 12.3

    Quote Originally Posted by scnovell View Post
    NumLock is operative only for a few minutes after opensuse 12.3 installs; then the numbers pad is inoperative.
    I did have to set KDE to turn on NumLock at KDE startup. With that set, it is fine here. I don't know what the equivalent setting is in Gnome.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: NUMLock pad is essentially inoperative in opensuse 12.3

    Quote Originally Posted by nrickert View Post
    I did have to set KDE to turn on NumLock at KDE startup. With that set, it is fine here. I don't know what the equivalent setting is in Gnome.
    on openSUSE 12.3/GNOME we need to open dconf-editor and navigate to org.gnome.settings-daemon.peripherals.keyboard and configure the settings
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  7. #7

    Default Re: NUMLock pad is essentially inoperative in opensuse 12.3

    I will try to answer most of the comments posted.
    Currently I use opensuse 12.3 with 64 bit multicore [6] amd hardware with gnome.

    However, the problem also occurred with opensuse 12.2 with 32 bit hardware and different hardware including keyboard; I think we can eliminate hardware and look toward the opensuse software as the probable culprit].
    I did not report it as a bug as I wasn't sure it was a bug or something I was doing. I still am not sure... but,
    I am interested in the constructive reply provided by Vazhavandan it looks promising but I would never have thought of it as a solution ... where did it come from?

    'on openSUSE 12.3/GNOME we need to open dconf-editor and navigate to org.gnome.settings-daemon.peripherals.keyboard and configure the settings'

    looked for a dconf-editor file - none found!
    then tried open dconf-editor no good; went to
    install dconf-editor which did give some result except the `install requires a number of arguments which did not immediately mean much to me - so rather than blindly plough ahead I'd rather ask for further - help!

    Thanks for input[s]

  8. #8
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,068

    Default Re: NUMLock pad is essentially inoperative in opensuse 12.3

    On Fri, 24 May 2013 22:16:01 +0000, scnovell wrote:

    > looked for a dconf-editor file - none found!


    dconf-editor is a program, you need to install it through YaST or zypper.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,640
    Blog Entries
    3

    Default Re: NUMLock pad is essentially inoperative in opensuse 12.3

    Quote Originally Posted by scnovell View Post
    However, the problem also occurred with opensuse 12.2 with 32 bit hardware and different hardware including keyboard; I think we can eliminate hardware and look toward the opensuse software as the probable culprit.
    I first saw this with 12.2 .

    My own guess is that it is the kernel, and probably affects all distros using the same kernel series.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: NUMLock pad is essentially inoperative in opensuse 12.3

    Quote Originally Posted by scnovell View Post
    I will try to answer most of the comments posted.
    Currently I use opensuse 12.3 with 64 bit multicore [6] amd hardware with gnome.

    However, the problem also occurred with opensuse 12.2 with 32 bit hardware and different hardware including keyboard; I think we can eliminate hardware and look toward the opensuse software as the probable culprit].
    I did not report it as a bug as I wasn't sure it was a bug or something I was doing. I still am not sure... but,
    I am interested in the constructive reply provided by Vazhavandan it looks promising but I would never have thought of it as a solution ... where did it come from?

    'on openSUSE 12.3/GNOME we need to open dconf-editor and navigate to org.gnome.settings-daemon.peripherals.keyboard and configure the settings'

    looked for a dconf-editor file - none found!
    then tried open dconf-editor no good; went to
    install dconf-editor which did give some result except the `install requires a number of arguments which did not immediately mean much to me - so rather than blindly plough ahead I'd rather ask for further - help!

    Thanks for input[s]
    Try left Win key ==> type install ==> invoke YaST installer==>and try this


    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •