Results 1 to 3 of 3

Thread: Trouble updating via zypper

  1. #1
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    254

    Default Trouble updating via zypper

    For the last few days I am seeing trouble running zypper up

    What I see is

    Installing: libgnutls28-3.0.20-1.4.1 ....................................[error]
    Installation of libgnutls28-3.0.20-1.4.1 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: rpmdb: __db_meta_setup: /var/lib/rpm/Obsoletename: unexpected file type or format
    error: cannot open Obsoletename index using db4 - Invalid argument (22)


    Abort, retry, ignore? [a/r/i] (a):

    I presume something is corrupted but what and how do I fix?

  2. #2

    Default Re: Trouble updating via zypper

    Quote Originally Posted by jpff View Post
    I presume something is corrupted but what and how do I fix?
    Try to run:
    Code:
    sudo rpm --rebuilddb

  3. #3
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    254

    Default Re: Trouble updating via zypper

    Thank you; seems to br settled

    Now al I nred is X on 12.3!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •