Servus,

ich habe mir letztens den neuen Nvidia-Beta-Treiber für mein Toshiba Satellite Notebook geholt, weil ich ausprobieren möchte ob die Optimus-Unterstützung endlich funktioniert. Kernel 3.9x ist auch installiert. Der Treiber lässt sich installieren, aber beim Start des X-Servers steigt er mit der Fehlermeldung "no screens found" aus. Ich vermute mal, dass meine xorg.conf irgendwie falsch ist, aber leider fehlt es mir an Erfahrung um zu wissen, wo genau der Fehler liegt.
Die xorg.conf, die nvidia-xconfig erzeugt sieht so aus:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 319.12  (buildmeister@swio-display-x86-rhel47-06)  Wed Apr  3 16:12:29 PDT 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
    
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
und die dazugehörige Xorg-Logdatei sieht so aus:
Code:
[  1970.243] 
X.Org X Server 1.13.2
Release Date: 2013-01-24
[  1970.243] X Protocol Version 11, Revision 0
[  1970.243] Build Operating System: openSUSE SUSE LINUX
[  1970.243] Current Operating System: Linux linux-wuo0.site 3.9.2-1.g04040b9-desktop #1 SMP PREEMPT Sun May 12 14:53:56 UTC 2013 (04040b9) x86_64
[  1970.243] Kernel command line: BOOT_IMAGE=/vmlinuz-3.9.2-1.g04040b9-desktop root=/dev/mapper/LVM_Gruppe-root resume=/dev/LVM_Gruppe/swap splash=silent quiet showopts acpi=copy_dsdt acpi-osi=Linux
[  1970.243] Build Date: 30 April 2013  08:24:17AM
[  1970.243]  
[  1970.243] Current version of pixman: 0.28.2
[  1970.243]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[  1970.243] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1970.244] (==) Log file: "/var/log/Xorg.1.log", Time: Wed May 15 13:43:06 2013
[  1970.244] (==) Using config file: "/etc/X11/xorg.conf"
[  1970.244] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  1970.244] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1970.244] (==) ServerLayout "Layout0"
[  1970.244] (**) |-->Screen "Screen0" (0)
[  1970.244] (**) |   |-->Monitor "Monitor0"
[  1970.244] (**) |   |-->Device "Device0"
[  1970.244] (**) |-->Input Device "Keyboard0"
[  1970.244] (**) |-->Input Device "Mouse0"
[  1970.244] (==) Automatically adding devices
[  1970.244] (==) Automatically enabling devices
[  1970.244] (==) Automatically adding GPU devices
[  1970.244] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
[  1970.244]     Entry deleted from font path.
[  1970.244] (==) FontPath set to:
    /usr/share/fonts/misc:unscaled,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/ghostscript/,
    /usr/share/fonts/cyrillic:unscaled,
    /usr/share/fonts/truetype/,
    built-ins
[  1970.244] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
[  1970.244] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1970.244] (WW) Disabling Keyboard0
[  1970.244] (WW) Disabling Mouse0
[  1970.245] (II) Loader magic: 0x801c20
[  1970.245] (II) Module ABI versions:
[  1970.245]     X.Org ANSI C Emulation: 0.4
[  1970.245]     X.Org Video Driver: 13.1
[  1970.245]     X.Org XInput driver : 18.0
[  1970.245]     X.Org Server Extension : 7.0
[  1970.245] (II) config/udev: Adding drm device (/dev/dri/card1)
[  1970.245] setversion 1.4 failed
[  1970.245] (II) config/udev: Adding drm device (/dev/dri/card0)
[  1970.245] setversion 1.4 failed
[  1970.246] (--) PCI:*(0:0:2:0) 8086:0116:1179:fc01 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[  1970.246] (--) PCI: (0:1:0:0) 10de:0df4:1179:fc01 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[  1970.247] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  1970.247] Initializing built-in extension Generic Event Extension
[  1970.247] Initializing built-in extension SHAPE
[  1970.247] Initializing built-in extension MIT-SHM
[  1970.247] Initializing built-in extension XInputExtension
[  1970.247] Initializing built-in extension XTEST
[  1970.247] Initializing built-in extension BIG-REQUESTS
[  1970.247] Initializing built-in extension SYNC
[  1970.247] Initializing built-in extension XKEYBOARD
[  1970.247] Initializing built-in extension XC-MISC
[  1970.247] Initializing built-in extension SECURITY
[  1970.247] Initializing built-in extension XINERAMA
[  1970.247] Initializing built-in extension XFIXES
[  1970.247] Initializing built-in extension RENDER
[  1970.247] Initializing built-in extension RANDR
[  1970.247] Initializing built-in extension COMPOSITE
[  1970.247] Initializing built-in extension DAMAGE
[  1970.247] Initializing built-in extension MIT-SCREEN-SAVER
[  1970.247] Initializing built-in extension DOUBLE-BUFFER
[  1970.247] Initializing built-in extension RECORD
[  1970.247] Initializing built-in extension DPMS
[  1970.247] Initializing built-in extension X-Resource
[  1970.247] Initializing built-in extension XVideo
[  1970.247] Initializing built-in extension XVideo-MotionCompensation
[  1970.247] Initializing built-in extension XFree86-VidModeExtension
[  1970.247] Initializing built-in extension XFree86-DGA
[  1970.247] Initializing built-in extension XFree86-DRI
[  1970.247] Initializing built-in extension DRI2
[  1970.247] (II) "glx" will be loaded by default.
[  1970.247] (II) LoadModule: "dri2"
[  1970.247] (II) Module "dri2" already built-in
[  1970.247] (II) LoadModule: "glamoregl"
[  1970.247] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
[  1970.257] (EE) Failed to load /usr/lib64/xorg/modules/libglamoregl.so: /usr/lib64/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
[  1970.257] (II) UnloadModule: "glamoregl"
[  1970.257] (II) Unloading glamoregl
[  1970.257] (EE) Failed to load module "glamoregl" (loader failed, 7)
[  1970.257] (II) LoadModule: "glx"
[  1970.257] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  1970.267] (II) Module glx: vendor="NVIDIA Corporation"
[  1970.267]     compiled for 4.0.2, module version = 1.0.0
[  1970.267]     Module class: X.Org Server Extension
[  1970.267] (II) NVIDIA GLX Module  319.12  Wed Apr  3 15:25:32 PDT 2013
[  1970.267] Loading extension GLX
[  1970.267] (II) LoadModule: "nvidia"
[  1970.267] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  1970.268] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1970.268]     compiled for 4.0.2, module version = 1.0.0
[  1970.268]     Module class: X.Org Video Driver
[  1970.268] (II) NVIDIA dlloader X Driver  319.12  Wed Apr  3 15:07:08 PDT 2013
[  1970.268] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1970.268] (--) using VT number 3

[  1970.421] (EE) No devices detected.
[  1970.421] 
Fatal server error:
[  1970.421] no screens found
[  1970.421] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[  1970.421] (EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[  1970.421] (EE)
Leider werde ich daraus nicht ganz schlau, und die meisten thematisch verwandten Forenposts beziehen sich auf bumblebee, welches mich aber in diesem Fall explizit nicht interessiert.
Kann mir jemand bisschen weiterhelfen?

Vielen Dank schonmal und schöne Grüße!