Results 1 to 3 of 3

Thread: Disabled daemons still start

  1. #1

    Default Disabled daemons still start

    Hi all,

    I have a weird issue with openSUSE 12.3 X64. I just moved back to SUSE after a few years using mainly Ubuntu. So far, I'm enjoying most of it, but on one system I have a weird issue
    I have a Dell XPS system that I just installed. Install went fine, but I always install some packages that I don't want to use right away, so I disable them after install, as well as some default packages I don't want to run

    Specifically:
    - rpcbind
    - cyrus
    - openldap
    - avahi-daemon
    - nscd (as I run a bind server)

    I did this previously without issue, but on the Dell box, all the above services start after every reboot despite the fact that I've done everything I can think of to disable them. I used Yast to edit the runlevels and disable them. They started after that. I manually checked all rcX.d links and removed any links relating to the above programs (insserv -r, then another manual check), so they are definitely NOT starting from rc5.d.
    So I figured that somehow the new systemd must start them (even though cyrus isn't a systemctl service). So I went and disabled them all with systemctl disable
    And yet: they still start up after every reboot.

    Checking with systemctl:

    # systemctl is-enabled rpcbind.servicedisabled


    So it appears they are set to disabled. And yet, they keep starting. Except for avahi-daemon: somehow, I did manage to disable that. The others, not so much, they start every time
    Any ideas?

    thanks
    Stefan

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Disabled daemons still start

    Quote Originally Posted by Bhawks_2 View Post
    Hi all,

    I have a weird issue with openSUSE 12.3 X64. I just moved back to SUSE after a few years using mainly Ubuntu. So far, I'm enjoying most of it, but on one system I have a weird issue
    I have a Dell XPS system that I just installed. Install went fine, but I always install some packages that I don't want to use right away, so I disable them after install, as well as some default packages I don't want to run

    Specifically:
    - rpcbind
    - cyrus
    - openldap
    - avahi-daemon
    - nscd (as I run a bind server)

    I did this previously without issue, but on the Dell box, all the above services start after every reboot despite the fact that I've done everything I can think of to disable them. I used Yast to edit the runlevels and disable them. They started after that. I manually checked all rcX.d links and removed any links relating to the above programs (insserv -r, then another manual check), so they are definitely NOT starting from rc5.d.
    So I figured that somehow the new systemd must start them (even though cyrus isn't a systemctl service). So I went and disabled them all with systemctl disable
    And yet: they still start up after every reboot.

    Checking with systemctl:

    # systemctl is-enabled rpcbind.servicedisabled


    So it appears they are set to disabled. And yet, they keep starting. Except for avahi-daemon: somehow, I did manage to disable that. The others, not so much, they start every time
    Any ideas?

    thanks
    Stefan
    Sounds to me its time to lean how to use systemd. Once an application is moved over to a service file, you must use systemd to set their operation. Here are a few programs for your systemd pleasure and example:

    SysdCmd - systemd Command Help/Config Editor - Blogs - openSUSE Forums

    systemd and using the after.local script in openSUSE 12.3 - Blogs - openSUSE Forums

    DKMS & systemd - How to get Dynamic Kernel Module Support to work in openSUSE 12.3 - Blogs - openSUSE Forums

    Thank You,
    Last edited by jdmcdaniel3; 14-May-2013 at 18:11.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Disabled daemons still start

    On 2013-05-15 00:56, Bhawks 2 wrote:

    > disable them after install, as well as some default packages I don't
    > want to run
    >
    > Specifically:
    > - rpcbind
    > - cyrus
    > - openldap
    > - avahi-daemon
    > - nscd (as I run a bind server)


    nscd, despite the name, doesn't cache the same things as bind, they
    complement.


    > I did this previously without issue, but on the Dell box, all the above
    > services start after every reboot despite the fact that I've done
    > everything I can think of to disable them. I used Yast to edit the
    > runlevels and disable them.


    YaST runlevel editor in 12.3 is known to be broken.

    > They started after that. I manually checked
    > all rcX.d links and removed any links relating to the above programs


    The symlinks are ignored. If you read the openSUSE manual of a version
    when systemv was used, the symlinks were ignored for service startup:
    instead a series of Makefile like files (.depend.*) in that directory
    were used.

    insserve might work, but as 12.3 uses systemd, then it will probably not
    work. chkconfig might work.

    Or you can try "systemadm" - you have to install "systemd-ui".

    I see jdmcdaniel3 has given you some reading material :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •