Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Updates: Needed vs All

  1. #1
    Join Date
    Jan 2013
    Location
    Brazil
    Posts
    327

    Default Updates: Needed vs All

    Hi.

    On Ubuntu there were some updates that even being there they weren't recommended to install, because some of them may conflict with other software (for being new). While on openSUSE, there are "Needed patches" and "All patches" I'd like to know if installing all of them may cause conflicts. This may sound like a noob question but tell me your experiences with all patches.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Updates: Needed vs All

    On 2013-05-06 23:36, amarildojr wrote:
    >
    > Hi.
    >
    > On Ubuntu there were some updates that even being there they weren't
    > recommended to install, because some of them may conflict with other
    > software (for being new). While on openSUSE, there are "Needed patches"
    > and "All patches" I'd like to know if installing all of them may cause
    > conflicts. This may sound like a noob question but tell me your
    > experiences with all patches.


    I assume you are using YOU, aka YaST Online Update. In this situation,
    all updates (patches) are considered safe. Some are necessary, some
    optional.

    Notice that in openSUSE parlance "patches" are not the same as
    "updates". Currently patches applied by YOU come only from the update
    repository, which is one of the official repositories, and very
    carefully maintained.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  3. #3
    Join Date
    Jan 2013
    Location
    Brazil
    Posts
    327

    Default Re: Updates: Needed vs All

    Thanks Carlos! I feel a lot better now

  4. #4
    Join Date
    Jan 2013
    Location
    Brazil
    Posts
    327

    Default Re: Updates: Needed vs All

    Just tried installing all (All in this list -> install). Yast2 closes itself.
    Any help?

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Updates: Needed vs All

    On 2013-05-07 01:16, amarildojr wrote:
    >
    > Just tried installing all (All in this list -> install). Yast2 closes
    > itself.


    I'm not sure I understand what you did... with YOU, you only need to
    press "OK".

    Let me try ... oh, my! :-(


    No, don't do that. Just use the "needed patches" and "accept". The
    patches that are not selected for installation are that way because you
    do not have those packages installed, so don't install "all patches".


    I thought that what you had seen was a different category that sometimes
    appears in the list.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  6. #6
    Join Date
    Jan 2013
    Location
    Brazil
    Posts
    327

    Default Re: Updates: Needed vs All

    out1 - YouTube


    Very low quality (not a good recording software) so select 720p

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,754
    Blog Entries
    3

    Default Re: Updates: Needed vs All

    I'm just going by your video.

    It looks to me as if needed patches are the patches to software that you have installed.

    When you select "all" it is showing the patch that exist, even if you have not installed the software that is being patched. However, only the ones where you have the software installed are showing up as checked.

    I'm not sure if it makes sense to check a patch for something not installed. If that works, then the software would have to be installed and then patched. But I suppose it makes sense to show the list. There might be a package that you want, but you don't want it until a known problem is fixed. This would give you some information about such packages.

    The above is partly guessing.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8
    Join Date
    Jan 2013
    Location
    Brazil
    Posts
    327

    Default Re: Updates: Needed vs All

    I tested it again by clicking at only one (unmarked) update and it also happens. I'll do a fresh install and update everything from there.

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Updates: Needed vs All

    On 2013-05-07 03:46, amarildojr wrote:
    >
    > I tested it again by clicking at only one (unmarked) update and it also
    > happens. I'll do a fresh install and update everything from there.


    You only need to use everything at the defaults, touch nothing!

    Just leave the selection filter as "needed patches" and accept.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  10. #10
    Join Date
    Jan 2013
    Location
    Brazil
    Posts
    327

    Default Re: Updates: Needed vs All

    Quote Originally Posted by robin_listas View Post
    On 2013-05-07 03:46, amarildojr wrote:
    >
    > I tested it again by clicking at only one (unmarked) update and it also
    > happens. I'll do a fresh install and update everything from there.


    You only need to use everything at the defaults, touch nothing!

    Just leave the selection filter as "needed patches" and accept.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)
    So, before they were safe and now I can't install them?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •