Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: WOL Wake on Lan

  1. #1

    Default WOL Wake on Lan

    Hello,

    I'm sorry if this has been answered already but I have been looking and cannot figure it out. I am trying to get my Ethernet port to stay powered up after I shutdown my computer. I had no issue with this when I was using opensuse 12.2 but when I update to opensuse 12.3 it powers off after shutdown. I have run the command ethtool -s Eth0 -wol g but it did not resolve the problem. Any help would be appreciated.

    Thanks,

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,366

    Default Re: WOL Wake on Lan

    On Sat, 04 May 2013 04:06:03 +0000, DanB1983 wrote:

    > Hello,
    >
    > I'm sorry if this has been answered already but I have been looking and
    > cannot figure it out. I am trying to get my Ethernet port to stay
    > powered up after I shutdown my computer. I had no issue with this when
    > I was using opensuse 12.2 but when I update to opensuse 12.3 it powers
    > off after shutdown. I have run the command ethtool -s Eth0 -wol g but
    > it did not resolve the problem. Any help would be appreciated.


    There's usually a BIOS setting that needs to be enabled as well - if it's
    not staying on after you shut down, that's outside the control of the OS,
    so that's where I'd start looking.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Oct 2011
    Location
    Germany (Ore Mountains)
    Posts
    461

    Default Re: WOL Wake on Lan

    If he is using 12.3 at the same hardware then 12.2 it is no BIOS issue.
    I had the same problem some time ago with an older PC. Eventually I found out, that it was a new kernel "feature". At some point in time the kernel devs decided, that some peaces of network hardware did not behave well to the power management specifications; and to avoid problems arising sometimes from this misbehavior they disabled some capabilities (among them WOL) for this hardware. So starting with a certain kernel version WOL did not work any more on my hardware. The only solutions for me were: Use an old kernel or by new hardware.
    With more information about the hardware, especially the network chip, this could be investigated.

    Hendrik

  4. #4

    Default Re: WOL Wake on Lan

    I have an ASUS G74SX-RH71 laptop.

    here is the information hwinfo gave me:
    77: None 00.0: 10701 Ethernet
    [Created at net.124]
    Unique ID: usDW.ndpeucax6V1
    Parent ID: rBUF.dptbeTZujz1
    SysFS ID: /class/net/eth0
    SysFS Device Link: /devices/pci0000:00/0000:00:1c.5/0000:05:00.0
    Hardware Class: network interface
    Model: "Ethernet network interface"
    Driver: "r8169"
    Driver Modules: "r8169"
    Device File: eth0
    HW Address: 14:da:e9:bd:1b:42
    Link detected: yes
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #35 (Ethernet controller)

    lspci:
    05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)

  5. #5
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: WOL Wake on Lan

    On 05/04/2013 07:16 AM, hendwolt wrote:
    >
    > If he is using 12.3 at the same hardware then 12.2 it is no BIOS issue.
    > I had the same problem some time ago with an older PC. Eventually I
    > found out, that it was a new kernel "feature". At some point in time the
    > kernel devs decided, that some peaces of network hardware did not behave
    > well to the power management specifications; and to avoid problems
    > arising sometimes from this misbehavior they disabled some capabilities
    > (among them WOL) for this hardware. So starting with a certain kernel
    > version WOL did not work any more on my hardware. The only solutions for
    > me were: Use an old kernel or by new hardware.
    > With more information about the hardware, especially the network chip,
    > this could be investigated.


    Please reference this "decision" the the kernel devs made.



  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,366

    Default Re: WOL Wake on Lan

    On Sat, 04 May 2013 12:16:02 +0000, hendwolt wrote:

    > If he is using 12.3 at the same hardware then 12.2 it is no BIOS issue.


    Good point, I missed that part of the OP's message somehow.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  7. #7

    Default Re: WOL Wake on Lan

    Just to verify, did you ensure ethtool reported Wake-on: g (at least) after configuring?

    It might be worth also ruling out any network issues (just to be sure): if you run tcpdump upd port 9 to verify there is nothing preventing the packet from being generated and arriving (you never know, and it doesn't hurt to check.)

    Newer NICS actually retain the IP from a DHCP lease when powered off, so you can try using the unicast address and MAC in addition to the multicast address. (I was amazed to learn this recently, and yep - it really does work.)

    I'd be very interesting to hear if the interface shows Wake-on: g and the packet has been verified to arrive, and if it still does not respond to either unicast or multicast addresses. That would be weird indeed.

  8. #8

    Default Re: WOL Wake on Lan

    According to ethtools WOL is set to g. The other day i had to perform a hard power down and the ethernet port stayed active after the machine was powered off.

  9. #9
    Join Date
    Oct 2011
    Location
    Germany (Ore Mountains)
    Posts
    461

    Default Re: WOL Wake on Lan

    Quote Originally Posted by lwfinger View Post
    On 05/04/2013 07:16 AM, hendwolt wrote:
    >
    >

    Please reference this "decision" the the kernel devs made.
    Hard to do, because I've had these problems 2 years ago (or so) and I did not bookmark the webpage(s), where I found this information.

    So after googling a lot, without any guaranties, it might be this one:

    https://git.kernel.org/cgit/linux/ke...ec550c13b8fe72

    Hendrik

  10. #10

    Default Re: WOL Wake on Lan

    Quote Originally Posted by DanB1983 View Post
    According to ethtools WOL is set to g. The other day i had to perform a hard power down and the ethernet port stayed active after the machine was powered off.
    Though it might seem silly (as you know it worked previously) but could you run #tcpdump udp port 9 and send the wake on lan magic packet to the system, just to be absolutely certain the packet is arriving as expected? Otherwise, all your troubleshooting is for naught.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •