Results 1 to 3 of 3

Thread: MySQL doesn't want to start with systemd

  1. #1

    Default MySQL doesn't want to start with systemd

    Greetings!

    Since I just reconfigured my server from openSuSE 11.4 to 12.2 (a fresh install), and now MySQL refuses to start up.
    The system boots up with systemd as its init process, and for some reason the necessary unit files to start MySQL are not present. Any recommendations on what to do now?
    Switching back to System V init should be the last option to do - so the question is how I have to set up the unit file necessary for launching MySQL...

    I had backed up all relevant directories beforehand and replayed everything so resuming normal operation should be possible...

  2. #2

    Default Re: MySQL doesn't want to start with systemd

    Quote Originally Posted by Robidu View Post
    Greetings!

    Since I just reconfigured my server from openSuSE 11.4 to 12.2 (a fresh install), and now MySQL refuses to start up.
    The system boots up with systemd as its init process, and for some reason the necessary unit files to start MySQL are not present. Any recommendations on what to do now?
    Switching back to System V init should be the last option to do - so the question is how I have to set up the unit file necessary for launching MySQL...

    I had backed up all relevant directories beforehand and replayed everything so resuming normal operation should be possible...
    How did you install MySQL?
    If you want to use the one included in openSUSE, you have to have the package "mysql-community-server" installed.
    It is true that there is no systemd unit file, but systemd also supports to use the old sysvinit init scripts. (and there are also wrappers for the old sysvinit commands)

    You can start it with
    Code:
    sudo systemctl start mysql
    or
    Code:
    sudo /etc/init.d/mysql start
    To make it start on every boot you would type:
    Code:
    sudo systemctl enable mysql
    or
    Code:
    sudo chkconfig mysql on
    You could also use YaST->System Services (Runlevels) for that

  3. #3

    Default Re: MySQL doesn't want to start with systemd

    Thanks for the info.
    I just don't know why, but all the sudden launching MySQL worked (I don't know what could have gone on there before, but somehow the problem seems to have fixed itself... *boggle*)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •