Results 1 to 7 of 7

Thread: "Type password for /home" only shows text

  1. #1
    Join Date
    Jan 2013
    Location
    Brazil
    Posts
    327

    Default "Type password for /home" only shows text

    I was having problems with my Nvidia Drivers, the error was:

    OpenGL GLX Context is not using direct rendering, which may cause performance problems.

    For more information visit https://support.steampowered.com/kb_...9938-EYZB-7457

    PIC: http://img850.imageshack.us/img850/4550/snapshot1ct.png
    --------------------------------------------------

    In an act of desperate I tested 3 commands (found HERE):

    nvidia-xconfig --composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24
    ---------------------------------------------------

    It fixed the problem, now I can run Steam and it's games but something weird happened: at that "/home decryption screen" where it asks for the encrypted password, that screen is gone and only texts are shown. Also, the panel was smaller.

    What went wrong?

  2. #2

    Default AW: "Type password for /home" only shows text

    Quote Originally Posted by amarildojr View Post
    I was having problems with my Nvidia Drivers, the error was:


    OpenGL GLX Context is not using direct rendering, which may cause performance problems.


    For more information visit https://support.steampowered.com/kb_...9938-EYZB-7457


    PIC: http://img850.imageshack.us/img850/4550/snapshot1ct.png
    --------------------------------------------------


    In an act of desperate I tested 3 commands (found HERE):


    nvidia-xconfig --composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24
    ---------------------------------------------------


    It fixed the problem, now I can run Steam and it's games but something weird happened: at that "/home decryption screen" where it asks for the encrypted password, that screen is gone and only texts are shown. Also, the panel was smaller.


    What went wrong?
    To fix your driver problem, you should add your user to the "video" group, see https://www.suse.com/releasenotes/i3...#idm1261534012


    I think those nvidia-xconfig commands have created a file named /etc/X11/xorg.conf, try to rename that so it isn't found and see if your decryption screen is ok again then.

  3. #3
    Join Date
    Jan 2013
    Location
    Brazil
    Posts
    327

    Default Re: "Type password for /home" only shows text

    Strangely enough the decrypt screen got back to normal. It didn't at 1st reboot after the commands, I didn't think it would after 2 reboots. For the smaller panel all I had to do was remove it and add a new one.

  4. #4
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: "Type password for /home" only shows text

    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  5. #5

    Default Re: "Type password for /home" only shows text

    Quote Originally Posted by amarildojr View Post
    For the smaller panel all I had to do was remove it and add a new one.
    Well, you could have just resized it...
    Click on the symbol on the far right, click on "Height" and drag to the desired size.

    And you should follow my advice in the previous post. Your workaround with those nvidia-xconfig commands shouldn't be necessary I think.

  6. #6
    Join Date
    Jan 2013
    Location
    Brazil
    Posts
    327

    Default Re: "Type password for /home" only shows text

    Quote Originally Posted by vazhavandan View Post
    Yes it is, I'm sorry. I dont have much time so I'd kill myself waiting there.
    Quote Originally Posted by wolfi323 View Post
    Well, you could have just resized it...
    Click on the symbol on the far right, click on "Height" and drag to the desired size.

    And you should follow my advice in the previous post. Your workaround with those nvidia-xconfig commands shouldn't be necessary I think.
    I did resize it, it just wasn't as perfect as the original one, I wanted to know why that happened.

    Also, it was necessary, maybe not all of them, but they were. Otherwise I wouldn't be able to play TF2, it'd give me an error like "the OpenGL version is not supported by you graphics card" which is obviously not true. I THINK it didn't mess any thing as bad as I thought.

  7. #7

    Default Re: "Type password for /home" only shows text

    Quote Originally Posted by amarildojr View Post
    Also, it was necessary, maybe not all of them, but they were. Otherwise I wouldn't be able to play TF2, it'd give me an error like "the OpenGL version is not supported by you graphics card" which is obviously not true.
    According to your screenshot the error msg is "OpenGL GLX context is not using direct rendering, which may cause performance problems."

    And the right fix for this would be to add your user to the "video" group, as I wrote earlier... You should do that anyway, it's needed for the nvidia driver to work properly (especially 3D).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •