I checked the panel settings->more option->use "always visible", however it has the effect of using "panel above windows", as the edge of the windows is covered by the panel when the windows are maximized.

So at the moment panel option "always visible" equals to "panel above windows"

So is this bug from 2009 solved or not :https://bugs.kde.org/show_bug.cgi?id=199257

Yes I have an HDMI plugged in my laptop.