Results 1 to 3 of 3

Thread: something wrong with repositories

  1. #1

    Lightbulb something wrong with repositories

    hi guys. this is what i get when i try to update

    Code:
    linux-oybs:/home/shahalam # zypper update
    Loading repository data...
    Reading installed packages...
    
    
    The following package updates will NOT be installed:
      gstreamer gstreamer-0_10 gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugins-bad-lang gstreamer-0_10-plugins-base gstreamer-plugins-bad 
      gstreamer-plugins-base gstreamer-plugins-good gstreamer-utils k3b libgstapp-0_10-0 libgstapp-1_0-0 libgstaudio-1_0-0 
      libgstbasecamerabinsrc-0_10-23 libgstbasecamerabinsrc-1_0-0 libgstbasevideo-0_10-23 libgstcodecparsers-0_10-23 libgstcodecparsers-1_0-0 
      libgstfft-1_0-0 libgstinterfaces-0_10-0 libgstpbutils-1_0-0 libgstphotography-0_10-23 libgstphotography-1_0-0 libgstreamer-0_10-0 
      libgstreamer-1_0-0 libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0 libgstsignalprocessor-0_10-23 libgsttag-1_0-0 
      libgstvdp-0_10-23 libgstvideo-1_0-0 libquicktime0 libquvi-scripts libxine2-pulse mjpegtools python-gstreamer-0_10 typelib-1_0-Gst-0_10 
      typelib-1_0-Gst-1_0 typelib-1_0-GstAudio-1_0 typelib-1_0-GstInterfaces-0_10 typelib-1_0-GstPbutils-1_0 typelib-1_0-GstTag-1_0 
      typelib-1_0-GstVideo-1_0 
    
    
    Nothing to do.
    my repositories are
    Code:
    linux-oybs:/home/shahalam # zypper lr -d
    #  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                                           | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------------------+--------
     1 | ftp.gwdg.de-suse          | Packman Repository                 | Yes     | Yes     |   99     | rpm-md |http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_12.3//suse/openSUSE_12.3                                      |        
     2 | openSUSE-12.3-1.7         | openSUSE-12.3-1.7                  | No      | No      |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-Kingston_DataTraveler_G3_0019E06B4A06BA91074A0009-0:0-part2 |        
     3 | opensuse-guide.org-repo   | libdvdcss repository               | No      | No      |   99     | rpm-md | http://opensuse-guide.org/repo/12.3/                                                          |        
     4 | repo-debug                | openSUSE-12.3-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.3/repo/oss/                                |        
     5 | repo-debug-update         | openSUSE-12.3-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.3/                                               |        
     6 | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/12.3-non-oss/                                       |        
     7 | repo-non-oss              | openSUSE-12.3-Non-Oss              | No      | No      |   99     | yast2  | http://download.opensuse.org/distribution/12.3/repo/non-oss/                                  |        
     8 | repo-oss                  | openSUSE-12.3-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.3/repo/oss/                                      |        
     9 | repo-source               | openSUSE-12.3-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/12.3/repo/oss/                               |        
    10 | repo-update               | openSUSE-12.3-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.3/                                                     |        
    11 | repo-update-non-oss       | openSUSE-12.3-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.3-non-oss/                                             |
    is there anything i need to disable or enable ?
    Last edited by oldcpu; 25-Apr-2013 at 22:28. Reason: Added [ code ] and [ /code ] tags to make text easier to read

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: something wrong with repositories

    It looks fine and that behaviour is normal if you followed the multimedia guide and switch to Packman
    https://dl.dropboxusercontent.com/u/...ckman_12.2.jpg
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,050

    Default Re: something wrong with repositories

    On Fri, 26 Apr 2013 05:16:05 +0000, mdshahalam3 wrote:

    > is there anything i need to disable or enable ?


    Nope, and there's nothing wrong with the repos, either.

    If you run YaST software installation, you can override these blocked
    updates, but as caf said, they're blocked for a reason. Zypper is
    telling you there are newer versions but because of selections you've
    made, these updates aren't being installed because they would contradict
    the choices you made when enabling the multimedia stuff.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •