Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Can't load Digikam photo editor after upgrading to Gnome 3.8.1

  1. #1

    Default Can't load Digikam photo editor after upgrading to Gnome 3.8.1

    I am running openSUSE 12.3 and Gnome 3.8 (upgrade). I can no longer run the Digikam photo editor. I realise this application comes out of the KDE environment and it usually install fine after loading the KDE elements it needs.
    I really love this app as it is a very comprehensive photo editor (one of the best I've used) and I wish it was also developed for the Gnome desktop (hint, hint). The
    I've tried removing the Digikam package with YAST and reinstalling it. I've also tried reinstalling it using an RPM. I always end up with the same error. It's seems something in one of the libraries is missing.

    This is the error I get.

    Executable: digikam PID: 7898 Signal: Segmentation fault (11)

    I'm including the developer information in the hope that this will point to the problem. I


    Application: digiKam (digikam), signal: Segmentation fault
    Using host libthread_db library "/lib64/libthread_db.so.1".
    [Current thread is 1 (Thread 0x7fc332456800 (LWP 7898))]

    Thread 3 (Thread 0x7fc3099c3700 (LWP 7901)):
    #0 0x00007fc329d45964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
    #1 0x00007fc32d85f62b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
    #2 0x00000000005d4338 in ?? ()
    #3 0x00007fc32d85f0cc in ?? () from /usr/lib64/libQtCore.so.4
    #4 0x00007fc32085f764 in ?? () from /usr/X11R6/lib64/libGL.so.1
    #5 0x00007fc329d41e0f in start_thread () from /lib64/libpthread.so.0
    #6 0x00007fc32bdc97dd in clone () from /lib64/libc.so.6

    Thread 2 (Thread 0x7fc3091c2700 (LWP 7902)):
    #0 0x00007fc32384a269 in ?? () from /usr/lib64/libglib-2.0.so.0
    #1 0x00007fc32384a4d9 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
    #2 0x00007fc32380aaba in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
    #3 0x00007fc32380af15 in ?? () from /usr/lib64/libglib-2.0.so.0
    #4 0x00007fc32380b0a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
    #5 0x00007fc32d9891f6 in QEventDispatcherGlib:: processEvents(QFlags<QEventLoop:: processEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #6 0x00007fc32d9599ef in QEventLoop:: processEvents(QFlags<QEventLoop:: processEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #7 0x00007fc32d959c78 in QEventLoop::exec(QFlags<QEventLoop:: processEventsFlag>) () from /usr/lib64/libQtCore.so.4
    #8 0x00007fc32d85c0f0 in QThread::exec() () from /usr/lib64/libQtCore.so.4
    #9 0x00007fc32d93a1af in ?? () from /usr/lib64/libQtCore.so.4
    #10 0x00007fc32d85f0cc in ?? () from /usr/lib64/libQtCore.so.4
    #11 0x00007fc32085f764 in ?? () from /usr/X11R6/lib64/libGL.so.1
    #12 0x00007fc329d41e0f in start_thread () from /lib64/libpthread.so.0
    #13 0x00007fc32bdc97dd in clone () from /lib64/libc.so.6

    Thread 1 (Thread 0x7fc332456800 (LWP 7898)):
    [KCrash Handler]
    #4 0x00007fc32bd6ef6a in strchrnul () from /lib64/libc.so.6
    #5 0x00007fc32bd27c6d in vfprintf () from /lib64/libc.so.6
    #6 0x00007fc32bddc9f0 in __vsnprintf_chk () from /lib64/libc.so.6
    #7 0x00007fc327deda58 in cmsSignalError () from /usr/lib64/liblcms2.so.2
    #8 0x00007fc3269eb7ad in _cmsSearchTag () from /usr/lib64/liblcms.so.1
    #9 0x00007fc3269f10d0 in cmsReadICCTextEx () from /usr/lib64/liblcms.so.1
    #10 0x00007fc3269f1f36 in cmsTakeProductDesc () from /usr/lib64/liblcms.so.1
    #11 0x00007fc32fb68625 in Digikam::IccProfile::description() () from /usr/lib64/libdigikamcore.so.3
    #12 0x00007fc32fb74f25 in Digikam::IccSettings::loadAllProfilesProperties() () from /usr/lib64/libdigikamcore.so.3
    #13 0x0000000000598d52 in ?? ()
    #14 0x00000000004987c1 in ?? ()
    #15 0x00007fc32bd02a15 in __libc_start_main () from /lib64/libc.so.6
    #16 0x000000000049a96d in _start ()

  2. #2

    Default Re: Can't load Digikam photo editor after upgrading to Gnome 3.8.1

    This is related to the latest KDE update:
    https://bugzilla.novell.com/show_bug.cgi?id=816693

    An online update for digikam is in the works.
    If you can't wait for that, you could install digikam from the Update-Test repo

  3. #3
    Join Date
    Apr 2011
    Posts
    19

    Default Re: Can't load Digikam photo editor after upgrading to Gnome 3.8.1

    I upgraded to the version in the test repo and it is working very well. Thanks a lot guys.

  4. #4

    Default Re: Can't load Digikam photo editor after upgrading to Gnome 3.8.1

    For me downgrading libkdcraw (and digikam) worked.

  5. #5
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,153

    Default Re: Can't load Digikam photo editor after upgrading to Gnome 3.8.1

    The problem is that a recent 12.3 update included a partial update from KDE-4.10.0 to KDE-4.10.2, which omitted digikam. KDE users who used the current release version of KDE from ../repositories/KDE:/Release:/410/openSUSE_12.3/ would already have digikam-3.1.0, and not have suffered the digikam failure. My recommendation would be to add the Release repository rather than taking a single rpm from Test.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  6. #6

    Default AW: Re: Can't load Digikam photo editor after upgrading to Gnome 3.8.1

    Quote Originally Posted by eng-int View Post
    My recommendation would be to add the Release repository rather than taking a single rpm from Test.
    Of course you should install all the digikam packages from the update test repo.
    But they will be released as online update in the next days anyway...

  7. #7
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,153

    Default Re: AW: Re: Can't load Digikam photo editor after upgrading to Gnome 3.8.1

    Quote Originally Posted by wolfi323 View Post
    Of course you should install all the digikam packages from the update test repo.
    But they will be released as online update in the next days anyway...
    That's OK if you know that any particular rpm has been tested successfully, and that there are no other missing/broken dependencies. As a general rule I feel that using the Release/Stable repositories is safer advice.

    You never now who is reading this forum. Several times I have given a user a temporary fix to a specific problem from a mobile phone, only to find that this has been circulated around the department as a standard procedure to applied everywhere in all circumstances.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  8. #8

    Default Re: Can't load Digikam photo editor after upgrading to Gnome 3.8.1

    Quote Originally Posted by eng-int View Post
    That's OK if you know that any particular rpm has been tested successfully, and that there are no other missing/broken dependencies. As a general rule I feel that using the Release/Stable repositories is safer advice.

    You never now who is reading this forum. Several times I have given a user a temporary fix to a specific problem from a mobile phone, only to find that this has been circulated around the department as a standard procedure to applied everywhere in all circumstances.
    But using the KDE:Release:410 repo can also lead to problems, especially if you miss to switch some packages to that repo.
    And it is also not "officially supported". See https://en.opensuse.org/KDE_repositories
    This page lists and describes the available KDE repositories and provides links. None of them are officially supported.
    Warning Avoid mixing repositories belonging to different KDE versions/flavours (Stable/Factory/Unstable/...).
    So why would you recommend that?

    Anyway, I only suggested to use packages from the update test repo for this specific case. As you can see in the bugreport, the packages are already tested and known to work. And they're the same packages as in KR410, only compiled against standard openSUSE+updates.
    Also what bigger problem can arise than not being able to run the program at all?

    And in the other thread I also recommended the OP to remove the update test repo again afterwards. So that he doesn't run into troubles with it.
    I want to stress this again here as well.

  9. #9
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Can't load Digikam photo editor after upgrading to Gnome 3.8.1

    How do I upgrade to digikam 3.1?

    3.0 is worthless at this point. I've installed Shotwell which is my favorite Photo program, but I would like to use digikam if I have a working version.

    I'll uninstall digikam and wait to hear back.

    Thanks.

    running 12.3 KDE 64bit.

  10. #10

    Default Re: Can't load Digikam photo editor after upgrading to Gnome 3.8.1

    Quote Originally Posted by vinoman2 View Post
    I'll uninstall digikam and wait to hear back.
    Why would you uninstall it? It doesn't hurt if it is installed, even if you can't use it.

    Quote Originally Posted by vinoman2 View Post
    How do I upgrade to digikam 3.1?
    Just run Konsole (you find it in the "Favorites" tab of the KDE startmenu) or Gnome-Terminal and type in the following:
    Code:
    sudo zypper ar http://download.opensuse.org/update/12.3-test/ testupdate
    sudo zypper in -f digikam-3.1.0
    sudo zypper rr testupdate
    You will be asked for your root password (the same as your user's password on a default install) after the first line.
    After the second line you could be asked for conflict resolution. Just select the option which says "upgrade". If in doubt ask!

    After that, digikam should work fine for you...

    Or wait a few days for the official online update.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •