Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Networkmanager plasmoid icon missing (Opensuse 12.3)

  1. #1

    Default Networkmanager plasmoid icon missing (Opensuse 12.3)

    Greetings.

    After upgrading from opensuse 12.2 --> 12.3 the KDE Networkmanager systray icon gone missing.

    It's just an empty hole.



    While no icon the area is still click-able, so the function as such does work.

    Tried to reinstall the plasmoid-networkmanagement package, but that makes no difference.

    Any ideas ?

    Brgds Jonas

  2. #2
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,500

    Default Re: Networkmanager plasmoid icon missing (Opensuse 12.3)

    @swejis

    the icon mentioned is automatically loaded when Networkmanger is loaded

    my resolution,
    if any plasmoid Networkmanger is installed
    -- delete it
    -- then delete and re-install the Networkmanger
    -- reboot

    the icon should then be visible,
    if not, left mouse click over System Tray, to see if its in-active

    cheers

  3. #3

    Default Re: Networkmanager plasmoid icon missing (Opensuse 12.3)

    You could try to delete the plasma cache. Start Konsole (it's in the Favorites tab of the startmenu) and type in the following:
    Code:
    kquitapp plasma-desktop
    rm -rf /var/tmp/kdecache-$USER/plasma*
    plasma-desktop &

  4. #4

    Default Re: Networkmanager plasmoid icon missing (Opensuse 12.3)

    Quote Originally Posted by wolfi323 View Post
    You could try to delete the plasma cache. Start Konsole (it's in the Favorites tab of the startmenu) and type in the following:
    Code:
    kquitapp plasma-desktop
    rm -rf /var/tmp/kdecache-$USER/plasma*
    plasma-desktop &
    I have the same problem, I tried your solution but it doesn't works, but, the lack of icon was related in mobile broadband connection, while I was connected with mobile broadband I tried to connect also with a wireless connection, the wireless connection failed, but the mobile broadband icon appeared, I don't know if it is due to the failure or to the attempt of wireless connection, but maybe this can helps to solve the issue....
    thanx, ciao, pier :-)

  5. #5

    Default Re: Networkmanager plasmoid icon missing (Opensuse 12.3)

    Quote Originally Posted by pier_andreit View Post
    I have the same problem, I tried your solution but it doesn't works, but, the lack of icon was related in mobile broadband connection, while I was connected with mobile broadband I tried to connect also with a wireless connection, the wireless connection failed, but the mobile broadband icon appeared, I don't know if it is due to the failure or to the attempt of wireless connection, but maybe this can helps to solve the issue....
    thanx, ciao, pier :-)
    So you don't see an icon just for a wireless connection?

    Well, the connection icons are in the file "/usr/share/kde4/apps/desktoptheme/openSUSE/icons/network.svgz" (for the standard openSUSE theme, that is). Please check if you have that file.
    It's in the package "kdebase4-runtime-branding-openSUSE". Do you have that installed? Maybe try to reinstall it.

    You could also try to switch to another desktop-theme in "Configure Desktop"->"Workspace Appearance"->"Desktop Theme" and see if that helps...

  6. #6

    Default Re: Networkmanager plasmoid icon missing (Opensuse 12.3)

    Quote Originally Posted by wolfi323 View Post
    So you don't see an icon just for a wireless connection?
    No, step by step is what happen in the systemtray networkmanager icon :
    I start the laptop with mobile broadband inserted
    a red disk with a diagonal bar icon (no connection),
    click on the no-connection icon and connect with mobile broadband
    no icon in the systemtray
    click on the no-icon and connect to a wireless connection
    a wireless icon appear in systemtray, a popup appear for failure wireless connection
    the mobile broadband icon appear in the systemtray

    thanx, ciao, pier :-)

  7. #7

    Default Re: Networkmanager plasmoid icon missing (Opensuse 12.3)

    Quote Originally Posted by pier_andreit View Post
    click on the no-connection icon and connect with mobile broadband
    no icon in the systemtray
    So you don't have an icon when you're connected with mobile broadband, right?
    Hm, I don't know which icon should be shown in that case (don't have mobile broadband)... Maybe it's missing from the openSUSE theme.
    Did you try changing to another theme as I suggested?

  8. #8

    Default Re: Networkmanager plasmoid icon missing (Opensuse 12.3)

    Quote Originally Posted by wolfi323 View Post
    So you don't have an icon when you're connected with mobile broadband, right?
    no, I have broadband icon connection icon only after the wireless connection failure
    Quote Originally Posted by wolfi323 View Post
    Hm, I don't know which icon should be shown in that case (don't have mobile broadband)...
    it is like a mobile phone... now susepaste doesn't works so I cannot inser an image, I tried also with personalized system trays icons, copying icons in in /home/<yourusername>/.kde4/share/apps/desktoptheme/default/icons/ and going to /home/[<yourusername>/.kde/cache-[ComputerName]
    and removing the file “icon-cache.kcache” and also “plasma_theme_[theme-name].kcache”., but it happens as well
    Quote Originally Posted by wolfi323 View Post
    Maybe it's missing from the openSUSE theme.
    I think not becouse after the wireless failure the icon appear...
    Quote Originally Posted by wolfi323 View Post
    Did you try changing to another theme as I suggested?
    not yet, I will do..
    thanx, ciao, pier

  9. #9

    Default AW: Re: Networkmanager plasmoid icon missing (Opensuse 12.3)

    Quote Originally Posted by pier_andreit View Post
    no, I have broadband icon connection icon only after the wireless connection failure
    OK, I think I understand now...

    But that sounds more like a bug in networkmanager then, I'm afraid.
    So I can't tell you an easy fix. Sorry.

  10. #10
    Join Date
    Feb 2011
    Location
    Zagreb, Croatia
    Posts
    120

    Default Re: Networkmanager plasmoid icon missing (Opensuse 12.3)

    If the icon would indeed miss from default oS theme, it would then fallback to Air/default one, so must be something else then. But, i guess you've concluded that already

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •