Results 1 to 9 of 9

Thread: Refreshing "system sources" and passwords not being remembered

  1. #1
    Join Date
    Jun 2008
    Location
    Illinois, USA
    Posts
    30

    Default Refreshing "system sources" and passwords not being remembered

    This is one of a few quirky things things that my 13.2 64-bit install has started doing over the last couple of weeks, which I can only guess must have had something to do with one of the updates as previously I don't recall seeing this;
    Every morning shortly (but not immediately) after logging in, it pops up with a dialog saying it needs to "refresh system sources" and that it needs my root password to do it - what is this, and what is it doing that it needs root access?

    Also, pretty much none of the "I need the root password" dialogs are remembering my password from session to session even though I haven't checked the "for this session only" box - I seem to remember that once you hit "remember" without the "this session only" checked that dialog should no longer pop up, but it hasn't been working that way lately - is there anything I can do to fix that? Thanks!


  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,973

    Default Re: Refreshing "system sources" and passwords not being remembered

    Quote Originally Posted by Shadoglare View Post
    .......... that my 13.2 64-bit install .......
    You are sure you are talking about openSUSE?
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,763
    Blog Entries
    14

    Default Re: Refreshing "system sources" and passwords not being remembered

    It's not forgetting/remembering that. The session stays valid for a couple of minutes. To be honest: I've never really gotten what the password options are doing. If I use Yast, then exit it, I can reuse it without entering the root password again. If I wait for 15(?) minutes, I'll have to enter the password again.

    I've never bothered about it too much. Entering the root password makes me aware of my changing permissions.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Refreshing "system sources" and passwords not being remembered

    Quote Originally Posted by Knurpht View Post
    It's not forgetting/remembering that. The session stays valid for a couple of minutes. To be honest: I've never really gotten what the password options are doing. If I use Yast, then exit it, I can reuse it without entering the root password again. If I wait for 15(?) minutes, I'll have to enter the password again.
    You are talking about kdesu's dialog.
    The OP is talking about KAuth/PolicyKit's dialog...

    Quote Originally Posted by Shadoglare View Post
    This is one of a few quirky things things that my 13.2 64-bit install has started doing over the last couple of weeks, which I can only guess must have had something to do with one of the updates as previously I don't recall seeing this;
    Every morning shortly (but not immediately) after logging in, it pops up with a dialog saying it needs to "refresh system sources" and that it needs my root password to do it - what is this, and what is it doing that it needs root access?
    It's the update applet, that wants to refresh the software repositories to check for new updates.

    Also, pretty much none of the "I need the root password" dialogs are remembering my password from session to session even though I haven't checked the "for this session only" box - I seem to remember that once you hit "remember" without the "this session only" checked that dialog should no longer pop up, but it hasn't been working that way lately - is there anything I can do to fix that? Thanks!
    This "remember" checkbox (from KAuth/PolicyKit) never really worked... you also seem to remember ksudo's dialog, which you get when you start YaST from the startmenu f.e.

    For KAuth you can change the permissions in "Configure Desktop" (aka. systemsettings)->"Actions Policy".
    The "Refresh system sources" thing you asked about is in org.freedesktop->The PackageKit Project->Refresh system sources.
    On my system the settings are Any:No, Inactive console:No, Active console:Yes, which prevents the password dialog.

    You can also change permissions for other stuff there, f.e. who is allowed to mount drives.
    The meaning of the settings:
    No: not allowed
    Yes: allowed without entering password
    Administrator authentification: user has to enter root password
    Authentication: user has to enter his own password
    for the last 2 also a variation with (retain) is available, which means the password has to be entered only once and is remembered.

    Any means any user, Active console is the locally logged in user and Inactive console are f.e. remotely logged in users.

  5. #5
    Join Date
    Jun 2008
    Location
    Illinois, USA
    Posts
    30

    Default Re: Refreshing "system sources" and passwords not being remembered

    Quote Originally Posted by wolfi323 View Post
    For KAuth you can change the permissions in "Configure Desktop" (aka. systemsettings)->"Actions Policy".
    The "Refresh system sources" thing you asked about is in org.freedesktop->The PackageKit Project->Refresh system sources.
    On my system the settings are Any:No, Inactive console:No, Active console:Yes, which prevents the password dialog.
    Huh. Interestingly, mine is set exactly the same, yet it keeps asking for the root password.

    I may have to tinker with those settings and see if I can come up with a different result.

  6. #6

    Default Re: Refreshing "system sources" and passwords not being remembered

    Quote Originally Posted by Shadoglare View Post
    Huh. Interestingly, mine is set exactly the same, yet it keeps asking for the root password.

    I may have to tinker with those settings and see if I can come up with a different result.
    Well, maybe you're not running in an "Active console"...
    What's the output of:
    Code:
    loginctl
    If your current session isn't listed there, it's not considered to be running on the active console and you would be asked for the root password.

  7. #7
    Join Date
    Jun 2008
    Location
    Illinois, USA
    Posts
    30

    Default Re: Refreshing "system sources" and passwords not being remembered

    Quote Originally Posted by wolfi323 View Post
    What's the output of:
    Code:
    loginctl
    If your current session isn't listed there, it's not considered to be running on the active console and you would be asked for the root password.
    Nope, looks like I'm there:

    Code:
    SESSION        UID USER             SEAT            
             1       1000 steve                            
    
    1 sessions listed.

  8. #8

    Default Re: Refreshing "system sources" and passwords not being remembered

    Quote Originally Posted by Shadoglare View Post
    Nope, looks like I'm there:

    Code:
    SESSION        UID USER             SEAT            
             1       1000 steve                            
    
    1 sessions listed.
    Well, for me it looks like this:
    Code:
       SESSION        UID USER             SEAT
             5        500 wolfi            seat0           
    
    
    1 sessions listed.
    Notice the "seat0" that you are lacking.
    I don't know at the moment what could cause this...
    Are you logged in via ssh or something like that?

    Well, you could set the other 2 settings to yes ("Any" and "Inactive console") and then you shouldn't be asked for the password again.

  9. #9

    Default AW: Re: Refreshing "system sources" and passwords not being remembered

    Quote Originally Posted by wolfi323 View Post
    Well, you could set the other 2 settings to yes ("Any" and "Inactive console") and then you shouldn't be asked for the password again.
    Forget that, sorry. That can't help really, because those settings were no, so you wouldn't get a request for the root passwd anyway but just be blocked.
    Hm, changes in that systemsettings module don't seem to have any effect here (maybe a reboot is required?)...

    But you could try to run (as root):
    Code:
    set_polkit_default_privs
    This sets all permissions to the default values which shouldn't ask you for a root password for refreshing the software sources.
    But before you do that, please check the settings in /etc/sysconfig/security. If they are set to "restrictive" there, the defaults would be more restrictive and may cause password requests for things you could normally do without a password...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •