Results 1 to 4 of 4

Thread: Trouble setting up SABnzbd

  1. #1

    Default Trouble setting up SABnzbd

    I searched for SABnzbd in software.opensuse.org and used the 1-click install to set it up. From looking over an older tutorial, I'm apparently supposed to run a python script called SABnzbd.py that is located in the install directory. When I try to run it, I get this error message:

    Traceback (most recent call last):
    File "/usr/share/SABnzbd/SABnzbd.py", line 66, in <module>
    import sabnzbd
    File "/usr/share/SABnzbd/sabnzbd/__init__.py", line 72, in <module>
    from sabnzbd.nzbqueue import NzbQueue
    File "/usr/share/SABnzbd/sabnzbd/nzbqueue.py", line 28, in <module>
    from sabnzbd.nzbstuff import NzbObject
    File "/usr/share/SABnzbd/sabnzbd/nzbstuff.py", line 40, in <module>
    from sabnzbd.misc import to_units, cat_to_opts, cat_convert, sanitize_foldername, \
    File "/usr/share/SABnzbd/sabnzbd/misc.py", line 45, in <module>
    import sabnzbd.growler as growler
    File "/usr/share/SABnzbd/sabnzbd/growler.py", line 33, in <module>
    from gntp import GNTPRegister

    Any ideas?

  2. #2

    Default Re: Trouble setting up SABnzbd

    Oops! Forgot the last part of the log...

    ImportError: cannot import name GNTPRegister

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,051
    Blog Entries
    14

    Default Re: Trouble setting up SABnzbd

    From which repo did you install SABNzb? Which version?

    Please post output from
    Code:
    zypper se -i -s sabnzb
    , between CODE tags.

    Plus, how do you run SABnzb? I do, as user, not as root:
    Code:
    cd /usr/share/SABnzbd
    ./SABnzbd.py
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Trouble setting up SABnzbd

    I pulled it up here and installed SABnzbd from the bmanojlovic repository:

    Code:
    S | Name    | Type    | Version     | Arch   | Repository      
    --+---------+---------+-------------+--------+-----------------
    i | SABnzbd | package | 0.7.11-15.2 | noarch | home:bmanojlovic
    It doesn't seem to make a difference which user I run SABnzbd.py as, my regular user or root; I get the same message.

    Interestingly enough, I tried downloading the source from SABnzbd's Web site and it runs perfectly well. Is there a problem with the way this particular repository has packaged it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •