Results 1 to 6 of 6

Thread: qgis and libgdal/libpng issue

  1. #1

    Default qgis and libgdal/libpng issue

    Hello,

    I'm new to opensuse, so far I'm loving it.
    Thing is I'm trying to install qgis on 12.3 through 1click install but I run into this issue where YaST keeps telling me it can't get libgpng14.so.14 which is required by libgdal1-1.9.2-6.4.x86_64.
    I would really appreciate any help since I need it for work and it's the only problem I have ran into with opensuse.

    Thanks in advance and sorry for my english

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: qgis and libgdal/libpng issue

    Quote Originally Posted by dsierig View Post
    Hello,

    I'm new to opensuse, so far I'm loving it.
    Thing is I'm trying to install qgis on 12.3 through 1click install but I run into this issue where YaST keeps telling me it can't get libgpng14.so.14 which is required by libgdal1-1.9.2-6.4.x86_64.
    I would really appreciate any help since I need it for work and it's the only problem I have ran into with opensuse.

    Thanks in advance and sorry for my english
    You can download the appropriate rpm from here RPM Search libpng14.so.14
    Use it with *discretion* Be careful of the installation. It *may* try to remove any software which may *stone* your system
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  3. #3

    Default Re: qgis and libgdal/libpng issue

    Quote Originally Posted by vazhavandan View Post
    You can download the appropriate rpm from here RPM Search libpng14.so.14
    Use it with *discretion* Be careful of the installation. It *may* try to remove any software which may *stone* your system
    Thanks for your answer. I could run qgis after searching some other dependences.
    Now when I run qgis I get the following error

    Couldn't load PyQt4. Python support will be disabled.
    Traceback (most recent call last):
    File "", line 1, in
    RuntimeError: the sip module implements API v9.0 to v9.1 but the qgis.core module requires API v8.1
    I think I should downgrade some package in order to get python support but have no clue what the name of it would be.
    Any ideas?

    Thanks in advance

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: qgis and libgdal/libpng issue

    Am 26.04.2013 00:36, schrieb dsierig:
    > RuntimeError: the sip module implements API v9.0 to v9.1 but the
    >> qgis.core module requires API v8.1
    >>

    looks as if python-sip is too new for qgis

    --
    PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.2 | GTX 650 Ti
    ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.2 | HD 3000
    HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.2 | GMA4500

  5. #5

    Default Re: qgis and libgdal/libpng issue

    OK after some struggling I got it working.

    Tried downgrading lots of different versions of these files.

    python-qt4
    python-sip

    In case someone runs into the same issue, the right versions can be found here and here
    Thanks for all your help

  6. #6
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: qgis and libgdal/libpng issue

    Quote Originally Posted by dsierig View Post
    OK after some struggling I got it working.

    Tried downgrading lots of different versions of these files.

    python-qt4
    python-sip

    In case someone runs into the same issue, the right versions can be found here and here
    Thanks for all your help
    you are welcome
    Some rpm sites that *i* found useful are. You them at *your* own risk.
    Linux Free Software Catalog and Packages Search - pkgs.org
    RPM Search
    Welcome to the RPM repository on fr2.rpmfind.net
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •