Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Epiphany Freezing on certain websites for 30 seconds, once per session.

  1. #1

    Default Epiphany Freezing on certain websites for 30 seconds, once per session.

    With plugins disabled, epiphany freezes on a handful of websites (such as Google+) but not others for 15-20 seconds. After that, it runs smoothly and never freezes again in the same session. With the plugins enabled, Epiphany freezes on even more websites (still not all the websites) for 20-30 seconds. This happens only once per session as well.
    Here's a list of installed plugins: SUSE Paste

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Epiphany Freezing on certain websites for 30 seconds, once per session.

    Quote Originally Posted by Vagrant232 View Post
    With plugins disabled, epiphany freezes on a handful of websites (such as Google+) but not others for 15-20 seconds. After that, it runs smoothly and never freezes again in the same session. With the plugins enabled, Epiphany freezes on even more websites (still not all the websites) for 20-30 seconds. This happens only once per session as well.
    Here's a list of installed plugins: SUSE Paste
    Does the freeze occurs when watching videos ?
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  3. #3

    Default Re: Epiphany Freezing on certain websites for 30 seconds, once per session.

    Quote Originally Posted by vazhavandan View Post
    Does the freeze occurs when watching videos ?
    The freeze occurs when the first poblematic page is still loading. Once the page loads, epiphany never freezes again so no it doesn't freeze when watching videos.

  4. #4

    Default Re: Epiphany Freezing on certain websites for 30 seconds, once per session.

    With the plugins enabled, it also freezes on extensions.gnome.org

  5. #5
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Epiphany Freezing on certain websites for 30 seconds, once per session.

    Quote Originally Posted by Vagrant232 View Post
    With the plugins enabled, it also freezes on extensions.gnome.org
    Try launching epiphany from terminal/konsole. Do you notice any errors when the freeze happens ?
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  6. #6

    Default Re: Epiphany Freezing on certain websites for 30 seconds, once per session.

    Quote Originally Posted by vazhavandan View Post
    Try launching epiphany from terminal/konsole. Do you notice any errors when the freeze happens ?
    No errors show up when the freeze happens. However, this error shows up randomly:
    Code:
    (epiphany:8430): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 1

  7. #7
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Epiphany Freezing on certain websites for 30 seconds, once per session.

    Do you have openJDK installed ?
    On my system epiphany is invoking openJDK whenever there is flash content on a website
    It is also invoking openJDK on extensions.gnome.org
    Code:
    $epiphany 
    java version "1.7.0_17"
    OpenJDK Runtime Environment (IcedTea7 2.3.8) (suse-8.8.1-x86_64)
    OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  8. #8

    Default Re: Epiphany Freezing on certain websites for 30 seconds, once per session.

    Quote Originally Posted by vazhavandan View Post
    Do you have openJDK installed ?
    Yes, he has. IcedTea is the java browserplugin from openJDK.

    On my system epiphany is invoking openJDK whenever there is flash content on a website
    I don't think so.
    It would invoke openJDK whenever there is java content on a website.
    If there is flash content, it would invoke flashplayer...

    But maybe some pages use a java applet instead of flash, when the browser doesn't support flash (i.e. no flash plugin installed)

    Can't help with the original problem though. Maybe epiphany freezes while it is loading the java/flash plugin. (could happen esp. if you are low on ram).
    It could also be related to the iTunes plugin (but this is a wild guess).

    But then, you said it also happens with all plugins disabled?
    So maybe it's about javascript? Could you try to disable that? (don't know how you would do that in epiphany, though)

  9. #9

    Default Re: Epiphany Freezing on certain websites for 30 seconds, once per session.

    The problem can't possibly be due to shortage of RAM since Firefox works almost flawlessly. I've got 4 GiB of RAM. Also, I don't have the faintest idea on how to disable Javascript. Epiphany freezing without the plugins can be due to a different problem as well. With the plugins enabled, it freezes on extensions.gnome.org (so that could be due to the gnome integration plugin since the website doesn't have any videos. It also freezes on youtube.com but I can't see why it would use the gnome integration plugin on that website, so it's probably due to flash or the itunes plugin (it doesn't freeze on youtube with the plugins enabled). Same thing with Steampowered.com. My.jolidrive.com with doesn't use neither flash nor the gnome integration plguin also freezes. The puzzling part is, once it freezes on ONE of these websites, it never freezes again during the same session. The only website I found it to freeze on without the plugins is Google+. In short: It is probably due to a plugin that is used on multiple websites, probably isn't flash or gnome integration, but God knows which.

  10. #10

    Default Re: Epiphany Freezing on certain websites for 30 seconds, once per session.

    Quote Originally Posted by Vagrant232 View Post
    The problem can't possibly be due to shortage of RAM since Firefox works almost flawlessly. I've got 4 GiB of RAM.
    Ah, I don't think you are short on RAM then...
    But since it only happens once per session, it could be because epiphany is loading something (a plugin presumably).

    Also, I don't have the faintest idea on how to disable Javascript.
    From https://help.gnome.org/users/epiphan...tomize.html.en:
    10.1.3. Privacy Preferences
    Epiphany allows you to configure a number of features which allow you to restrict what web pages can do:


    • Select Allow popup windows if you want web pages to be able to launch content in new windows automatically.
    • Select Enable Java to allow pages to load Java applets - programs which run inside web pages.
    • Select Enable JavaScript to give web pages the capability to use the more advanced programming techniques of the JavaScript language.


    Disabling these features may cause some pages to display incorrectly or cause some loss of functionility. For Java to work, you need to install the Java plugin.

    You could also try to disable java...
    Oh, and you didn't specify your epiphany version. Apparently they removed that option in 3.7...
    https://trisquel.info/de/forum/epiph...ion-disable-js
    Last edited by wolfi323; 20-Apr-2013 at 09:08. Reason: fixed link

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •