Results 1 to 8 of 8

Thread: KDE screen timeout indicator

  1. #1

    Default KDE screen timeout indicator

    Hi. I'm using 12.3 64-bit with KDE 4.10.2. I've got the lock screen set to lock after 4 minutes. After a few minutes of inactivity, there is an indicator that appears on the screen with a monitor and a horizontal graphic that says 50% for a few seconds. If I touch the keyboard, it pops up again and says 100%. If I don't touch the keyboard, it says something like 13" after another minute or so. Honestly, I am getting tired of this and it seems rather pointless. It did not exist when I was running 4.8.5 under 11.2 (prior computer). Is there a way to turn it off?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Question Re: KDE screen timeout indicator

    Quote Originally Posted by JJMT View Post
    Hi. I'm using 12.3 64-bit with KDE 4.10.2. I've got the lock screen set to lock after 4 minutes. After a few minutes of inactivity, there is an indicator that appears on the screen with a monitor and a horizontal graphic that says 50% for a few seconds. If I touch the keyboard, it pops up again and says 100%. If I don't touch the keyboard, it says something like 13" after another minute or so. Honestly, I am getting tired of this and it seems rather pointless. It did not exist when I was running 4.8.5 under 11.2 (prior computer). Is there a way to turn it off?
    So if you go to menu / Configure Desktop / Hardware / Display and Monitor what do you see there? Here is my setup:



    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: KDE screen timeout indicator

    OK. These are my settings:



    And this is what I see on screen after about two and a half minutes (note the 50% video indicator):


  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: KDE screen timeout indicator

    Quote Originally Posted by JJMT View Post
    OK. These are my settings:



    And this is what I see on screen after about two and a half minutes (note the 50% video indicator):

    Looks like the monitor brightness control. Might want to check your Power Management setup for that control.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: KDE screen timeout indicator

    Quote Originally Posted by jdmcdaniel3 View Post
    Looks like the monitor brightness control. Might want to check your Power Management setup for that control.

    Thank You,
    Yes. I agree. It is exactly like the brightness indicator that pops up when I increase or decrease brightness. But in this case, brightness is not changing. The percentage is clearly indicating the time before the screen locks.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,628
    Blog Entries
    3

    Default Re: KDE screen timeout indicator

    Quote Originally Posted by JJMT View Post
    Yes. I agree. It is exactly like the brightness indicator that pops up when I increase or decrease brightness. But in this case, brightness is not changing.
    That happens to me. If I check the logs, they indicate that the monitor does not support brightness changes. If that's your situation, then go into KDE power settings, and set it to never dim the screen (but keep the option to turn off the display).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7

    Default Re: KDE screen timeout indicator

    Quote Originally Posted by nrickert View Post
    That happens to me. If I check the logs, they indicate that the monitor does not support brightness changes. If that's your situation, then go into KDE power settings, and set it to never dim the screen (but keep the option to turn off the display).
    Yeah. I've been following the same line of reasoning. I guess the lock screen is a red hearing, and really this is all power setting dependent. I turned off Dim Display in all the power profiles, and that solved the problem. But while doing all this, I discovered that I cannot actually adjust my screen brightness. I did a quick Google and found some people are having luck with adding "acpi_osi=Linux acpi_backlight=vendor" to the kernel options in Grubb, but that got me nothing. So, I'm not sure where I am right now. but I'm going to bed.

  8. #8

    Default Re: KDE screen timeout indicator

    OK. Just to tie this thread off, the odd behavior I was seeing was ultimately resolved by fixing the fact that screen brightness was unchangeable. KDE would *try* to change the brightness, but nothing would happen. Keyboard shortcuts would do the same thing. My laptop is a Dell E6530. It's got an nvidia NVS 5200M. That's an optimus adapter, but optimus is turned off in the BIOS. I am running exclusively on nvidia using proprietary drivers.

    I got screen brightness to work by creating a file called "10-nvidia-brightness.conf" in the directory /etc/X11/xorg.conf.d. In that file is this:

    Code:
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "NVS 5200M"
        Option         "RegistryDwords" "EnableBrightnessControl=1"
    EndSection
    I did not make any changes to my kernel or kernel boot parameters, which remain as default from the 12.3 install. So. Done.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •