Results 1 to 5 of 5

Thread: $DISPLAY is not properly set after upgrade to Opensuse 12.3

  1. #1

    Default $DISPLAY is not properly set after upgrade to Opensuse 12.3

    Hi,

    I recently upgraded my laptop at work from Opensuse 11.4 to 12.3. Now $DISPLAY is not properly set. I.e.,

    > echo $DISPLAY
    :0

    When I log in remotely using ssh, "echo $DISPLAY" just returns a blank line, whereas I had expected something like "localhost:10.0". Thus I cannot run X applications remotely. This is puzzling, because it worked in Opensuse 11.4, and I don't remember having fiddled with any settings. I have

    ForwardX11 yes
    ForwardAgent yes

    in my ~/.ssh/config

    In case there were some obsolete settings in my other configuration files, I tried creating a "fresh" test user, but that did not help.

    Does anyone have an idea how to fix this?

    Regards,

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: $DISPLAY is not properly set after upgrade to Opensuse 12.3

    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  3. #3

    Default Re: $DISPLAY is not properly set after upgrade to Opensuse 12.3

    Quote Originally Posted by vazhavandan View Post
    Thanks, yes, I tried this, and it didn't help. Isn't this the same as setting
    Code:
    ForwardX11 yes
    ?

    I suspect the problem is not directly related to ssh, since $DISPLAY is only ":0" in the begiinning?

    Regards,

  4. #4

    Default Re: $DISPLAY is not properly set after upgrade to Opensuse 12.3

    I have done some more tests. I think the problem is somehow related to ssh.

    When I log in using ssh, the following appears in /var/log/messages:

    sshd[31251]: error: Failed to allocate internet-domain X11 display socket.

    However, if I edit /etc/ssh/sshd_config and change
    X11UseLocalhost yes
    to
    X11UseLocalhost no

    and restart sshd, then $DISPLAY is set and I can start X applications.

    Does anyone understand this? Is the latter setting less safe?

    Regards,

  5. #5

    Default Re: $DISPLAY is not properly set after upgrade to Opensuse 12.3

    Quote Originally Posted by svendtm View Post
    I have done some more tests. I think the problem is somehow related to ssh.

    When I log in using ssh, the following appears in /var/log/messages:

    sshd[31251]: error: Failed to allocate internet-domain X11 display socket.

    However, if I edit /etc/ssh/sshd_config and change
    X11UseLocalhost yes
    to
    X11UseLocalhost no

    and restart sshd, then $DISPLAY is set and I can start X applications.
    I found the trick: To make it work using "X11UseLocalhost yes", I needed to enable IPv6 in the network settings.

    Strange and wonderful.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •