Results 1 to 4 of 4

Thread: Issue YAST2 OpenSuse 12.3 New Installation.

  1. #1

    Default Issue YAST2 OpenSuse 12.3 New Installation.

    Hi this is my first post, i was reading alot before posting and i could not find a answer to my issue.

    When i start the YAST2 everything goes well till i try install or uninstall software i get this message.

    "/sbin/yast2: líne 431: 10430 Segment Violation $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS"

    i try reinstalling the YAST2 with this command "zypper in -f yast2" and nothing happenend.


    i hope get help to keep setup my OpensSuse 12.3.

    Thanks!!!

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Issue YAST2 OpenSuse 12.3 New Installation.

    Quote Originally Posted by indabeat View Post
    Hi this is my first post, i was reading alot before posting and i could not find a answer to my issue.

    When i start the YAST2 everything goes well till i try install or uninstall software i get this message.

    "/sbin/yast2: líne 431: 10430 Segment Violation $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS"

    i try reinstalling the YAST2 with this command "zypper in -f yast2" and nothing happenend.


    i hope get help to keep setup my OpensSuse 12.3.

    Thanks!!!
    So I am thinking YaST got corrupted somehow during the install and/or the install media is bad. My normal suggestion would be to reinstall and reuse all existing partions just as before, making sure to reformat root /. I did find someone who suggested you could try this before you went on to a full install. " removing the directory (/usr/lib/YaSt2) and reinstalling yast (#zypper in yast2) and the yast2-qt as well as yast2-ncurses modules resolved all my problems" and its worth a try.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Issue YAST2 OpenSuse 12.3 New Installation.

    Quote Originally Posted by indabeat View Post
    Hi this is my first post, i was reading alot before posting and i could not find a answer to my issue.

    When i start the YAST2 everything goes well till i try install or uninstall software i get this message.

    "/sbin/yast2: líne 431: 10430 Segment Violation $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS"

    i try reinstalling the YAST2 with this command "zypper in -f yast2" and nothing happenend.


    i hope get help to keep setup my OpensSuse 12.3.

    Thanks!!!
    That is a stupid error in YaST2 that i do see *sometimes* in YaST. Are you using GNOME ?
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Issue YAST2 OpenSuse 12.3 New Installation.

    It may sound now ridiculous, silly, stupid and unrelated, but I had seen
    that error in the following situation:
    I set up a fresh openSUSE 12.3 on a netbook with Gnome 3 and an nvidia
    card after installing the proprietary driver for the daughter.
    After I noticed that I forgot to add the user to the video group and
    added that user (logout and login again of course) the problem
    disappeared as a side effect and never came back.

    Do not ask me why as yast runs as root in the users X session, so I do
    not understand it, but it happened.
    I was completely stomped about that effect.

    So maybe you ran into that if you are using nvidia with the proprietary
    driver. If you have a different graphic card ignore this post.

    --
    PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
    ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.0 | HD 3000
    HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •