Hi folks,
I'm quite new to Linux, but hopefully there is an easy answer to this.
I'm doing a standard upgrade from 12.1 -> 12.2.
I was current on 12.1, then changed the repo's to 12.2 using "sed -i 's/12\.1/12\.2/g' /etc/zypp/repos.d/*"

Now using a zypper ref/zypper dup, I get...

Code:
Computing distribution upgrade...
2 Problems:
Problem: problem with installed package product:openSUSE-12.1-1.4.x86_64
Problem: problem with installed package product:openSUSE-12.1-1.4.x86_64

Problem: problem with installed package product:openSUSE-12.1-1.4.x86_64
 Solution 1: Following actions will be done:
  do not forbid installation of product:openSUSE-12.2-1.6.i586[repo-oss]
  install product:openSUSE-12.2-1.6.i586 despite the inferior architecture
  install product:openSUSE-12.2-1.6.i586 despite the inferior architecture
 Solution 2: keep obsolete product:openSUSE-12.1-1.4.x86_64
 Solution 3: do not forbid installation of product:openSUSE-12.2-1.6.x86_64[repo-oss]
Solution 3 seems like the logical answer here given what I'm trying to do, but is this normal..?
Is there anything else I need to be aware of here..?

Repo's are:

Code:
# | Alias                | Name                       | Enabled | Refresh | URI
--+----------------------+----------------------------+---------+---------+----------------------------------------------------------------
1 | Updates-for-openSUSE | Updates for openSUSE 12.2  | Yes     | Yes     | http://download.opensuse.org/update/12.2/
2 | repo-debug           | openSUSE-12.2-Debug        | No      | Yes     | http://download.opensuse.org/debug/distribution/12.2/repo/oss/
3 | repo-debug-update    | openSUSE-12.2-Update-Debug | No      | Yes     | http://download.opensuse.org/debug/update/12.2/
4 | repo-non-oss         | openSUSE-12.2-Non-Oss      | Yes     | Yes     | http://download.opensuse.org/distribution/12.2/repo/non-oss/
5 | repo-oss             | openSUSE-12.2-Oss          | Yes     | Yes     | http://download.opensuse.org/distribution/12.2/repo/oss/
6 | repo-source          | openSUSE-12.2-Source       | No      | Yes     | http://download.opensuse.org/source/distribution/12.2/repo/oss/
Many thanks!