Results 1 to 4 of 4

Thread: NTFS-3g and colon character

  1. #1
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default NTFS-3g and colon character

    I'm always having issues moving files created in linux with ntfs-3g to windows when there is a colon character in the filename. Windows will display the name, but wont' open it. Is this a persistent bug, or is there a way to issue an "illegal character" response to software whenever it attempts to name a file with an "illegal" colon on an NTFS filesystem? I can't find any discussions on google.

    Thank You!
    Patti

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: NTFS-3g and colon character

    Quote Originally Posted by PattiMichelle View Post
    I'm always having issues moving files created in linux with ntfs-3g to windows when there is a colon character in the filename. Windows will display the name, but wont' open it. Is this a persistent bug, or is there a way to issue an "illegal character" response to software whenever it attempts to name a file with an "illegal" colon on an NTFS filesystem? I can't find any discussions on google.

    Thank You!
    Patti
    I am seeing that there is a fstab mount option for ntfs-3g file system called "windows_names" which I found here: NTFS-3G Manual | Tuxera

    Besides this fix, the obvious thing to do is to not use the colon character in your file names. It is also possible to write a bash script, using the tr command to change a colon discovered into something else. I have done this before to get rid of spaces in filenames for instance.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,495
    Blog Entries
    3

    Default Re: NTFS-3g and colon character

    Quote Originally Posted by PattiMichelle View Post
    I'm always having issues moving files created in linux with ntfs-3g to windows when there is a colon character in the filename.
    When I tried to do that, I got an error message from "cp". I think I was running 12.2 at the time.

    My present method of solving that problem: I have a directory on a linux box that I share with both "NFS" and "samba". If I put the file there, and then copy from Windows, the "samba" file name mangling seems to take care of the problem. I haven't tested this very thoroughly.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: NTFS-3g and colon character

    Thanks for the replies, I'm surprised it's still an unresolved issue, is all. Too, I thought maybe there was some obvious fix that people might be using....
    I'll try to get smarter on ways to avoid these problems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •