I installed the GDAL library (packages python-gdal, libgdal-devel, libgdal1, gdal (static)) from the repository:
Index of /repositories/Application:/Geo/openSUSE_12.2

When I run the Python bindings to the GDAL:
python
import gdalnumeric
python complains that gdalnumeric is compiled with numpy API version 7 while installed numpy is version 6.
There is a simple fix. Do the following with YAST:
a. Uninstall python-gdal (the remainder of GDAL should remain installed)
b. Install numpy-devel. When Yast complains about conflict and provides some alternatives to choose from -> Choose vendor change
c. Install python-gdal

Now gdalnumeric works.
Please note that this is a problem with GDAL for SuSE 12.3. Previous versions of SuSE did not have this problem.

Thanasis