Results 1 to 5 of 5

Thread: gParted refuses to launch on openSUSE 12.3/ GNOME 3.6

  1. #1
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default gParted refuses to launch on openSUSE 12.3/ GNOME 3.6

    When i try to launch "gParted" from Activities it refuses to launch saying that passcode is wrong.
    But i can launch it from terminal as shown below.
    gnomesu and xdg-su work. But the pkexec used in Activities doesn't validate properly.
    Anyone else seeing similar issue ?
    Code:
    dartmouth@linux-8zs1:~> gnomesu /usr/sbin/gparted
    ======================
    libparted : 2.4
    ======================
    dartmouth@linux-8zs1:~> xdg-su -c /usr/sbin/gparted
    ======================
    libparted : 2.4
    ======================
    dartmouth@linux-8zs1:~> pkexec /usr/sbin/gparted %f
    Error executing command as another user: Not authorized
    
    This incident has been reported.
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,832
    Blog Entries
    15

    Default Re: gParted refuses to launch on openSUSE 12.3/ GNOME 3.6

    On Fri 12 Apr 2013 03:46:02 AM CDT, vazhavandan wrote:


    When i try to launch "gParted" from Activities it refuses to launch
    saying that passcode is wrong.
    But i can launch it from terminal as shown below.
    gnomesu and xdg-su work. But the pkexec used in Activities doesn't
    validate properly.
    Anyone else seeing similar issue ?

    Code:
    --------------------
    dartmouth@linux-8zs1:~> gnomesu /usr/sbin/gparted
    ======================
    libparted : 2.4
    ======================
    dartmouth@linux-8zs1:~> xdg-su -c /usr/sbin/gparted
    ======================
    libparted : 2.4
    ======================
    dartmouth@linux-8zs1:~> pkexec /usr/sbin/gparted %f
    Error executing command as another user: Not authorized

    This incident has been reported.
    --------------------


    Hi
    Works for me, both from Activities (%f works here) and terminal...?
    Code:
    pkexec /usr/sbin/gparted %f
    ======================
    libparted : 2.4
    ======================
    Could not stat device %f - No such file or directory.
    
    pkexec /usr/sbin/gparted /dev/sda
    ======================
    libparted : 2.4
    ======================
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.3 (x86_64) Kernel 3.7.10-1.1-desktop
    up 15:34, 3 users, load average: 0.22, 0.10, 0.06
    CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile


  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: gParted refuses to launch on openSUSE 12.3/ GNOME 3.6

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Works for me, both from Activities (%f works here) and terminal...?
    Code:
    pkexec /usr/sbin/gparted %f
    ======================
    libparted : 2.4
    ======================
    Could not stat device %f - No such file or directory.
    
    pkexec /usr/sbin/gparted /dev/sda
    ======================
    libparted : 2.4
    ======================
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.3 (x86_64) Kernel 3.7.10-1.1-desktop
    up 15:34, 3 users, load average: 0.22, 0.10, 0.06
    CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile
    When i try from "Activities", in the validation screen when i am getting a yellowish text in authentication window "sorry that did not works..."
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,832
    Blog Entries
    15

    Default Re: gParted refuses to launch on openSUSE 12.3/ GNOME 3.6

    Quote Originally Posted by vazhavandan View Post
    When i try from "Activities", in the validation screen when i am getting a yellowish text in authentication window "sorry that did not works..."
    Hi
    That's an xterm window, not seen here, sure it's the right password?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: gParted refuses to launch on openSUSE 12.3/ GNOME 3.6

    Quote Originally Posted by malcolmlewis View Post
    Hi
    That's an xterm window, not seen here, sure it's the right password?
    No i am not talking about terminal emulator. I should have mentioned "text" instead mentioned "window".





    I am providing the correct passcode and gparted does launch from terminal as demonstrated below


    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •