Results 1 to 5 of 5

Thread: Reclaiming original window launch behavior in KDE, 12.3

  1. #1
    Join Date
    Oct 2009
    Location
    Greater Portland, Oregon, USA
    Posts
    62

    Default Reclaiming original window launch behavior in KDE, 12.3

    I recently clean installed 12.3, using the KDE desktop. I have been quite happy with the older, traditional desktop, with the icons down the left side. So after choosing Folder view, and picking a lighter, more colorful wall paper than the default that was installed, I have been generally satisfied. I keep several terminal windows alive, with buttons on the panel that open the window when I click on the button. Nothing fancy. My one dissatisfaction with the new screen layout was the dark/charcoal background color of the panel, and that this same dark color appeared also in the CPU performance monitor widget that I keep in the upper right hand corner. I think this color choice makes both the panel buttons (and their associated icons) and the CPU usage trace in the monitor harder to see. I preferred the white/lighter background that I had in my previous 11.4 installation (KDE 3.?). So I attempted to find the setting that controlled this dark color, and I first went to the Panel Tool Box/ More Settings. I didn't see anything obvious, but I made the mistake of clicking on Windows Can Cover and Windows Go Below, just to see what they did. Certainly the wrong thing to do, since neither seems to be the default that I started with. What also happened was that now the panel behavior has changed. When I hover over a panel button for one of my terminal windows, or Kontact, or Firefox, the window appears, semi-transparently, and If I click on the button, that window is active and fills the screen. I don't want this behavior, I know what the buttons represent and I only want the window to appear when I click the button. However, even more irritating is that my terminal windows appear iconified in the upper left corner of the screen, rather than appearing at the size and location on the desktop that I have set for them.

    So what have I done, and how do I get back to the previous behavior? I don't see anything obvious in the Configure Desktop dialogues.

    And if anyone knows how to change the background color in the panel and widget, I certainly would like to know that also!

  2. #2

    Default Re: Reclaiming original window launch behavior in KDE, 12.3

    Quote Originally Posted by lrkeefe View Post
    Certainly the wrong thing to do, since neither seems to be the default that I started with.
    The default setting is "Always show".

    What also happened was that now the panel behavior has changed. When I hover over a panel button for one of my terminal windows, or Kontact, or Firefox, the window appears, semi-transparently, and If I click on the button, that window is active and fills the screen. I don't want this behavior, I know what the buttons represent and I only want the window to appear when I click the button.
    Right click in one of the buttons and select "Taskmanager settings". Uncheck "Show Tooltips" there.

    However, even more irritating is that my terminal windows appear iconified in the upper left corner of the screen, rather than appearing at the size and location on the desktop that I have set for them.
    I don't understand that. Could you post a screenshot?

    And if anyone knows how to change the background color in the panel and widget, I certainly would like to know that also!
    You can change the theme in KDE's Configure Desktop (aka systemsettings)->Workspace Appearance->Desktop Theme

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,507
    Blog Entries
    3

    Default Re: Reclaiming original window launch behavior in KDE, 12.3

    Quote Originally Posted by lrkeefe View Post
    I didn't see anything obvious, but I made the mistake of clicking on Windows Can Cover and Windows Go Below, just to see what they did.
    I never paid attention to those.

    Now that you mention them, I guess I will have to give them a try.

    I have a second user account for that purpose. If I want to try something, I login as that user and try it. If I mess up, nothing is lost. At the worst, I can login as that user in a virtual terminal and delete all files to get back to the status quo ante. It allows safe testing.

    And if I like the result, I can then make that change to my regular login.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Oct 2009
    Location
    Greater Portland, Oregon, USA
    Posts
    62

    Default Re: Reclaiming original window launch behavior in KDE, 12.3

    Thank you Wolfi323. All of your suggestions worked. As to the problem of the iconified (zero size, just the title bar) terminals, I was able to right click on the title bar, go to other settings, and resize. Then I dragged the windows back to the 80 x 25 size I wanted and placed them where I wanted. Then when I invoked another terminal instance, the new instance came up with the correct size and could be dragged to where I desired. With regards to the hovering behavior, it seems the default behavior was to show tooltips, but not to highlight windows. I have another 12.3 installation that I hadn't messed with, and your suggestions allowed me to check the settings there on the original behavior I was satisfied with.

    In the panel settings, it is unclear to me that the other window options have much effect, except that they both seem to put the bottom of a full screen window behind the panel, which makes it difficult to resize by dragging the corner. When the Always Visible option is checked, the window lower border always rests on the top edge of the panel.

    If I fiddled with settings more, the suggestion of having another user account just to try things out in would be worth implementing.

    Thanks to both for your help and suggestions.

  5. #5

    Default Re: Reclaiming original window launch behavior in KDE, 12.3

    Quote Originally Posted by lrkeefe View Post
    As to the problem of the iconified (zero size, just the title bar) terminals, I was able to right click on the title bar, go to other settings, and resize.
    Well, could have been the "Window Shader", which is activated/deactivated by double clicking on the window title bar by default. (can be changed in Configure Desktop->Window Behavior->Window Behavior->Title Bar.

    With regards to the hovering behavior, it seems the default behavior was to show tooltips, but not to highlight windows.
    Yes.

    In the panel settings, it is unclear to me that the other window options have much effect, except that they both seem to put the bottom of a full screen window behind the panel, which makes it difficult to resize by dragging the corner.
    "Windows Go Below" does what you describe (windows are "under" the panel and hidden by it). But you can also resize windows by dragging any other corner (well, every part of the window's frame), or by using the menu item as you found out. A shortcut would also be to press the "ALT" key and right-click on the window (can be configured in Configure Desktop->Window Behavior->Window Behavior->Window)

    "Windows Can Cover" should actually do the opposite! When enabled, windows should always be in front of the panel.

    And if you use "Automatically Hide" (not sure if it's called that way, I'm running in german here...), the panel will completely disappear as long as the mouse pointer doesn't touch it...

    Well, anyway, I'm glad I could help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •