Results 1 to 6 of 6

Thread: fcitx mozc and Libreoffice

  1. #1
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,649

    Default fcitx mozc and Libreoffice

    This is a question specifically for MargueriteSu who I believe is the maintainer of the various IMEs in openSUSE (and I know peruses these forums) but I guess there may be others that can answer my questions.

    After switching to 12.3 from 12.2 I removed ibus and anthy and replaced them with fcitx and mozc due to better KDE integration and being much much more lightweight (due to them not needing the gtk dependencies that ibus has).

    It's taken me a couple of days to get used to after so long using ibus but I am getting used to it now.

    There are a couple of quirks that I just can't work out.

    The firs is that the kde4 config window for fcitx wont let me select ctrl+super as my trigger for mozc
    Is there anyway I can force this as I have spent most of my linux life using this trigger configuration and it is hard to change old habbits.

    The second is a quirk in using fcitx/mozc in Libreoffice.

    It does work OK but the text being typed does not display in Libreoffice until it is selected from the candidate window.
    In other QT and GTK apps the text appears and changes as the selected candidate changes.

    see the below screenshots

    kwrite



    and Libreoffice



    notice how in Libreoffice there is no text present. Once I select the candidate it appears in Libreoffice.

    Is there something I am missing here?
    I hope I am making myself clear.

    Many thanks

  2. #2

    Default Re: fcitx mozc and Libreoffice

    Quote Originally Posted by farcusnz View Post
    This is a question specifically for MargueriteSu who I believe is the maintainer of the various IMEs in openSUSE (and I know peruses these forums) but I guess there may be others that can answer my questions.

    After switching to 12.3 from 12.2 I removed ibus and anthy and replaced them with fcitx and mozc due to better KDE integration and being much much more lightweight (due to them not needing the gtk dependencies that ibus has).

    It's taken me a couple of days to get used to after so long using ibus but I am getting used to it now.

    There are a couple of quirks that I just can't work out.

    The firs is that the kde4 config window for fcitx wont let me select ctrl+super as my trigger for mozc
    Is there anyway I can force this as I have spent most of my linux life using this trigger configuration and it is hard to change old habbits.

    The second is a quirk in using fcitx/mozc in Libreoffice.

    It does work OK but the text being typed does not display in Libreoffice until it is selected from the candidate window.
    In other QT and GTK apps the text appears and changes as the selected candidate changes.

    see the below screenshots

    kwrite



    and Libreoffice



    notice how in Libreoffice there is no text present. Once I select the candidate it appears in Libreoffice.

    Is there something I am missing here?
    I hope I am making myself clear.

    Many thanks
    Hi, I'm fcitx upstream developer and I came here via google search though..

    Short answer: install libreoffice-gnome and try

    export OOO_FORCE_DESKTOP=gnome

    and then run libreoffice.

    Long answer including technically details:

    Techinically, the "underlined" text is called preedit text, to show it or not depends on the capacity of the application you're using. (And you see the "preedit" is shown at the first line of input window, which means fcitx think this applicaton have no capacity to show preedit, so fcitx do it on its own.)

    libreoffice could use gtk im module, or XIM to communicate with other application. And it seems if it's using kde integration, it will not use gtk im module.

    From your screenshot, seems it's using XIM. While XIM have some different mode, and one of them can support the "preedit" text, unfortunately, using this mode will break some other function, which is also important (namely, show the input window at the position of cursor https://fcitx-im.org/wiki/FAQ#Cursor_Following_problem ). So fcitx doesn't enable that mode for XIM by default.

    There is a setting to force fcitx to use that mode (namely, on the spot), but you will lose the ability to shown the input window at the cursor's position for almost all XIM application (which barely means, all non-gtk/qt application).

    Or, for libreoffice to use gnome integration, as shown in short answer.

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,649

    Default Re: fcitx mozc and Libreoffice

    Quote Originally Posted by csslayer View Post

    Short answer: install libreoffice-gnome and try
    thanks - that fixed it up for me

    export OOO_FORCE_DESKTOP=gnome
    didn't find this necessary

    From your screenshot, seems it's using XIM. While XIM have some different mode, and one of them can support the "preedit" text, unfortunately, using this mode will break some other function, which is also important (namely, show the input window at the position of cursor https://fcitx-im.org/wiki/FAQ#Cursor_Following_problem ). So fcitx doesn't enable that mode for XIM by default.
    this seems to be the same situation as ibus

    is there much likelihood that we'll see better KDE (libreoffice) integration with fcitx in the (near) future?

    Oh - and any idea on my question about the shortcut to trigger fcitx?

    Many thanks again for your help.

  4. #4

    Default Re: fcitx mozc and Libreoffice

    Quote Originally Posted by farcusnz View Post
    thanks - that fixed it up for me



    didn't find this necessary



    this seems to be the same situation as ibus

    is there much likelihood that we'll see better KDE (libreoffice) integration with fcitx in the (near) future?

    Oh - and any idea on my question about the shortcut to trigger fcitx?

    Many thanks again for your help.
    Oh sorry, I missed that.

    Ok, the problem is, modifier only (with only ctrl,alt, shift, super) key, behaves quite different from others, so usaually they need some hack to work.

    Well, there are two option (combobox-ed) contains only modify key

    http://wstaw.org/m/2013/04/15/plasma-desktopL21100.png ( you need to check show advance to get all of this)

    "Extra" trigger key by default can be only used to deactive (namely switch to the first one) and switch back, but as you can see in screenshot there is another option to make it behaves just like the normal trigger key. But the list doesn't have ctrl + super right now (easy to add from code though), personally I use right ctrl to do that since I can press that with my palm..

    and another one is to scroll through the input method (ctrl + shift) in screen shot, it can be set to ctrl + super, it's not exact the same function you want, but if you only have two entry in the input method list, then you can use ctrl + super just like the trigger key (don't forget to check the "including inactive state" in you want to try that).

  5. #5
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,649

    Default Re: fcitx mozc and Libreoffice

    Quote Originally Posted by csslayer View Post
    Oh sorry, I missed that.

    Ok, the problem is, modifier only (with only ctrl,alt, shift, super) key, behaves quite different from others, so usaually they need some hack to work.

    Well, there are two option (combobox-ed) contains only modify key

    http://wstaw.org/m/2013/04/15/plasma-desktopL21100.png ( you need to check show advance to get all of this)

    "Extra" trigger key by default can be only used to deactive (namely switch to the first one) and switch back, but as you can see in screenshot there is another option to make it behaves just like the normal trigger key. But the list doesn't have ctrl + super right now (easy to add from code though), personally I use right ctrl to do that since I can press that with my palm..

    and another one is to scroll through the input method (ctrl + shift) in screen shot, it can be set to ctrl + super, it's not exact the same function you want, but if you only have two entry in the input method list, then you can use ctrl + super just like the trigger key (don't forget to check the "including inactive state" in you want to try that).
    thanks

    Many options there. Got it all working the way I want it now.

    Thanks again

  6. #6
    Join Date
    Nov 2010
    Location
    BEIJING,CHINA; SHANGHAI,CHINA
    Posts
    219

    Default 回复: fcitx mozc and Libreoffice

    seems someone has done his homework...
    Describe questions in details. Google the 'broken application + error message' first

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •