Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [12.3] systemd / systemctl is very slow

  1. #1

    Default [12.3] systemd / systemctl is very slow

    hi,

    after updating to 12.3 i find systemctl rather slow. "systemctl re/start smb/network.service" takes 2-3 minutes, whereas before it took less then a minute. even runlevel switching, where i assume behind the "init" command now systemctl is used, takes like forever. dhclient is like 5 times slower with systemctl then without. anyone else experiencing this? thats quite annoying...

    brian

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: [12.3] systemd / systemctl is very slow

    On 2013-04-05 23:06, brian j wrote:
    > after updating to 12.3


    How was that done?

    Online upgrade
    method

    Offline upgrade
    method


    Chapter 16. Upgrading the System and System Changes


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  3. #3

    Default Re: [12.3] systemd / systemctl is very slow

    Quote Originally Posted by robin_listas View Post
    On 2013-04-05 23:06, brian j wrote:
    How was that done?
    zypper dup


    since your asking: also have a little sound issue since updating:

    https://forums.opensuse.org/english/...wned-root.html

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: [12.3] systemd / systemctl is very slow

    On 2013-04-05 23:36, brian j wrote:
    >
    > robin_listas;2544923 Wrote:
    >> On 2013-04-05 23:06, brian j wrote:
    >> How was that done?
    >>

    >
    > zypper dup


    Verify the config files listed in "/var/adm/rpmconfigcheck".

    > since your asking: also have a little sound issue since updating:
    >
    > http://tinyurl.com/bwhjtwb


    No idea...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  5. #5

    Default Re: [12.3] systemd / systemctl is very slow

    Quote Originally Posted by robin_listas View Post
    On 2013-04-05 23:36, brian j wrote:
    >
    > robin_listas;2544923 Wrote:
    >> On 2013-04-05 23:06, brian j wrote:
    >> How was that done?
    >>

    >
    > zypper dup


    Verify the config files listed in "/var/adm/rpmconfigcheck".
    doesn't exist:

    Code:
    b@jazz:/var/adm> cd /var/adm
    b@jazz:/var/adm> ls
    autoinstall                       mount               SuSEconfig
    backup                            netconfig           update-messages
    crypsetup.fstab.noauto_converted  perl-modules        update-scripts
    fillup-templates                  postfix.configured
    no more gnome!
    @see
    http://www.omgubuntu.co.uk/2012/07/is-the-new-nautilus-a-step-in-the-direction-poll

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: [12.3] systemd / systemctl is very slow

    On 2013-04-06 00:06, brian j wrote:
    >
    > robin_listas;2544934 Wrote:



    >> Verify the config files listed in "/var/adm/rpmconfigcheck".
    >>

    >
    > doesn't exist:


    Interesting, they no longer activate it. Do:

    Code:
    su -
    rcrpmconfigcheck

    you can activate the service doing:

    Code:
    su -
    chkconfig rpmconfigcheck
    chkconfig rpmconfigcheck on

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  7. #7
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,507

    Default Re: [12.3] systemd / systemctl is very slow

    What's the size of file /var/log/journal/<32bit#>/system.journal?

    suggest a read of https://forums.opensuse.org/english/...od-laptop.html

  8. #8

    Default Re: [12.3] systemd / systemctl is very slow

    Quote Originally Posted by keellambert View Post
    What's the size of file /var/log/journal/<32bit#>/system.journal?
    127mb. deleted them and it seems to help.

    thanks!
    no more gnome!
    @see
    http://www.omgubuntu.co.uk/2012/07/is-the-new-nautilus-a-step-in-the-direction-poll

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: [12.3] systemd / systemctl is very slow

    Check the setting of the network device in Yast - Network devices - Network settings - Network card, Edit, General tab. The activiation of the device should be set to "At boot" instead of "At cable connection". In case of the latter samba waits for the network to start for too long.

    And. ..... do something about this sig of yours. We're not interested in what people hate, we're interested in what people love. Bashing and ranting has never brought any good.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: [12.3] systemd / systemctl is very slow

    Quote Originally Posted by Knurpht View Post
    Check the setting of the network device in Yast - Network devices - Network settings - Network card, Edit, General tab. The activiation of the device should be set to "At boot" instead of "At cable connection". In case of the latter samba waits for the network to start for too long.
    but it's all the systemctl commands - including runlevel changes - that are slow. however it seems that deleting the logs helped.

    Quote Originally Posted by Knurpht View Post
    And. ..... do something about this sig of yours. We're not interested in what people hate, we're interested in what people love. Bashing and ranting has never brought any good.
    all right, all right. but they make me nuts...
    no more gnome!
    @see
    http://www.omgubuntu.co.uk/2012/07/is-the-new-nautilus-a-step-in-the-direction-poll

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •