Results 1 to 8 of 8

Thread: Can't fix wrong time

  1. #1

    Default Can't fix wrong time

    The time is always 1 hour later than the correct time. Timezone is correct Europe/Paris.

    It used be correct. It seems it happens after the daylight save change a few days ago in Europe. And automatically sync with network time doesn't work as it always shows can't connect to time server whichever I choose. OS is up to date.
    openSUSE Leap 15.0

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,274

    Default Re: Can't fix wrong time

    Are you cross-booting with some form of MS Windows?

    When yes, is your "Set hardware clock to" set to local time?

    Do you mean with "automatically sync with network time" that you use NTP?
    Henk van Velden

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Can't fix wrong time

    Quote Originally Posted by bonedriven View Post
    The time is always 1 hour later than the correct time. Timezone is correct Europe/Paris.

    It used be correct. It seems it happens after the daylight save change a few days ago in Europe. And automatically sync with network time doesn't work as it always shows can't connect to time server whichever I choose. OS is up to date.
    Here is a blog post on the subject you might read: What is UTC or GMT Time & a possible issue with openSUSE 12.2 and its solution. - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: Can't fix wrong time

    Thank you for the reply. I have read the well known issue about dual booting win/linux causing problematic time. So UTC is always disabled in openSUSE and I use NTP.

    I guess the main problem now is NTP can't connect any server at all. Whatever server I choose it says can't connect. I don't have connection problem with neither browser nor system update.
    openSUSE Leap 15.0

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,274

    Default Re: Can't fix wrong time

    Quote Originally Posted by bonedriven View Post
    Thank you for the reply. I have read the well known issue about dual booting win/linux causing problematic time. So UTC is always disabled in openSUSE and I use NTP.

    I guess the main problem now is NTP can't connect any server at all. Whatever server I choose it says can't connect. I don't have connection problem with neither browser nor system update.
    Setting the hardware clock is not disabled. but it is set to Local Time instead of UTC. I know of no way to disable the setting of the hardware clock at shutdown.

    In any case, even when you can not synchronise with an NTP server, you shouldn't be exactly a hour off at every reboot. You should then find a slight difference after days of working and shutdow/reboot sequences.

    So we have two things here: find out why you are at every boot an hour off and why you can not work with an NTP server.

    You say your timezone is correct, but please show it. We computer nerds do not believe in people, but in computers :
    Code:
    date
    and for comparison
    Code:
    TZ=UTC date
    And add please what at that moment your wall clock/wrist watch says.
    Henk van Velden

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Can't fix wrong time

    On 2013-04-05 15:26, bonedriven wrote:
    >
    > Thank you for the reply. I have read the well known issue about dual
    > booting win/linux causing problematic time. So UTC is always disabled in
    > openSUSE and I use NTP.


    So you are double booting, using local time on the cmos clock, and the
    official time changed to summer time.

    In this situation it is documented that current openSUSE versions will
    _NOT_ correct the clock when the official clock change happens. It is up
    to you, or to Windows.

    If you boot Windows it will probably detect that the date for the clock
    change has passed, and probably will move the clock one hour. On next
    boot, as Linux picks the time from the CMOS clock, it should be correct.


    If you are using Windows 7 or later (even vista), I would recommend that
    you switch to use UTC time in the CMOS clock. Instructions here:


    SDB:Configuring the clock



    > I guess the main problem now is NTP can't connect any server at all.
    > Whatever server I choose it says can't connect. I don't have connection
    > problem with neither browser nor system update.


    That's a different issue.

    Notice that NTP can reject to update your clock if the error is large. A
    one hour error is large.

    The logs might say.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  7. #7
    Join Date
    Sep 2012
    Location
    The Lost Continent of Atlantis
    Posts
    11

    Default Re: Can't fix wrong time

    ok, i think everybody is missing the point.

    he wants the display in the lower right of his screen to show his local time instead of utc, so he can glance down and see if he is late for work or something.

    all the times settings and such can be confusing.

    it sounds like it is set right, and due to other issues the utc clock is better, but to just DISPLAY your local time in the bottom corner of the screen

    right click on the clock, and go to "digital clock settings" got to time zone and uncheck the UTC box, the clock will now display your local time, if you hover over the clock it will also show you the UTC time

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Can't fix wrong time

    On 2013-04-08 15:56, russ8293 wrote:
    >
    > ok, i think everybody is missing the point.
    >
    > he wants the display in the lower right of his screen to show his local
    > time instead of utc, so he can glance down and see if he is late for
    > work or something.


    That's not how I read his posts.

    In any case, if that's what he wants, he first has to prove that the
    clock in the system and plain CLI is correct, and then the issue of the
    panel clock can be addressed.

    He has to post these commands (starts as plain user, then as root) in a
    terminal:

    Code:
    date
    date --utc
    su -
    hwclock --debug
    date
    date --utc
    cat /etc/adjtime
    and the wall clock time.


    Please use code tags for printouts and commands. Advanced editor, '#'
    button.
    Posting in Code Tags - A Guide


    Of course, we want the whole terminal text, the prompts, the commands
    exactly as typed... all.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •