Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 40

Thread: Another Nvidia good new problem...

  1. #11
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: AW: Re: Another Nvidia good new problem...

    Quote Originally Posted by wolfi323 View Post
    Did you upgrade from 12.2? Then your user already was in the "video" group... Only fresh installs are affexted by this.
    Also, KDE should work fine without direct rendering but it seems GNOME only shows a black screen then.

    Btw. here's the bugreport:
    https://bugzilla.novell.com/show_bug.cgi?id=808319
    Looks like a fix is coming soon via online updates...
    Clean install .
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  2. #12
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Another Nvidia good new problem...

    On 2013-04-04 07:56, F style wrote:
    > And --with all my apologies to mr Caf who has endured me for a long
    > time--, from what I'm seeing, I'm starting to think a relatively crappy
    > opensuse release was released and no one will help, at least not in the
    > correct way.....


    Please consider that we are users helping users; we are not the people
    that created the distribution.

    The problems that people installing the distro are having just after
    release are also new to the volunteer helpers. Until these volunteers
    learn what to do by trial and error of the people doing the
    installations, they can not give you exact and correct info...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  3. #13

    Default Re: Another Nvidia good new problem...

    Quote Originally Posted by caf4926 View Post
    Clean install .
    Well, then either you don't have direct rendering (as I said, KDE should work fine without it) or you _did_ get added to the "video" group somehow...

    What output do you get if you type the following commands in a terminal?
    Code:
    groups
    Code:
    glxinfo | grep direct
    (you may have to install the package "Mesa-demo-x" for the second one)

  4. #14
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Another Nvidia good new problem...

    Code:
    users

    glxinfo | grep direct

    produced nothing
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #15

    Default AW: Re: Another Nvidia good new problem...

    Quote Originally Posted by caf4926 View Post
    Code:
    users
    So you're _not_ in the video group, which means, if you are using the proprietary nvidia driver, direct rendering WILL NOT work.
    This is needed mostly for 3D stuff (and GNOME3 apparently does not work without it).
    So, you should add your user to the "video" group, as per the Release Notes, to make the nvidia driver work correctly.
    Or, if you don't really have problems at the moment, you can just wait for the online update... (should be available in a week or so)

    glxinfo | grep direct

    produced nothing
    Then you don't have glxinfo installed. It's in the package "Mesa-demo-x".

  6. #16
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Another Nvidia good new problem...

    I'll have to check that later
    But I know desktop effects will toggle on no problem (I don't use it most of the time, it's a production machine)
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #17
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Another Nvidia good new problem...

    Installed and got
    Code:
    glxinfo | grep directNVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #18

    Default AW: Re: Another Nvidia good new problem...

    Quote Originally Posted by caf4926 View Post
    Installed and got
    Code:
    glxinfo | grep directNVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    Yeah, that's exactly what the Release Notes entry and the bug report I linked to is about...
    If you would try to run GNOME, you would likely also just get a black screen like the OP does.

    Adding your user to the "video" group should fix that. (and the glxinfo line should return "direct rendering: Yes" then)
    Anyway, if you're satisfied with your system, you don't need to do this... (and it will be resolved by an online update anyway)

    But I really believe the OP's issue would be solved by that.

  9. #19

    Default Re: AW: Re: Another Nvidia good new problem...

    Quote Originally Posted by wolfi323 View Post
    Yeah, that's exactly what the Release Notes entry and the bug report I linked to is about...
    If you would try to run GNOME, you would likely also just get a black screen like the OP does.

    Adding your user to the "video" group should fix that. (and the glxinfo line should return "direct rendering: Yes" then)
    Anyway, if you're satisfied with your system, you don't need to do this... (and it will be resolved by an online update anyway)

    But I really believe the OP's issue would be solved by that.
    There's little reason to chime in supporting good advice, but I can confirm that I've seen that very message, and adding my user to the "video" group resolved it.

  10. #20

    Default Re: Another Nvidia good new problem...

    @Wolfi323:
    Please help me...
    In the release notes it's said that to add my user I have to do this as root:
    Code:
    usermod -a -G video (my_user_name)
    But when? Beofre or after installing the nvidia driver? I've done a clean installation again.

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •