Results 1 to 4 of 4

Thread: Not sure if Quagga Router daemon is running or If i cannot access it

  1. #1

    Question Not sure if Quagga Router daemon is running or If i cannot access it

    I am using opensuse 12.3 and installed Quagga version 0.99.21-3.1.1, from the repositories,

    I tried to access one of the daemons zebra by both ssh and telnet(I had to download and install telnet) .

    connection is refused for telnet as it is the policy in opensuse.

    with ssh, it prompts me for a password, but does not accept the root or user password. also not accepting the password in zebra.conf file. I also tried tried port 2601 which is the default for zebra.


    h61n1:/ # ssh localhost 2601
    Password:
    bash: 2601: command not found
    h61n1:/ # ssh localhost zebra
    Password:
    h61n1:/ # telnet localhost zebra
    telnet: zebra: bad port
    h61n1:/ # telnet localhost 2601
    Trying ::1...
    telnet: connect to address ::1: Connection refused
    Trying 127.0.0.1...
    telnet: connect to address 127.0.0.1: Connection refused
    h61n1:/ #

    Also tried these commands to check if the deamons are running, but i don't think so,

    h61n1:/ # ps -ef | grep quagga
    root 28177 27581 0 02:35 pts/0 00:00:00 grep --color=auto quagga
    h61n1:/ # ps -ef | grep zebra
    root 28179 27581 0 02:35 pts/0 00:00:00 grep --color=auto zebra
    h61n1:/ # ps -ef | grep ospfd
    root 28181 27581 0 02:35 pts/0 00:00:00 grep --color=auto ospfd
    h61n1:/ #


    Most help resourses i can find for this software are for debian based stuff and i tried to follow this tutorial QUAGGA - The Easy Tutorial - How to use Quagga

    But the installed files in opensuse themselves are in different folders than the ones shown in the tutorial, so i am not sure where to look for the initial configuration setup

    I am pretty sure that i am missing something here, any kind of help is appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Not sure if Quagga Router daemon is running or If i cannot access it

    I am not a Quagga user, thus my answers are simply based upon the fact that you say you installed soemthing that should run as a deamon.

    Normaly you will find system daemons in YaST > System > sSystem services (runlevel), wher eyou can switch them on/off. Did you go there?

    When I read corrctly, I see that you use SSH to login somewhere as root. Never log in as root! Specialy not remote. Not even when using SSH.

    And last, please next time that you post computer text here, do so between CODE tags. You get them by suing the # button in the toolbar of the post editor.
    Henk van Velden

  3. #3

    Default Re: Not sure if Quagga Router daemon is running or If i cannot access it

    Thank you Henk,

    I was able to start the daemons from YaST and interestingly enough I was also able to telnet to them. (Note that I am only Telneting or SSHing to daemons running in my own PC, But i will never SSH as Root again anyways). will use the code tags also. thank you once again.

    Opensuse is awesome as usual

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Not sure if Quagga Router daemon is running or If i cannot access it

    You are welcome.

    It seems that you are not new to Unix/Linux systems in general, but that may be openSUSE (this is the "correct" way to spell it) is new to you. Look at what YaST has to offer you as system management tool. It is allways usefull when you have to do something and you remember: "there was something in YaST wasn't there?"
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •