Results 1 to 7 of 7

Thread: 12.3 hangs and won't let me boot to the desktop after upgrading

  1. #1

    Exclamation 12.3 hangs and won't let me boot to the desktop after upgrading

    Dear OpenSuse fellow users,
    I have this problem after I performed an OpenSuse 12.2-->12.3 upgrade as described here:

    https://en.opensuse.org/SDB:System_upgrade

    When I rebooted I noticed the following on the console:

    systemd-fsck[546]: /dev/md2: clean, 44151/6815744 files, 13616319/27262702 blocks
    _ (blinks)

    I can ssh into the machine but don't know what's wrong and how to fix it.

    I have a raid array which looks ok :

    cat /proc//mdstat
    Personalities : [raid1] [raid0] [raid10] [raid6] [raid5] [raid4]
    md2 : active raid1 sdb3[1] sda3[0]
    109050808 blocks super 1.0 [2/2] [UU]
    bitmap: 0/1 pages [0KB], 65536KB chunk

    md0 : active raid1 sda1[0] sdb1[1]
    41993144 blocks super 1.0 [2/2] [UU]
    bitmap: 0/1 pages [0KB], 65536KB chunk

    md1 : active raid1 sda2[0] sdb2[1]
    5244916 blocks super 1.0 [2/2] [UU]
    bitmap: 0/1 pages [0KB], 65536KB chunk

    unused devices: <none>

    The last part dmesg shows this:

    [ 10.036811] Disabling lock debugging due to kernel taint
    [ 10.060895] ACPI: PCI Interrupt Link [SGRU] enabled at IRQ 20
    [ 10.060930] nvidia 0000:02:00.0: setting latency timer to 64
    [ 10.060939] vgaarb: device changed decodes: PCI:0000:02:00.0,olddecodes=io+mem,decodes=nonewns=io+mem
    [ 10.062725] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 310.32 Mon Jan 14 14:41:13 PST 2013
    [ 10.085223] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:07.0/sound/card0/input6
    [ 10.085401] input: HDA NVidia Line as /devices/pci0000:00/0000:00:07.0/sound/card0/input7
    [ 10.085538] input: HDA NVidia Front Mic as /devices/pci0000:00/0000:00:07.0/sound/card0/input8
    [ 10.085668] input: HDA NVidia Rear Mic as /devices/pci0000:00/0000:00:07.0/sound/card0/input9
    [ 10.085796] input: HDA NVidia Front Headphone as /devices/pci0000:00/0000:00:07.0/sound/card0/input10
    [ 10.085925] input: HDA NVidia Line Out Side as /devices/pci0000:00/0000:00:07.0/sound/card0/input11
    [ 10.086078] input: HDA NVidia Line Out CLFE as /devices/pci0000:00/0000:00:07.0/sound/card0/input12
    [ 10.086212] input: HDA NVidia Line Out Surround as /devices/pci0000:00/0000:00:07.0/sound/card0/input13
    [ 10.086349] input: HDA NVidia Line Out Front as /devices/pci0000:00/0000:00:07.0/sound/card0/input14
    [ 10.699728] Adding 5244912k swap on /dev/md1. Priority:-1 extents:1 across:5244912k
    [ 10.844121] md: bind<sda3>
    [ 10.875147] ALSA clock.c:228 2:3:1: cannot set freq 16000 to ep 0x86
    [ 11.145767] md: bind<sdb3>
    [ 11.154358] md/raid1:md2: active with 2 out of 2 mirrors
    [ 11.154792] created bitmap (1 pages) for device md2
    [ 11.155277] md2: bitmap initialized from disk: read 1 pages, set 0 of 1664 bits
    [ 11.275194] md2: detected capacity change from 0 to 111668027392
    [ 11.319576] md2: unknown partition table
    [ 11.875149] ALSA clock.c:228 2:3:2: cannot set freq 24000 to ep 0x86
    [ 12.875150] ALSA clock.c:228 2:3:3: cannot set freq 32000 to ep 0x86
    [ 13.875149] ALSA clock.c:228 2:3:4: cannot set freq 48000 to ep 0x86
    [ 13.875718] ALSA mixer.c:887 5:2: cannot get min/max values for control 2 (id 5)
    [ 13.876904] ALSA mixer.c:887 5:2: cannot get min/max values for control 2 (id 5)
    [ 13.877285] uvcvideo: Found UVC 1.00 device <unnamed> (046d:081b)
    [ 13.877439] usbcore: registered new interface driver snd-usb-audio
    [ 13.891742] input: UVC Camera (046d:081b) as /devices/pci0000:00/0000:00:04.1/usb2/2-5/2-5:1.0/input/input15
    [ 13.891896] usbcore: registered new interface driver uvcvideo
    [ 13.891900] USB Video Class driver (1.1.1)
    [ 15.690954] EXT4-fs (md2): mounted filesystem with ordered data mode. Opts: acl,user_xattr
    [ 15.797227] systemd-journald[263]: Received SIGUSR1
    [ 16.975624] vboxpci: IOMMU not found (not registered)
    [ 20.783882] NET: Registered protocol family 17
    [ 20.800197] forcedeth 0000:00:0a.0: irq 41 for MSI/MSI-X
    [ 20.800233] forcedeth 0000:00:0a.0 eth0: MSI enabled
    [ 30.288200] NVRM: API mismatch: the client has the version 304.64, but
    [ 30.288200] NVRM: this kernel module has the version 310.32. Please
    [ 30.288200] NVRM: make sure that this kernel module and all NVIDIA driver
    [ 30.288200] NVRM: components have the same version.

    What seems to be wrong?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,761

    Default Re: 12.3 hangs and won't let me boot to the desktop after upgrading

    looks like you need to reinstall NVIDIA driver

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: 12.3 hangs and won't let me boot to the desktop after upgrading

    Am 31.03.2013 18:56, schrieb djangoxl:
    > [ 30.288200] NVRM: API mismatch: the client has the version 304.64,
    > but
    > [ 30.288200] NVRM: this kernel module has the version 310.32. Please
    > [ 30.288200] NVRM: make sure that this kernel module and all NVIDIA
    > driver

    Looks like a mixture of G02 and G03 drivers, I had the same on a PC
    which I updated with zypper dup.
    Remove all! nvidia dirvers (all with G02 and G03 in their name), after
    that is done install the G03 drivers again.

    --
    PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
    ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.0 | HD 3000
    HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,761

    Default Re: 12.3 hangs and won't let me boot to the desktop after upgrading

    I had no luck with the G03 and I also somehow had both installed. Not sure how.

    I have a 6800+ and G03 did not work had to use G02 which works fine. Not knowing the card for the OP I'd suggest experimenting a bit. You may have to to some install/removal from command line if Desktop does not start.

  5. #5

    Default Re: 12.3 hangs and won't let me boot to the desktop after upgrading SOLVED

    Quote Originally Posted by gogalthorp View Post
    I had no luck with the G03 and I also somehow had both installed. Not sure how.

    I have a 6800+ and G03 did not work had to use G02 which works fine. Not knowing the card for the OP I'd suggest experimenting a bit. You may have to to some install/removal from command line if Desktop does not start.
    Thanks all for your help, but removing the nvidia drivers made my machine boot to the desktop again:

    sudo zypper remove *nvidia*
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    The following NEW packages are going to be installed:
    libdrm2-32bit libdrm_intel1-32bit libdrm_nouveau2-32bit libdrm_radeon1-32bit libpciaccess0-32bit libxcb-glx0-32bit libXxf86vm1-32bit Mesa-32bit Mesa-libGL1-32bit
    Mesa-libglapi0-32bit

    The following packages are going to be REMOVED:
    nvidia-computeG02 nvidia-computeG03 nvidia-gfxG02-kmp-desktop nvidia-gfxG03-kmp-desktop x11-video-nvidiaG02 x11-video-nvidiaG03

    10 new packages to install, 6 to remove.
    Overall download size: 21.2 MiB. After the operation, 345.5 MiB will be freed.
    Continue? [y/n/p/?] (y):
    Retrieving package Mesa-libglapi0-32bit-9.0.2-34.3.1.x86_64 (1/10), 39.4 KiB ( 85.8 KiB unpacked)
    Retrieving: Mesa-libglapi0-32bit-9.0.2-34.3.1.x86_64.rpm .................................................................................................................[done]
    Retrieving package libXxf86vm1-32bit-1.1.2-4.1.1.x86_64 (2/10), 9.8 KiB ( 17.6 KiB unpacked)
    Retrieving: libXxf86vm1-32bit-1.1.2-4.1.1.x86_64.rpm .....................................................................................................................[done]
    Retrieving package libdrm2-32bit-2.4.42-1.1.1.x86_64 (3/10), 33.6 KiB ( 49.6 KiB unpacked)
    Retrieving: libdrm2-32bit-2.4.42-1.1.1.x86_64.rpm ........................................................................................................................[done]
    Retrieving package libpciaccess0-32bit-0.13.1-4.1.1.x86_64 (4/10), 19.1 KiB ( 37.7 KiB unpacked)
    Retrieving: libpciaccess0-32bit-0.13.1-4.1.1.x86_64.rpm ..................................................................................................................[done]
    Retrieving package libxcb-glx0-32bit-1.9-2.1.1.x86_64 (5/10), 23.7 KiB ( 97.5 KiB unpacked)
    Retrieving: libxcb-glx0-32bit-1.9-2.1.1.x86_64.rpm .......................................................................................................................[done]
    Retrieving package libdrm_radeon1-32bit-2.4.42-1.1.1.x86_64 (6/10), 32.3 KiB ( 45.7 KiB unpacked)
    Retrieving: libdrm_radeon1-32bit-2.4.42-1.1.1.x86_64.rpm .................................................................................................................[done]
    Retrieving package libdrm_nouveau2-32bit-2.4.42-1.1.1.x86_64 (7/10), 26.1 KiB ( 25.6 KiB unpacked)
    Retrieving: libdrm_nouveau2-32bit-2.4.42-1.1.1.x86_64.rpm ................................................................................................................[done]
    Retrieving package libdrm_intel1-32bit-2.4.42-1.1.1.x86_64 (8/10), 64.6 KiB (134.8 KiB unpacked)
    Retrieving: libdrm_intel1-32bit-2.4.42-1.1.1.x86_64.rpm ..................................................................................................................[done]
    Retrieving package Mesa-32bit-9.0.2-34.3.1.x86_64 (9/10), 20.8 MiB ( 77.3 MiB unpacked)
    Retrieving: Mesa-32bit-9.0.2-34.3.1.x86_64.rpm ...............................................................................................................[done (1.6 MiB/s)]
    Retrieving package Mesa-libGL1-32bit-9.0.2-34.3.1.x86_64 (10/10), 127.9 KiB (374.2 KiB unpacked)
    Retrieving: Mesa-libGL1-32bit-9.0.2-34.3.1.x86_64.rpm ........................................................................................................[done (1.1 MiB/s)]
    ( 1/16) Removing x11-video-nvidiaG02-304.64-27.1 .........................................................................................................................[done]
    ( 2/16) Removing x11-video-nvidiaG03-310.32-15.1 .........................................................................................................................[done]
    ( 3/16) Removing nvidia-computeG03-310.32-15.1 ...........................................................................................................................[done]
    ( 4/16) Removing nvidia-computeG02-304.64-27.1 ...........................................................................................................................[done]
    ( 5/16) Removing nvidia-gfxG03-kmp-desktop-310.32_k3.7.9_1.1-15.3 ........................................................................................................[done]
    Additional rpm output:
    make: Entering directory `/usr/src/kernel-modules/nvidia-310.32-desktop'
    make: Leaving directory `/usr/src/kernel-modules/nvidia-310.32-desktop'


    ( 6/16) Removing nvidia-gfxG02-kmp-desktop-304.64_k3.7.9_1.1-26.3 ........................................................................................................[done]
    Additional rpm output:
    make: Entering directory `/usr/src/kernel-modules/nvidia-304.64-desktop'
    make: Leaving directory `/usr/src/kernel-modules/nvidia-304.64-desktop'


    ( 7/16) Installing: Mesa-libglapi0-32bit-9.0.2-34.3.1 ....................................................................................................................[done]
    ( 8/16) Installing: libXxf86vm1-32bit-1.1.2-4.1.1 ........................................................................................................................[done]
    ( 9/16) Installing: libdrm2-32bit-2.4.42-1.1.1 ...........................................................................................................................[done]
    (10/16) Installing: libpciaccess0-32bit-0.13.1-4.1.1 .....................................................................................................................[done]
    (11/16) Installing: libxcb-glx0-32bit-1.9-2.1.1 ..........................................................................................................................[done]
    (12/16) Installing: libdrm_radeon1-32bit-2.4.42-1.1.1 ....................................................................................................................[done]
    (13/16) Installing: libdrm_nouveau2-32bit-2.4.42-1.1.1 ...................................................................................................................[done]
    (14/16) Installing: libdrm_intel1-32bit-2.4.42-1.1.1 .....................................................................................................................[done]
    (15/16) Installing: Mesa-32bit-9.0.2-34.3.1 ..............................................................................................................................[done]
    (16/16) Installing: Mesa-libGL1-32bit-9.0.2-34.3.1 .......................................................................................................................[done]
    There are some running programs that use files deleted by recent upgrade. You may wish to restart some of them. Run 'zypper ps' to list these programs.
    Last edited by djangoxl; 31-Mar-2013 at 13:31. Reason: Solved

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,761

    Default Re: 12.3 hangs and won't let me boot to the desktop after upgrading

    You are probably running under neuveau then. This is fine if it works but you won't have the full 3d accel that that NVIDIA driver gives you

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: 12.3 hangs and won't let me boot to the desktop after upgrading

    Am 31.03.2013 22:36, schrieb djangoxl:
    > The following packages are going to be REMOVED:
    > nvidia-computeG02 nvidia-computeG03 nvidia-gfxG02-kmp-desktop
    > nvidia-gfxG03-kmp-desktop x11-video-nvidiaG02 x11-video-nvidiaG03


    That shows that you had an incompatible mix.

    --
    PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
    ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.0 | HD 3000
    HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •