Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Shift+Space combination

  1. #1

    Default Shift+Space combination

    I've recently installed OpenSuse 11.3. I've noticed that combination of SHIFT + SPACE creates some kind of invisible character (but not space).

    This combination is very easy to hit accidentally and very annoying because i see syntax errors all over the place (e.g. code compilation, database queries). Is it possible to disable that shortcut?


    Best regards,
    Aleksander

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Shift+Space combination

    You mean like this sort of invisible character? Kind of like a space. I can't see any invisible characters
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Shift+Space combination

    Quote Originally Posted by caf4926 View Post
    You mean like this sort of invisible character? Kind of like a space. I can't see any invisible characters
    In fact they are so invisible the forum not only didn't show them it removed the empty space I put there
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Shift+Space combination

    Quote Originally Posted by datadiscovery View Post
    I've recently installed OpenSuse 11.3. I've noticed that combination of SHIFT + SPACE creates some kind of invisible character (but not space).

    This combination is very easy to hit accidentally and very annoying because i see syntax errors all over the place (e.g. code compilation, database queries). Is it possible to disable that shortcut?


    Best regards,
    Aleksander
    There are a few things to say here:

    1) openSUSE 11.3 is way out of support. Why not install 12.3? The facct taht 11.3 is not supported anymore also means that very few people here have it running, thus very few people will be able to cjeck what happens when they try this on their own system.

    2) Do you do this loged in on the console, or are you using a desktop environment.? When the latter is the case, you should of course tell this and also which one you use. All these things can be different per DE used.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Shift+Space combination

    On 03/31/2013 12:56 PM, caf4926 wrote:
    >
    > caf4926;2543015 Wrote:
    >> You mean like this sort of invisible character?
    >> Kind of like a space. I can't see any invisible characters

    >
    > In fact they are so invisible the forum not only didn't show them it
    > removed the empty space I put there


    only the vBulletin/html based forum software removed the invisible
    characters...as you can see above the space created remains in nntp!

    i took a screen shot of what a space and what a shift+space looks
    like in hex, and both appear to be "20" in hex, so they look to be
    identical both in ascii and hex... i don't know what they look like
    in just ones and zeros..

    and, i can't post the images of my experiment because susepaste.org
    just said to me (rudely and incorrectly): "An Error Was Encountered"
    and "You are spammer!!!"

    so, where to report problems at susepaste.org is not listed on either
    susepaste.org *or* https://en.opensuse.org/openSUSE:Services_help [/sigh]

    --
    dd
    openSUSE®, the "German Engineered Automobile" of operating systems!

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: Shift+Space combination

    In my case a Shift+space just creates a space. If on 12.3 you may have been hit by the choice for US International as the default keyboard. Change this in Yast to "US English" and the unwanted keycombo's will disappear.

    @DD. the hex 20 is the space char.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Shift+Space combination

    On 2013-03-31 12:36, datadiscovery wrote:
    >
    > I've recently installed OpenSuse 11.3.


    Recently? 11.3 is obsolete and not maintained.

    > I've noticed that combination of
    > SHIFT + SPACE creates some kind of invisible character (but not space).


    Why don't you create a file with only those invisible spaces, and then
    have a look at it with "hexdump -C file"? Then you can post here that
    line inside code tags and we can see what character it actually is.

    And what editor and what desktop you are using might help us. I tried
    with gedit, and I could not reproduce your problem. Maybe your editor
    uses shift-space for "unbreakable space", which is something useful on
    some editors.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  8. #8

    Default Re: Shift+Space combination

    I apologize, it is of course 12.3.

    The keyboard layout is English (US). I'm using the default gnome env. I have some images for you:

    ghex - http://ubuntuone.com/6e8v947NRXJ44JV07vbWbN
    netbeans editor - http://ubuntuone.com/1o6mS1xMa0bUyatPWtLjRL

    The character is c2a0 (NO-BREAK SPACE) and this must be a system-wide setting because I can produce it even in terminal. Is it possible to turn it off?

    Thanks to community for super fast reaction.

    Best regards
    Alek

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: Shift+Space combination

    Quote Originally Posted by datadiscovery View Post
    I apologize, it is of course 12.3.

    The keyboard layout is English (US). I'm using the default gnome env. I have some images for you:

    ghex - http://ubuntuone.com/6e8v947NRXJ44JV07vbWbN
    netbeans editor - http://ubuntuone.com/1o6mS1xMa0bUyatPWtLjRL

    The character is c2a0 (NO-BREAK SPACE) and this must be a system-wide setting because I can produce it even in terminal. Is it possible to turn it off?

    Thanks to community for super fast reaction.

    Best regards
    Alek
    In a terminal says nothing about system-wide. Opening "konsole" for example uses the user's settings. Another thing is, if this happens in the konsole. That would mean it's systemwide. Could you tell us a bit more about the keyboard itself?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Shift+Space combination

    There is no need too jump throughall sorts of hoops to see what tthe hex value is:
    Code:
    henk@boven:~> echo " " | od -x
    0000000 0a20
    0000002
    henk@boven:~>
    Which is in fact 200a, which is an ASCII Space and an ASCII Line-Feed.
    Between the " and " I typed of course a Shift-Space.

    Did you try this on a console login (Crel-Shift-F1)? That is where you can see if this is system wide.

    You are using Gnome, which is of course not system wide, but at the most Gnome default wide, but allways Gnome user wide.

    I am not using Gnome. Thus when you can not reproduce this at the real console, I am afraid that more Gnome loving people must go on with this phenomenon.
    Henk van Velden

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •