Results 1 to 3 of 3

Thread: No openGL with Nvidia proprietary driver (current/310.xx)

  1. #1

    Default No openGL with Nvidia proprietary driver (current/310.xx)

    Hi all,

    I'm having a strange issue regarding openGL and the current nvidia driver under 12.3. I found this after trying to enable some effects, and was presented with an error that certain effects couldn't be enabled because they require openGL. I've not had this issue while using the same driver in other distros. Also, there are no obvious issues when I browse through the nvidia x server settings. In there, openGL appears to be enabled and I am able to make changes to the settings. I saw in an old post that someone with a similar issue solved it by adding themselves to the 'video' group, but that didn't help in my case and in fact made things a little worse (now task bar mouse-over previews are broken.) Anyway, any ideas?

  2. #2

    Default Re: No openGL with Nvidia proprietary driver (current/310.xx)

    Solved.

    I guess I didn't poke around enough. The driver wasn't the issue, it was the effects settings. Desktop effects -> advanced -> composting type was set as xrender by default. I changed to openGL and effects worked fine.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: No openGL with Nvidia proprietary driver (current/310.xx)

    Can you try something...

    Create a new user login, just to test. Normally in KDE effects will be on automatically when your hardware is supported. Report back
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •