Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: SUSE 12.3 - How to auto start services...?

  1. #21

    Default Re: SUSE 12.3 - How to auto start services...?

    Quote Originally Posted by jdmcdaniel3 View Post
    So for step 2, yes you can move /etc/init.d/mediatomb to /usr/sbin, as this is where I moved the dkms_autoinstaller bash script from /etc/init.d. For step 3 it should work there, but if you wanted to have a /lib/systemd/applications folder, you can do that. The systemctl enable command must just point to its location, such as in systemctl enable /lib/systemd/applications/mediatomb. When using my example service file, make sure to remove the line that says ExecStartPre=/usr/local/bin/userfix from the service file as it was intended to allow you to run a bash script for any purpose before I would start dkms. Also consider that once you make it work manually, you could modify the make-dkms-installer to do your bidding by installing the mediatomb stuff instead. After mediatomb works, consider modifying the bash script I wrote, make your best effort and post it back here. I can make any other required changes. Once complete, you can run it on each openSUSE install and get mediatomb working again. That is what I have done so far with dkms. On each new openSUSE install, I install dkms and try to make it run under systemd with no modifications. If its a no go, I just run the make-dkms-installer and I am back in business. No need to remember exact details of how you did it before and you can just look back at the script if there is any doubt. Go for the first part and make it work under systemd, then we can look at the rest.

    Thank You,

    I have been reading through the documentation on openSUSE 12.3: Chapter 8. The systemd daemon and it is saying to make all changes in /etc/systemd never in /lib/systemd/ due to overwrites when systemd is updated.

  2. #22

    Default Re: SUSE 12.3 - How to auto start services...?

    I have also found that xinetd won't survive a reboot either. I had my vnc servers fail to start after a reboot because for some reason the system isn't keeping the service enabled.
    Xinetd is enabled in yast and vnc is enabled in xinetd. Reboot and everything is back to the way it was before. Disabled and having to be started by hand.
    Is there something seriously wrong with the way the OS is operating by not honoring the savings? Is yast completely broken?

  3. #23

    Default Re: SUSE 12.3 - How to auto start services...?

    On 04/08/2013 03:36 PM, diensthunds pecked at the keyboard and wrote:
    > I have also found that xinetd won't survive a reboot either. I had my
    > vnc servers fail to start after a reboot because for some reason the
    > system isn't keeping the service enabled.
    > Xinetd is enabled in yast and vnc is enabled in xinetd. Reboot and
    > everything is back to the way it was before. Disabled and having to be
    > started by hand.
    > Is there something seriously wrong with the way the OS is operating by
    > not honoring the savings?


    Yes, it is using systemd now and not everything has been ported yet.

    > Is yast completely broken?

    Just the part that deals with system services, it hasn't been modified
    to use systemd.

    Ken

  4. #24
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: SUSE 12.3 - How to auto start services...?

    On 2013-04-08 21:46, Ken Schneider wrote:
    > On 04/08/2013 03:36 PM, diensthunds pecked at the keyboard and wrote:
    >> I have also found that xinetd won't survive a reboot either. I had my
    >> vnc servers fail to start after a reboot because for some reason the
    >> system isn't keeping the service enabled.
    >> Xinetd is enabled in yast and vnc is enabled in xinetd. Reboot and
    >> everything is back to the way it was before. Disabled and having to be
    >> started by hand.
    >> Is there something seriously wrong with the way the OS is operating by
    >> not honoring the savings?

    >
    > Yes, it is using systemd now and not everything has been ported yet.


    Does that means that services that we need to start via xinetd will not
    be started any more? How do we cope with that?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  5. #25
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,823
    Blog Entries
    15

    Default Re: SUSE 12.3 - How to auto start services...?

    On Mon 08 Apr 2013 08:13:06 PM CDT, Carlos E. R. wrote:

    On 2013-04-08 21:46, Ken Schneider wrote:
    > On 04/08/2013 03:36 PM, diensthunds pecked at the keyboard and wrote:
    >> I have also found that xinetd won't survive a reboot either. I had my
    >> vnc servers fail to start after a reboot because for some reason the
    >> system isn't keeping the service enabled.
    >> Xinetd is enabled in yast and vnc is enabled in xinetd. Reboot and
    >> everything is back to the way it was before. Disabled and having to
    >> be started by hand.
    >> Is there something seriously wrong with the way the OS is operating
    >> by not honoring the savings?

    >
    > Yes, it is using systemd now and not everything has been ported yet.


    Does that means that services that we need to start via xinetd will not
    be started any more? How do we cope with that?

    Hi
    Read the systemctl output?
    Code:
    systemctl status xinetd
    
    xinetd.service - LSB: Starts the xinet daemon. Be aware that xinetd doesn't start if no service is configured to run under it.
    To enable xinetd services go to YaST Network Services (xinetd) section.
    
    Loaded: loaded (/etc/init.d/xinetd) Active: inactive (dead)
    CGroup: name=systemd:/system/xinetd.service
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.3 (x86_64) Kernel 3.7.10-1.1-desktop
    up 3:45, 4 users, load average: 0.10, 0.10, 0.13
    CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile


  6. #26

    Default Re: SUSE 12.3 - How to auto start services...?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Read the systemctl output?
    Code:
    systemctl status xinetd
    
    xinetd.service - LSB: Starts the xinet daemon. Be aware that xinetd doesn't start if no service is configured to run under it.
    To enable xinetd services go to YaST Network Services (xinetd) section.
    
    Loaded: loaded (/etc/init.d/xinetd) Active: inactive (dead)
    CGroup: name=systemd:/system/xinetd.service
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.3 (x86_64) Kernel 3.7.10-1.1-desktop
    up 3:45, 4 users, load average: 0.10, 0.10, 0.13
    CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile
    Ok so for mediatomb or minidlna I can understand perhaps they just haven't been written to startup the way systemd expects them to be and they are failing to load because of this. However systemd was / is supposed to be backwards compatible with the old sys v scripts (to a point).
    For xinetd to not work though? And I did enable my vnc server which runs under xinetd so xinetd should start when a vnc request is made, however it's not. So what's the work around there?

    When will the work on fixing yast be done so that yast can enable system services like it is supposed to? And why was it released to begin with if it wasn't working correctly? Yast is one of the main strong points of openSUSE.

  7. #27
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: SUSE 12.3 - How to auto start services...?

    On 2013-04-08 23:06, diensthunds wrote:
    > For xinetd to not work though? And I did enable my vnc server which
    > runs under xinetd so xinetd should start when a vnc request is made,
    > however it's not. So what's the work around there?


    As I understand it, xinetd should be started if vnc is configured under
    it. It is xinetd who would then start vnc when there is a connection
    attempt.


    > When will the work on fixing yast be done so that yast can enable
    > system services like it is supposed to?


    Maybe one or two years. :-(

    > And why was it released to begin
    > with if it wasn't working correctly? Yast is one of the main strong
    > points of openSUSE.


    Indeed.

    It doesn't look like SUSE is going to hire devs.

    Apparently, yast uses its own language, named "YCP". Contributors need
    to learn ycp first. So there is a plan to create a translator from ycp
    to ruby, and this has to be tested and then the migration finished.

    Source:
    YaST hurdles


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  8. #28

    Default Re: SUSE 12.3 - How to auto start services...?

    Quote Originally Posted by jdmcdaniel3 View Post
    You know if mediatomb does not start on its own, you could place a start command in the after.local script, after you activate per this blog: systemd and using the after.local script in openSUSE 12.1 - Blogs - openSUSE Forums

    Or, you could do the same thing with mediatomb as I did with dkms and move it over to a real systemd service. Have a look how I did this here: DKMS & systemd - How to get Dynamic Kernel Module Support to work in openSUSE 12.1 - Blogs - openSUSE Forums

    While the former may be the easiest, do give it a try, the latter is not that big a deal. With a few name changes, you could use my very script to convert mediatomb.

    Thank You,
    Have tried your procedures to a T for the after-local.service and it's till failing to bring up the mediatomb service.

  9. #29
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: SUSE 12.3 - How to auto start services...?

    Quote Originally Posted by diensthunds View Post
    Have tried your procedures to a T for the after-local.service and it's till failing to bring up the mediatomb service.
    So it is curious that a command run from terminal works and does not work from a bash script. You can also put it in the boot.local file to see if it matters. I have had issues with the network not being up at boot time stopping Samba smb/nmb and cifs mounts from the fstab file. I have no idea if the network condition can make this not work or not. By the way, just before your command, put in an echo command like 'echo "mediatob was just started ..."' for instances.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •