Results 1 to 3 of 3

Thread: Unable to get postgresql to work

  1. #1

    Default Unable to get postgresql to work

    I've been using Kubuntu for almost 1.5 year and just switched to openSUSE yesterday. I tried installing postgres but it's not working. I'm getting the following message when opening postgres in konsole:

    nayar@linux-2w4s:~> postgrespostgres does not know where to find the server configuration file.
    You must specify the --config-file or -D invocation option or set the PGDATA environment variable.
    What am i supposed to do? ON kubuntu, once you install postgresql, it runs on localhost automatically

  2. #2

    Default Re: Unable to get postgresql to work

    Go to YaST admin tool, and choice System Service(Runlevel), then enable service(PostgreSQL) and save configuration.

    p.s. /var/lib/pgsql/data/ -- pg_hba.cong and postgresql.conf
    if you want to try(beta):

  3. #3

    Default Re: Unable to get postgresql to work

    I followed this guide Running PostgreSQL on openSUSE |

    Then i uncommented some lines in postgres .conf files then it worked.

    Thanks for the tip.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts