Results 1 to 4 of 4

Thread: NVIDIA raid don't work with kernel 3.8

  1. #1
    Join Date
    Jan 2010
    Location
    Ukraine, Kharkov
    Posts
    113

    Question NVIDIA raid don't work with kernel 3.8

    I have a motherboard ASUS M2N32-SLI DELUXE with chipset NVIDIA nForce ® 590 SLI ™ MCP (defined as the MCP55) with built-in hardware RAID which I have configured as a RAID 0 of 4-HDD

    When using kernel 3.8 in the repository Index of /repositories/Kernel:/stable/standard
    I no longer identificate raid with a message at boot

    Code:
    ERROR: nvidia: wrong # of devices in RAID set "nvidia_ieigdchd" [1/4] on /dev/sda
    ERROR: removing inconsistent RAID set "nvidia_ieigdchd"
    ERROR: no RAID set found
    In this case, the base kernel 3.7.10 works fine.

    What's the problem? (In the kernel itself, or in the configuration)
    Whom and where (Kernel or openSUSE) to write a bug report? (give me link directly pleace)
    And is maybe it some kind of boot options, or editing boot scripts to solve the problem?
    openSUSE Tumbleweed | KDE 4

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: NVIDIA raid don't work with kernel 3.8

    On 03/31/2013 02:56 PM, ILYA INDIGO wrote:
    > In this case, the base kernel 3.7.10 works fine.


    i guess each kernel module to drive that raid is compiled to work
    within one particular kernel, and you still have one built for 3.7

    or, have you changed it to one built for 3.8?

    if not, you are not encountering a bug!

    i would not know if you can fetch a ready to run driver module from
    ASUS, or if they provide the source so you can compile it locally..

    maybe it will eventually be available from packman...have you looked
    there?

    there is a note on the Tumbleweed page
    <https://en.opensuse.org/Tumbleweedhttps://en.opensuse.org/Tumbleweed> about
    who should not use it:
    Due to the Linux kernel being updated very frequently, users who rely
    on proprietary graphic drivers should not use the Tumbleweed
    repository unless they are familiar with updating these drivers from
    source on their own . . . At this point there is no guarantee to have
    all additional modules available in the stable release like for
    Vmware or Virtualbox. And while the Packman Tumbleweed Essential
    repository attempts to deliver them there is no guarantee they will
    always succeed due to the incompatibilities with the quickly
    advancing Linux Kernel. The problems with proprietary Graphics
    drivers are similar and there is no guarantee they will work
    tomorrow, even if they do today. If you don't know how to compile
    your own additional kernel modules and you don't wish to learn or
    keep a very close eye on what is being updated, please don't use
    Tumbleweed.
    --
    dd
    openSUSE®, the "German Engineered Automobile" of operating systems!
    http://tinyurl.com/DD-Caveat

  3. #3
    Join Date
    Jan 2010
    Location
    Ukraine, Kharkov
    Posts
    113

    Default Re: NVIDIA raid don't work with kernel 3.8

    I did not understand anything of what you wrote here.
    Quote Originally Posted by DenverD View Post
    On 03/31/2013 02:56 PM, ILYA INDIGO wrote:
    > In this case, the base kernel 3.7.10 works fine.


    i guess each kernel module to drive that raid is compiled to work
    within one particular kernel, and you still have one built for 3.7

    or, have you changed it to one built for 3.8?
    If I install kernel 3.8, it is natural with it and installs its modules 3.8.

    Quote Originally Posted by DenverD View Post
    maybe it will eventually be available from packman...have you looked
    there?
    What is relevant to the multimedia repository Packman kernel modules?
    Quote Originally Posted by DenverD View Post
    there is a note on the Tumbleweed page
    <https://en.opensuse.org/Tumbleweedhttps://en.opensuse.org/Tumbleweed> about
    who should not use it:
    I know how to use the Tumbleweed.
    openSUSE Tumbleweed | KDE 4

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: NVIDIA raid don't work with kernel 3.8

    On 03/31/2013 04:56 PM, ILYA INDIGO wrote:
    > If I install kernel 3.8, it is natural with it and installs its modules
    > 3.8.


    no, if the modules are for proprietary hardware they will not be
    installed automatically....openSUSE does not distribute proprietary
    software/drivers/modules..

    --
    dd


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •