Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: openSUSE 12.3: Suspend Requires Root Permission

  1. #1

    Default openSUSE 12.3: Suspend Requires Root Permission

    I running into an issue where when I attempt to suspend my Gnome desktop, the system freezes for about 20-30 seconds, and then prompts me for my root password in order to suspend the system. Has anyone else seen this problem?

  2. #2

    Default Re: openSUSE 12.3: Suspend Requires Root Permission

    Hi bwilson30,

    Quote Originally Posted by bwilson30 View Post
    I running into an issue where when I attempt to suspend my Gnome desktop, the system freezes for about 20-30 seconds, and then prompts me for my root password in order to suspend the system. Has anyone else seen this problem?
    I've had the same with KDE and after my 12.2 to 12.3 upgrade. It seemed to be a matter of policykit settings.

    Sorry that I cannot offer details for the Gnome environment, but as it may be similar in this matter to KDE, here're where I was able to change things under KDE... and I'm translating from German NLS here :

    In the "systems settings" application, I chose "system administration" - "action permissions" (first entry in sys adm). There, under "org.freedesktop" - "The UPower project" - "Suspend the system" (AKA org.freedesktop.upower.suspend) I had a "local authorization" that I deleted and set the implicit authorizations to "yes" (all three - you may want to set up more limiting settings). After a restart, "suspend" worked without requiring any password input.

    Regards,
    Jens

  3. #3

    Default Re: openSUSE 12.3: Suspend Requires Root Permission

    Thanks for the response. I'm not sure what the problem was, but I think an update regarding the permissions fixed the issue. I wish I had paid closer attention to what the update was.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: openSUSE 12.3: Suspend Requires Root Permission

    On 04/05/2013 12:36 AM, bwilson30 wrote:
    > I wish I had paid
    > closer attention to what the update was.


    if you know when it was fixed, you can probably find it in
    /var/log/zypp/history

    because each action has a date/time listed..

    --
    dd


  5. #5

    Default Re: openSUSE 12.3: Suspend Requires Root Permission

    Quote Originally Posted by jmozdzen View Post
    Hi bwilson30,



    I've had the same with KDE and after my 12.2 to 12.3 upgrade. It seemed to be a matter of policykit settings.

    Sorry that I cannot offer details for the Gnome environment, but as it may be similar in this matter to KDE, here're where I was able to change things under KDE... and I'm translating from German NLS here :

    In the "systems settings" application, I chose "system administration" - "action permissions" (first entry in sys adm). There, under "org.freedesktop" - "The UPower project" - "Suspend the system" (AKA org.freedesktop.upower.suspend) I had a "local authorization" that I deleted and set the implicit authorizations to "yes" (all three - you may want to set up more limiting settings). After a restart, "suspend" worked without requiring any password input.

    Regards,
    Jens
    I have had this problem, which was started by an update, then fixed by another update, then screwed up again by another update. I tried the above advise, but found no local authorization entry to delete. Set implicit authos (all 3) to "yes." Restart. Problem not fixed. I suspect this problem was fixed (and relapsed) by "systemd-presets-branding...." patches/updates. I found a "suspend" entry under one of several "systemd project" categories in the above described app (Configure Desktop->System Administration->actions policy. But I find that this app is not working, trying to "Apply" changes returned an error msg after delay, changes to settings are not retained, but revert to previous....

  6. #6

    Default Re: openSUSE 12.3: Suspend Requires Root Permission

    Quote Originally Posted by hthansen View Post
    I have had this problem, which was started by an update, then fixed by another update, then screwed up again by another update. I tried the above advise, but found no local authorization entry to delete. Set implicit authos (all 3) to "yes." Restart. Problem not fixed. I suspect this problem was fixed (and relapsed) by "systemd-presets-branding...." patches/updates. I found a "suspend" entry under one of several "systemd project" categories in the above described app (Configure Desktop->System Administration->actions policy. But I find that this app is not working, trying to "Apply" changes returned an error msg after delay, changes to settings are not retained, but revert to previous....
    Same problem here, although I was able to get "actions policy" to save my setting (when I reboot and go back into action policy the changes I made show), but even with them all set to implicit I still get that prompt, this is incredibly annoying.

    When you close the lid on a laptop IT SHOULD SUSPEND, no if's and's or but's. This really needs to be fixed.

  7. #7

    Default Re: openSUSE 12.3: Suspend Requires Root Permission

    Quote Originally Posted by bwat47 View Post
    Same problem here, although I was able to get "actions policy" to save my setting (when I reboot and go back into action policy the changes I made show), but even with them all set to implicit I still get that prompt, this is incredibly annoying.
    That settings module is just plain broken, even if it may seem to work.
    It already got removed from openSUSE's default installation, see the changelog of "kdebase4-workspace":
    Code:
    * Sat May 18 2013 hrvoje.senjan@gmail.com
    - Remove polkit-kde-kcmmodules-1 from Requires, as the package is
      broken - it overwrites rules shipped by other packages (kde#308934),
      and confuses users that it does something it doesn't (bnc#814763)
    The two bugs mentioned are these:
    https://bugzilla.novell.com/show_bug.cgi?id=814763
    https://bugs.kde.org/show_bug.cgi?id=308934

    The only working and supported method to change those polkit permissions is to add them to /etc/polkit-default-privs.local and run "set_polkit_default_privs" afterwards.
    In this case, you would have to add:
    Code:
    org.freedesktop.upower.suspend yes
    But: Suspend should work without having to enter a password on a default install. (and it does here)
    Have you maybe changed the security settings in /etc/sysconfig/security? (especially "PERMISSION_SECURITY" should be set to "easy local")

    Maybe you have a problem with logind. What does "loginctl" output?

  8. #8

    Default Re: openSUSE 12.3: Suspend Requires Root Permission

    Quote Originally Posted by wolfi323 View Post
    In this case, you would have to add:
    Code:
    org.freedesktop.upower.suspend yes
    Well, actually with KDE 4.11 it is:
    Code:
    org.freedesktop.login1.suspend yes
    Can't check with 4.10 (as included in openSUSE 12.3) now.

    But to be on the safe side, you can just add BOTH lines.

  9. #9

    Default Re: openSUSE 12.3: Suspend Requires Root Permission

    Quote Originally Posted by wolfi323 View Post
    That settings module is just plain broken, even if it may seem to work.
    It already got removed from openSUSE's default installation, see the changelog of "kdebase4-workspace":
    Code:
    * Sat May 18 2013 hrvoje.senjan@gmail.com
    - Remove polkit-kde-kcmmodules-1 from Requires, as the package is
      broken - it overwrites rules shipped by other packages (kde#308934),
      and confuses users that it does something it doesn't (bnc#814763)
    The two bugs mentioned are these:
    https://bugzilla.novell.com/show_bug.cgi?id=814763
    https://bugs.kde.org/show_bug.cgi?id=308934

    The only working and supported method to change those polkit permissions is to add them to /etc/polkit-default-privs.local and run "set_polkit_default_privs" afterwards.
    In this case, you would have to add:
    Code:
    org.freedesktop.upower.suspend yes
    But: Suspend should work without having to enter a password on a default install. (and it does here)
    Have you maybe changed the security settings in /etc/sysconfig/security? (especially "PERMISSION_SECURITY" should be set to "easy local")

    Maybe you have a problem with logind. What does "loginctl" output?
    Let me clarify: it happens with more than one user logged in, and I can't find any way to make it suspend without prompting for authorization in this scenario. its a horrible, horrible default.

    Here's what happens:

    User 1 and user 2 are logged in. I close the lid in the user 1 session. Nothing happens. I open the lid, there is no prompt or anything in user 1, if I switch to user 2 there is an prompt saying I need authorization to suspend with multiple users logged in. As soon as I click anything on that prompt (even if I click cancel and don't put a password) if immediately suspends.

  10. #10

    Default Re: openSUSE 12.3: Suspend Requires Root Permission

    Quote Originally Posted by bwat47 View Post
    Let me clarify: it happens with more than one user logged in, and I can't find any way to make it suspend without prompting for authorization in this scenario. its a horrible, horrible default.

    Here's what happens:

    User 1 and user 2 are logged in. I close the lid in the user 1 session. Nothing happens. I open the lid, there is no prompt or anything in user 1, if I switch to user 2 there is an prompt saying I need authorization to suspend with multiple users logged in. As soon as I click anything on that prompt (even if I click cancel and don't put a password) if immediately suspends.
    Do you have the package "acpid" installed then? If yes, remove it.
    Sounds like two suspend systems are fighting with each other.

    The corresponding polkit rule should be this then in your case I guess:
    Code:
    org.freedesktop.login1.suspend-multiple-sessions
    which also defaults to "yes" for the active console on a default installation.

    To find out which rule is blocking you, click on details and hover the mouse on the text next to "Action:".

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •