Results 1 to 5 of 5

Thread: Opensuse 12.2 OpenNebula 4.0 Beta (3.9.80) ruby 1.8.7 cant find ruby-devel so can't install rubygems

  1. #1

    Default Opensuse 12.2 OpenNebula 4.0 Beta (3.9.80) ruby 1.8.7 cant find ruby-devel so can't install rubygems

    Hi,
    I have installed Opensuse 12.2 64 on my server and downloaded the source code for OpenNebula 4.0 Beta (3.9.80) as I like to compile the Opennebula source code and install manually rather than using the Opennebula rpm's. After a complicated install process of ruby and xmlrpc-c I now can compile opennebula and have installed opennebula (sqlite version as I had too much trouble compiling for mysql so gave up).

    I am now able to start opennebula via the one start command and it works, the problem I have is with the opennebula web gui sunstone, when I try to start sunstone using the sunstone-server start command I get an error

    /usr/lib64/ruby/site_ruby/1.8/rubygems/core_ext/kernel_require.rb:45:in 'gem_original_require' no sutch file to load -- json (LoadError)
    from /usr/lib64/ruby/site_ruby1.8/rubygems/core_ext/kernel_require.rb:45:in 'gem_original_require'
    from /srv/cloud/one/lib/ruby/OpenNebulaVNC.rb:22
    from /srv/cloud/one/bin/novnc-server:54:in 'require'
    from /srv/cloud/one/bin/novnc-server:54
    Could not start novnc server
    Error executing sunstone-server

    When I run zypper install rubygems I get 'rubygems' is already installed.
    No update candidate for 'rubygems-1.8.15-1.1.x86_64'. The highest available version is already installed.

    Searching the internet I have found that I need to install ruby-devel for ruby 1.8.7 and this does not seem to exist. I cannot use ruby 1.9 which is the default for opensuse 12.2 as I cannot compile opennebula when using ruby 1.9

    Opennbula does come with a rubygems_install script but when I run this I get the message "Install the ruby development package for your distro".
    I then use zypper install ruby-devel and get the messages:

    ruby-devel is already installed.
    No update candidate for 'ruby-devel-1.9.3-2.2.1.x86_64' the higest available version is already installed.

    Is there a way to install the ruby-devel for ruby-1.8.7?

    Thanks in advance
    Dennis

  2. #2

    Default Re: Opensuse 12.2 OpenNebula 4.0 Beta (3.9.80) ruby 1.8.7 cant find ruby-devel so can't install ruby

    Hi,

    I think I have solved the problem by un-installing ruby and re-installing ruby 1.9.3, I got some ruby errors but one starts and so does the sunstone-server.

    Not sure if I can recompile opennebula source code, will try again when opennebula 4.x is released.

    Regards
    Dennis

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,375
    Blog Entries
    2

    Default Re: Opensuse 12.2 OpenNebula 4.0 Beta (3.9.80) ruby 1.8.7 cant find ruby-devel so can't install ruby

    Doesn't seem to exist in the openSUSE repos, so
    1. You can try doing a generalized RPM search. Oftentimes RPMs for other distros will work on openSUSE as well.
    2. You can try building from source. The source can be downloaded from GIT and there are a few guides how to build.

    For both these options, you may want to deploy in a VM or chroot so that your base system isn't modified in a way that chanes can't be undone.

    You can also submit a "Feature Request" to bugzilla requesting a build that's as current as possible.

    HTH,
    TSU

  4. #4

    Unhappy Re: Opensuse 12.2 OpenNebula 4.0 Beta (3.9.80) ruby 1.8.7 cant find ruby-devel so can't install ruby

    Thanks for replying, i'm still having problems with xen and opennebula 3.9.8.0, the probem seems to be with parsing files, probably because of ruby. I've tried few different ruby libraries as you suggested (not in chroot or a vm) and have broken a few dependancies.

    I have not been able to find where I can submit a feature request to bugzilla requesting a build that's as current as possible? Can you send me a link?

    I have been hosting opennebula on opensuse 11.3 for about 3+ years and the only reason I upgraded was because I discovered that current versions of mongodb (a requirement for the devops part of opennebula) had issues with 11.3. I first tried upgrading from scratch to opensuse 12.3 but straight away had issues with xen. I then re-installed using 12.2, got further with xen but the issue with ruby is getting from bad to worse. I would like to stay with opensuse but these issues may push me to a different distro.

  5. #5

    Default Re: Opensuse 12.2 OpenNebula 4.0 Beta (3.9.80) ruby 1.8.7 cant find ruby-devel so can't install ruby

    I have now completed an installation of OpenNebula 4.0 Beta (3.9.80) and I must say it looks good and works very well.

    My latest issue was with the libxmlrpc libraries having dependancy issues so I un-installed the existing libraries by searching via zypper se libxmlrpc which lists all libraries then issued the zypper remove command listing all found libraries.

    Once all libraries were removed I issued the following to download and install xmlrpc-c (Stated on the opennebula site) and all my xmlrpc errors disappeared.


    svn co xmlrpc-c - Revision 2458: /super_stable xmlrpc-ccd xmlrpc-c./configuremake make install

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •