Results 1 to 2 of 2

Thread: Bumblebee / optirun with nVidia GeForce 610M graphics card error

  1. #1

    Default Bumblebee / optirun with nVidia GeForce 610M graphics card error

    Running openSUSE 12.3: I've installed bumblebee from the software.opensuse.org website, as well as the required virtualgl packages from the same sources. Whenever I try to run a program (i.e.,
    Code:
    optirun firefox
    ) bumblebee hangs for about 5-10 seconds, then exits with the error:
    Code:
    The Bumblebee X server was not available, please check the
    Bumblebee logfile at /var/log/bumblebee.log
    When I check the file, all I see is this:
    Code:
    [    590.47] Optirun start request received.
    [    590.48] Checking for X server availability before starting X...
    [    590.49] X server is not started
    [    590.49] Power management is disabled, only loading driver
    [    590.53] 
    [    590.53] Starting X using nouveau...
    [    590.54] Waiting for X server to become available...
    [    590.55] The Bumblebee X server failed to start. Please check /var/log/Xorg.8.log
    [    590.55] Waiting for orders
    Does anyone have a clue what the problem is? Any help is much appreciated.

    P.S. I'm using the GNOME flavour, installed from a netinstall disk.

  2. #2

    Default Re: Bumblebee / optirun with nVidia GeForce 610M graphics card error

    I followed the instructions that come up when you add this repository:
    https://build.opensuse.org/package/show?project=home%3AOverman79%3ALaptop&package=bumblebee



    Bumblebee and primus:To enable support for Nvidia Optimus, install those packages:
    Code:
    # sudo zypper in bumblebee primus dkms-nvidia x11-video-nvidia
    After that, ensure to enable bumblebee group was created and you are a member of it.

    To ensure the nvidia module is always rebuild upon kernel upgrades, enable dkms service with the command:
    Code:
    # sudo systemctl enable dkms
    Also enable the bumblebeed service:
    Code:
    # sudo systemctl enable bumblebeedI
    also had to add myself to the video group.
    Last edited by oldcpu; 27-Mar-2013 at 13:23. Reason: Added [ code ] and [ /code ] tags to make text easier to read

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •