Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Slow shutdown 12.3

  1. #1

    Unhappy Slow shutdown 12.3

    It doesn't matter how I do it, from the menu, or using shutdown now/shutdown -h now/shutdown -h -P now/systemctl poweroff, sometimes it powers off immediately, but usually it takes 2+ minutes to shut down. It displays the splash screen most times. If I close the splash screen (esc), all I see is the startup output (last line says '[ OK ] Reached Target Graphical Interface.'). Sometimes after waiting a few seconds, I can get it to shut off by hitting ctrl-alt-backspace, then it outputs something about trouble stopping the sound device and shuts down.
    One time I waited 30 minutes before I just hard shut it off. I've hard shut it off after 30 seconds or so sometimes, and about half the time I can hear the head park on my drive, other times I don't.

    Looked through /var/log/messages and there isn't anything interesting at shutdown time. I'm not sure what else to look at.

    This is a fairly new Dell Latitude (only about 6 months old). I don't remember the model. I had similar issues on 12.2, but it eventually went away (I think after a kernel update). I'm using gnome-shell.

    Any suggestions? Thanks.

  2. #2
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,507

    Default Re: Slow shutdown 12.3

    are the results the same?

    with cmd

    sudo poweroff

  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Slow shutdown 12.3

    Quote Originally Posted by dmulder View Post
    This is a fairly new Dell Latitude (only about 6 months old). I don't remember the model. I had similar issues on 12.2, but it eventually went away (I think after a kernel update). I'm using gnome-shell.
    This might happen if one of the extensions is leaking memory. Try disabling the extensions if you have them. It would also help if you exit the tray icons before shutting down.
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  4. #4

    Thumbs up Re: Slow shutdown 12.3

    sudo poweroff does work
    Disabling all the sys tray icons also allowed me to shutdown. It also made logins faster.
    I didn't have any extensions installed. I had to disable all my sys tray icons for it to work. I tried narrowing down which one, but any of them caused it to hang. I had google chrome, hp status service, and dropbox running.
    I'd like to at least get dropbox back.
    Anyone know what could be causing that?

  5. #5
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Slow shutdown 12.3

    Quote Originally Posted by dmulder View Post
    Disabling all the sys tray icons also allowed me to shutdown. It also made logins faster.
    I did face this issue in 12.2 where the tray icons played very badly with the system and shutdown were painful. I had to exit them all manually before shutting down. But it was worth the trouble.
    Quote Originally Posted by dmulder View Post
    I had google chrome, hp status service, and dropbox running.
    Run this before shutdown. You can get process names from gnome-system-monitor.
    command launcher(Alt+F2)==> killall<space><process name><space><process name> .
    Quote Originally Posted by dmulder View Post
    I'd like to at least get dropbox back.
    Anyone know what could be causing that?
    They are not obviously integrating well with the desktop. On finding the culprit it should be possible to raise a bug report.
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  6. #6
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,507

    Default Re: Slow shutdown 12.3

    Quote Originally Posted by dmulder View Post
    sudo poweroff does work
    if setting up a new user account clears the problem for that user,
    its suggested the current user account be deleted and then setup again,
    the drawback with this is that the desktop reverts to the default and has to be
    tweaked again

  7. #7

    Default Re: Slow shutdown 12.3

    Quote Originally Posted by keellambert View Post
    if setting up a new user account clears the problem for that user,
    its suggested the current user account be deleted and then setup again,
    the drawback with this is that the desktop reverts to the default and has to be
    tweaked again
    Ah, good idea. I'll give that a try.

  8. #8

    Default Re: Slow shutdown 12.3

    I was having this problem.

    It would take 90secs or more to shutdown.

    I've just removed the Lock/Leave widget from near the KDE clock (you might need to Unlock widgets first) and now it shuts down in ~10secs.

    If you're on the desktop you can click the "Search and Launch" thing at the top right of the screen and then select either "Lock" or "Leave" from the menu that appears.

    So it looks like there's an issue with the Lock/Leave widget somehow.

    Hope that helps.

  9. #9
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Slow shutdown 12.3

    Quote Originally Posted by amnesia7 View Post
    I was having this problem.

    It would take 90secs or more to shutdown.

    I've just removed the Lock/Leave widget from near the KDE clock (you might need to Unlock widgets first) and now it shuts down in ~10secs.

    If you're on the desktop you can click the "Search and Launch" thing at the top right of the screen and then select either "Lock" or "Leave" from the menu that appears.

    So it looks like there's an issue with the Lock/Leave widget somehow.

    Hope that helps.
    The other user is believe is using GNOME. If he/she is also using KDE then your suggestions might be useful.
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  10. #10

    Default Re: Slow shutdown 12.3

    My mistake. It was faster to shutdown the first time after removing the Lock/Leave widget but then returned to taking ~90secs again.

    I've since tried renaming the ".kde" folder as just "kde" so that a new one will get recreated. Again, it was faster to shutdown the first time but then has been slow shutting down again since.

    I assume this means the issue isn't with kde if this failed to correct it for me and the user above is having the same issue using gnome desktop.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •