Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: KDE kickoff (application launcher) "Unable to load the widget"

  1. #1

    Question KDE kickoff (application launcher) "Unable to load the widget"

    Greetings

    After running an update (zypper refresh && zypper update) the panel kickoff menu widget is not loaded. Instead there is a square red icon with white X. It is the same for all users on system, new and old. When I hover mouse the message says "Unable to load widget. Could not find requested component: launcher."

    Also, flash and java plugins to Firefox are broken. Related?

    I've tried, on a fresh test user, to move $HOME/.local and $HOME/.kde4, however to no effect.

    Code:
    @durque:~>kde4-config -v
    Qt: 4.8.4
    KDE Development Platform: 4.8.5 (4.8.5) "release 522"
    kde4-config: 1.0
    @durque:~> rpm -qa|grep kdebase|sort
    kdebase4-4.6.0-6.6.2.i586
    kdebase4-libkonq-4.6.0-6.10.1.i586
    kdebase4-nsplugin-4.6.0-6.10.1.i586
    kdebase4-openSUSE-11.4-33.42.1.i586
    kdebase4-openSUSE-lang-11.4-33.42.1.noarch
    kdebase4-runtime-4.8.5-382.19.i586
    kdebase4-runtime-branding-openSUSE-11.4-33.42.1.i586
    kdebase4-runtime-xine-4.6.0-4.9.1.i586
    kdebase4-session-4.6.0-10.1.i586
    kdebase4-wallpapers-4.8.5-51.1.noarch
    kdebase4-workspace-4.6.0-10.18.1.i586
    kdebase4-workspace-branding-openSUSE-11.4-33.42.1.i586
    kdebase4-workspace-ksysguardd-4.6.0-10.18.1.i586
    kdebase4-workspace-liboxygenstyle-4.6.0-10.18.1.i586
    python-kdebase4-4.8.5-1521.1.i586
    @durque:~>
    There seems to be some 4.8.5 packages and some 4.6.0. I'm on OpenSuse Evergreen 11.4.
    (Sorry for the formating below).

    It's only oss, non-oss, evergreen and packman repos that are enabled.

    Code:
    @durque:~> cat /etc/SuSE-release
    openSUSE 11.4 (i586)
    VERSION = 11.4
    CODENAME = Celadon
    @durque:~> zypper lr -u                                                                                                                                                        
    #  | Alias                                               | Name                                                     | Enabled | Refresh | URI                                                                                                                                                                                                                           
    ---+-----------------------------------------------------+----------------------------------------------------------+---------+---------+-------------------------------------------------------------------------------------------------------------                                                                                                                  
     1 | Durque_[Downloads                                   | Durque [Downloads]                                       | No      | No      | dir:///opt/downloads                                                                                                                                                                                                          
     2 | Java_-_openjdk6                                     | Java - openjdk6                                          | No      | No      | http://download.opensuse.org/repositories/Java:/openjdk6:/Factory/openSUSE_11.4/                                                                                                                                              
     3 | Java_-_openjdk7                                     | Java - openjdk7                                          | No      | No      | http://download.opensuse.org/repositories/Java:/jpackage-1.7/openSUSE_Factory/                                                                                                                                                
     4 | OpenSUSE_repositories_[official                     | OpenSUSE repositories [official] - oss                   | Yes     | Yes     | http://download.opensuse.org/distribution/11.4/repo/oss                                                                                                                                                                       
     5 | Opensuse_-_[non-oss                                 | OpenSUSE repositories [official] - non-oss               | Yes     | Yes     | http://download.opensuse.org/distribution/11.4/repo/non-oss/                                                
     6 | Packman Repository                                  | Packman Repository                                       | No      | No      | http://packman.inode.at/suse/openSUSE_11.4/                                                                 
     7 | Packman_-_Essentials                                | Packman - Essentials                                     | Yes     | Yes     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_11.4/Essentials/                                    
     8 | Packman_-_Extra                                     | Packman - Extra                                          | Yes     | Yes     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_11.4/Extra/                                         
     9 | Packman_-_Games                                     | Packman - Games                                          | Yes     | Yes     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_11.4/Games/                                         
    10 | Packman_-_Multimedia                                | Packman - Multimedia                                     | Yes     | Yes     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_11.4/Multimedia/                                    
    11 | Packman_Repository_[Germany                         | Packman Repository [Germany]                             | No      | No      | http://packman.jacobs-university.de/suse/11.3/                                                              
    12 | _-_Updates                                          | OpenSUSE repositories [official] - Updates               | No      | Yes     | http://download.opensuse.org/update/11.4/                                                                   
    13 | download.nvidia.com-opensuse_1                      | nVidia Graphics Drivers                                  | No      | No      | ftp://download.nvidia.com/opensuse/11.4/                                                                    
    14 | download.opensuse.org-openSUSE_11.4_Update_standard | openSUSE BuildService - Virtualization (VirtualBox)      | No      | Yes     | http://download.opensuse.org/repositories/Virtualization:/VirtualBox_backports/openSUSE_11.4_Update_standard
    15 | libdvdcss repository                                | libdvdcss repository                                     | No      | No      | http://opensuse-guide.org/repo/11.4/                                                                        
    16 | openSUSE_Evergreen_11.4                             | Evergreen update repository for openSUSE 11.4 (standard) | Yes     | Yes     | http://download.opensuse.org/repositories/openSUSE:/Evergreen:/11.4/standard/                               
    @durque:~>
    What to do?

  2. #2

    Default AW: KDE kickoff (application launcher) "Unable to load the widget"

    Hi!

    You really shouldn't have any KDE 4.8.5 packages, all of them should be 4.6.0.
    To find out where they come from, you could run f.e. rpm -qi kdebase4-runtime.

    Regarding your problem with kickoff:
    The updated plasmoid in kdebase4-workspace-4.6.0-10.18.1 absolutely needs the newer libkdecore4-4.6.0-6.69.1 (which is provided in the same update) from Evergreen to work.
    What does "rpm -qi libkdecore4" say?

    You seem to have some wild mixture of package versions (this could also explain your java and flash problems, at least I see a deactivated java repository for Factory in your list)
    So maybe the easiest thing to solve your problems would be to run "zypper dup" (this will bring all your installed packages to the versions available in the activated repositories)...

  3. #3

    Default Re: KDE kickoff (application launcher) "Unable to load the widget"

    Thanks for the tip.
    I did
    Code:
    # zypper refresh
    # zypper dup -d
    # zypper dup
    After a while the "whole thing died". That is, a screen saver kicked in, and I was not able to log in again not as any users not even root. I guess I should have disabled screensaver action before starting (lesson learned!). To get back I needed to boot a LiveCD and make a chroot-environment and do the whole thing again. Logins are back, but now panel are totally missing. For all users. However, desktop backgrounds are in place and desktop icons are there. I can do [alt] + [tab] to select applications and [alt] + [F2] to run new ones. Cumbersome ...

    Then I tried
    Code:
    @durque:~> kquitapp plasma-desktop
    Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
    @durque:~> plasma-desktop
    QDBusObjectPath: invalid path ""
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such signal KWindowSystem::windowChanged(WId,unsigned long*)
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(4788)/kdecore (services) KServicePrivate::init: The desktop entry file  "/usr/share/kde4/services/sysinfo.protocol"  has Type= "Application"  but no Exec line 
    
    Object::connect: No such signal QDBusAbstractInterface::Changed()
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
    runar@durque:~> plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(4788) KDesktopFile::isAuthorizedDesktopFile: Access to ' "/home/runar/Desktop/Kontact.desktop" ' denied, not owned by root, executable flag not set. 
    
    plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(4788)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application
    I have no clue what this means. But it didn't help anything at all. Still no panel.

    Code:
    @durque:~> rpm -qi libkdecore4
    Name        : libkdecore4                  Relocations: (not relocatable)
    Version     : 4.6.0                             Vendor: openSUSE
    Release     : 6.69.1                        Build Date: Thu 28 Feb 2013 08:24:12 CET
    Install Date: Fri 29 Mar 2013 14:27:26 CET      Build Host: build31
    Group       : System/GUI/KDE                Source RPM: kdelibs4-4.6.0-6.69.1.src.rpm
    Size        : 2883038                          License: LGPL-2.1+
    Signature   : DSA/SHA1, Thu 07 Mar 2013 15:01:10 CET, Key ID 241b84b36a0f1588
    Packager    : http://bugs.opensuse.org
    URL         : http://www.kde.org
    Summary     : KDE Core Libraries
    Description :
    This package contains the core libraries of the K Desktop Environment.
    
    This package is absolutely necessary for using KDE applications.
    
    Authors:
    --------
    The KDE Team <kde@kde.org>
    Distribution: openSUSE 11.4
    What are my next options to get panel back?
    Last edited by durque; 09-Apr-2013 at 00:59. Reason: typo

  4. #4

    Default Re: KDE kickoff (application launcher) "Unable to load the widget"

    If it hang during the zypper dup, it could be that there still some KDE 4.8.5 packages left, or some packages are incorrectly installed...
    The libkdecore4 seems to be ok now though.

    Maybe try to run "zypper dup" again.

    Or post the output of:
    Code:
    rpm -qa | grep kde
    and
    Code:
    rpm -qa | grep plasma

  5. #5

    Default AW: Re: KDE kickoff (application launcher) "Unable to load the widget"

    Also try to reinstall kdebase4-workspace:
    Code:
    zypper in -f kdebase4-workspace-4.6.0-10.18.1.i586
    Maybe this helps...

  6. #6

    Default Re: KDE kickoff (application launcher) "Unable to load the widget"

    Here's the output of:
    Code:
    @durque:~> rpm -qa | grep kde | sort
    bundle-lang-kde-en-11.4-5.13.1.noarch
    compiz-kde4-0.9.2.1-5.5.i586
    kde4-filesystem-4.6.0-4.1.i586
    kde4-kgreeter-plugins-4.6.0-10.18.1.i586
    kde4-l10n-en_GB-4.6.0-5.3.noarch
    kde4-l10n-en_GB-data-4.8.4-209.3.noarch
    kde4-l10n-en_GB-doc-4.8.4-209.3.noarch
    kde4-mediainfo-0.7.62-1.1.i586
    kde4-pacpl-plugins-4.0.5-3.1.noarch
    kdeartwork4-screensaver-4.6.0-0.2.2.i586
    kdeartwork4-wallpapers-4.8.5-189.3.noarch
    kdeartwork4-wallpapers-large-4.8.5-189.3.noarch
    kdeartwork4-wallpapers-weather-4.8.5-189.3.noarch
    kdebase4-4.6.0-6.6.2.i586
    kdebase4-libkonq-4.6.0-6.6.2.i586
    kdebase4-nsplugin-4.6.0-6.6.2.i586
    kdebase4-openSUSE-11.4-33.38.1.i586
    kdebase4-openSUSE-lang-11.4-33.38.1.noarch
    kdebase4-runtime-4.6.0-4.9.1.i586
    kdebase4-runtime-branding-openSUSE-11.4-33.38.1.i586
    kdebase4-runtime-xine-4.6.0-4.9.1.i586
    kdebase4-session-4.6.0-10.1.i586
    kdebase4-wallpapers-4.8.5-51.1.noarch
    kdebase4-workspace-4.6.0-10.18.1.i586
    kdebase4-workspace-branding-openSUSE-11.4-33.38.1.i586
    kdebase4-workspace-ksysguardd-4.6.0-10.18.1.i586
    kdebase4-workspace-liboxygenstyle-4.6.0-10.18.1.i586
    kdegames4-4.6.0-3.2.i586
    kdegames4-carddecks-default-4.6.0-3.1.noarch
    kdegames4-carddecks-other-4.6.0-3.1.noarch
    kdegraphics4-4.6.0-6.9.2.i586
    kdelibs3-default-style-3.5.10-44.1.i586
    kdelibs4-4.6.0-6.69.1.i586
    kdelibs4-branding-openSUSE-11.4-33.38.1.i586
    kdelibs4-core-4.6.0-6.69.1.i586
    kdemultimedia4-4.6.0-3.3.i586
    kdenetwork4-filesharing-4.6.0-3.2.i586
    kdepasswd-4.6.0-6.6.2.i586
    kdepim4-4.4.10-3.2.i586
    kdepim4-runtime-4.4.10-4.7.1.i586
    kdepimlibs4-4.6.0-4.7.1.i586
    libkde4-4.6.0-6.69.1.i586
    libkde4-debuginfo-4.8.5-522.6.i586
    libkdecore4-4.6.0-6.69.1.i586
    libkdegames4-4.6.0-3.2.i586
    libkdepim4-4.4.10-3.2.i586
    libkdepimlibs4-4.6.0-4.7.1.i586
    liblockdev1-1.0.3_git201003141408-7.1.i586
    libproxy1-config-kde4-0.4.6-3.9.1.i586
    libreoffice-kde4-3.5.4.13-103.1.i586
    lockdev-1.0.3_git201003141408-7.1.i586
    mozilla-kde4-integration-0.6.3-3.1.i586
    NetworkManager-kde4-libs-0.9.svn1192577-7.2.i586
    NetworkManager-kde4-libs-lang-0.9.svn1192577-7.2.noarch
    NetworkManager-openvpn-kde4-0.9.svn1192577-7.2.i586
    NetworkManager-pptp-kde4-0.9.svn1192577-7.2.i586
    NetworkManager-vpnc-kde4-0.9.svn1192577-7.2.i586
    patterns-openSUSE-kde4_games-11.4-6.9.1.i586
    patterns-openSUSE-kde4_internet-11.4-6.9.1.i586
    patterns-openSUSE-kde4_multimedia-11.4-6.9.1.i586
    patterns-openSUSE-kde4_office-11.4-6.9.1.i586
    patterns-openSUSE-kde4_pure-11.4-6.9.1.i586
    patterns-openSUSE-kde4_utilities-11.4-6.9.1.i586
    patterns-openSUSE-kde4_utilities_opt-11.4-6.9.1.i586
    patterns-openSUSE-kde4_xgl-11.4-6.9.1.i586
    patterns-openSUSE-kde4_yast-11.4-6.9.1.i586
    polkit-kde-agent-1-0.99.0-3.1.i586
    polkit-kde-kcmmodules-1-0.98.1-3.2.i586
    python-kde4-4.6.0-3.2.i586
    python-kdebase4-4.6.0-5.15.1.i586
    @durque:~>
    And
    Code:
    @durque:~> rpm -qa | grep plasma | sort
    plasma-addons-4.6.0-4.7.1.i586
    plasma-addons-marble-4.6.0-4.7.1.i586
    plasma-theme-aya-4.6.0-0.2.1.noarch
    plasma-theme-oxygen-4.6.0-4.9.1.i586
    @durque:~>
    And finally
    Code:
    @durque:~> sudo zypper refresh
    root's password:
    Retrieving repository 'Evergreen update repository for openSUSE 11.4 (standard)' metadata [done]
    Building repository 'Evergreen update repository for openSUSE 11.4 (standard)' cache [done]
    Repository 'OpenSUSE repositories [official] - non-oss' is up to date.
    Repository 'OpenSUSE repositories [official] - oss' is up to date.
    Retrieving repository 'Packman - Essentials' metadata [done]
    Building repository 'Packman - Essentials' cache [done]
    Retrieving repository 'Packman - Extra' metadata [done]
    Building repository 'Packman - Extra' cache [done]
    Retrieving repository 'Packman - Games' metadata [done]
    Building repository 'Packman - Games' cache [done]
    Retrieving repository 'Packman - Multimedia' metadata [done]
    Building repository 'Packman - Multimedia' cache [done]
    All repositories have been refreshed.
    @durque:~> sudo zypper in -f kdebase4-workspace-4.6.0-10.18.1.i586
    Loading repository data...
    Reading installed packages...
    Forcing installation of 'kdebase4-workspace-4.6.0-10.18.1.i586' from repository 'Evergreen update repository for openSUSE 11.4 (standard)'.
    Resolving package dependencies...
    
    The following package is going to be reinstalled:
      kdebase4-workspace 
    
    1 package to reinstall.
    Overall download size: 7.4 MiB. No additional space will be used or freed after the operation.
    Continue? [y/n/?] (y): y
    Retrieving package kdebase4-workspace-4.6.0-10.18.1.i586 (1/1), 7.4 MiB (29.2 MiB unpacked)
    Retrieving: kdebase4-workspace-4.6.0-10.18.1.i586.rpm [done (1.6 MiB/s)]
    Installing: kdebase4-workspace-4.6.0-10.18.1 [done]
    @durque:~>
    To test, I did
    Code:
    @durque:~> kquitapp plasma-desktop
    Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
    @durque:~> plasma-desktop &
    [1] 19013
    @durque:~> QDBusObjectPath: invalid path ""
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such signal KWindowSystem::windowChanged(WId,unsigned long*)
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/kdecore (services) KServicePrivate::init: The desktop entry file  "/usr/share/kde4/services/sysinfo.protocol"  has Type= "Application"  but no Exec line 
    
    Object::connect: No such signal QDBusAbstractInterface::Changed()
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
    plasma-desktop(19016)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(19016) KDesktopFile::isAuthorizedDesktopFile: Access to ' "/home/runar/Desktop/Kontact.desktop" ' denied, not owned by root, executable flag not set. 
    
    plasma-desktop(19016)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(19016)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application
    I have no idea what these messages mean, but I didn't get a panel. In my kde4 config I have
    Code:
    @durque:~/.kde4/share/config> ls -l pla*
    -rw------- 1 runar users    85 Mar 29 14:28 plasma-appletsrc
    -rw------- 1 runar users 10009 Apr 12 00:05 plasma-desktop-appletsrc
    -rw------- 1 runar users   891 Apr 12 00:05 plasma-desktoprc
    -rw------- 1 runar users   147 Mar 29 14:28 plasmarc
    -rw------- 1 runar users   994 Apr  1 16:02 plasma-windowed-appletsrc
    -rw------- 1 runar users    85 Mar 29 14:28 plasmoidviewer-appletsrc
    @durque:~/.kde4/share/config>
    How can I reset the plasma-desktop without purging the config entirely?
    What can I keep from $HOME/.kde4 that probably isn't broken?

    Suggestions?

  7. #7

    Default Re: KDE kickoff (application launcher) "Unable to load the widget"

    So you still have those packages from KDE 4.8:
    Code:
    kde4-l10n-en_GB-data-4.8.4-209.3.noarch
    kde4-l10n-en_GB-doc-4.8.4-209.3.noarch
    kdeartwork4-wallpapers-4.8.5-189.3.noarch
    kdeartwork4-wallpapers-large-4.8.5-189.3.noarch
    kdeartwork4-wallpapers-weather-4.8.5-189.3.noarch
    kdebase4-wallpapers-4.8.5-51.1.noarch
    libkde4-debuginfo-4.8.5-522.6.i586
    You should delete all of those (especially libkde4-debuginfo-4.8.5 is completely useless)...
    And for the wallpapers please do:
    Code:
    sudo zypper in -f kdeartwork4-wallpapers-4.6.0-0.2.1  kdeartwork4-weatherwallpapers-4.6.0-0.2.1 kdebase4-wallpapers-4.6.0-5.15.1
    Otherwise this list looks fine now.

    And please post the output of:
    Code:
    zypper ll
    I suppose you have some package locks in place...

    Quote Originally Posted by durque View Post
    To test, I did
    Code:
    @durque:~> kquitapp plasma-desktop
    Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
    @durque:~> plasma-desktop &
    [1] 19013
    @durque:~> QDBusObjectPath: invalid path ""
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(-1, 26) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    Object::connect: No such signal KWindowSystem::windowChanged(WId,unsigned long*)
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
    plasma-desktop(19016)/kdecore (services) KServicePrivate::init: The desktop entry file  "/usr/share/kde4/services/sysinfo.protocol"  has Type= "Application"  but no Exec line 
    
    Object::connect: No such signal QDBusAbstractInterface::Changed()
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    Object::connect: No such slot AbstractItemView::iconSettingsChanged()
    Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
    plasma-desktop(19016)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(19016) KDesktopFile::isAuthorizedDesktopFile: Access to ' "/home/runar/Desktop/Kontact.desktop" ' denied, not owned by root, executable flag not set. 
    
    plasma-desktop(19016)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application 
    plasma-desktop(19016)/plasma StatusNotifierItemSource::refreshCallback: DBusMenu disabled for this application
    I have no idea what these messages mean, but I didn't get a panel.
    Well, I'm not 100% sure either, but there doesn't seem to be a critical error.
    As you said you're seeing the desktop wallpaper and icons, that means plasma-desktop *is* running.
    Try killing it with "killall plasma-desktop" instead of kquitapp.

    But there are some messages about DBUS, is it running?
    Please post the output of:
    Code:
    ps aux | grep dbus
    In my kde4 config I have
    Code:
    @durque:~/.kde4/share/config> ls -l pla*
    -rw------- 1 runar users    85 Mar 29 14:28 plasma-appletsrc
    -rw------- 1 runar users 10009 Apr 12 00:05 plasma-desktop-appletsrc
    -rw------- 1 runar users   891 Apr 12 00:05 plasma-desktoprc
    -rw------- 1 runar users   147 Mar 29 14:28 plasmarc
    -rw------- 1 runar users   994 Apr  1 16:02 plasma-windowed-appletsrc
    -rw------- 1 runar users    85 Mar 29 14:28 plasmoidviewer-appletsrc
    @durque:~/.kde4/share/config>
    How can I reset the plasma-desktop without purging the config entirely?
    What can I keep from $HOME/.kde4 that probably isn't broken?

    Suggestions?
    Does it work now as a new user? If not, resetting your config wouldn't help.
    But if you want to try, just rename/move those plasma* files, don't delete them. So you can move them back afterwards...

    Does creating a new panel work? (right click on the desktop and select "Add Panel")

    You could try to run:
    Code:
    sudo rpm -Va
    and post the output. This verifies all your installed packages. Note that this can take a while...

  8. #8

    Default Re: KDE kickoff (application launcher) "Unable to load the widget"

    Thanks. I recognize that I have the whole night of work ahead of me.
    Strange that wallpaper-packages should have any influence at all. Aren't those only images?

    Will report back shortly.

  9. #9

    Default Re: KDE kickoff (application launcher) "Unable to load the widget"

    Quote Originally Posted by durque View Post
    Strange that wallpaper-packages should have any influence at all. Aren't those only images?
    That's true, they wouldn't cause your problem. So you don't have to do that.
    It was just a suggestion to clean up your system...
    (The packages got renamed between 4.6 and 4.8.)

  10. #10

    Default Re: KDE kickoff (application launcher) "Unable to load the widget"

    These seems to be the only "4.8.5" packages left.
    Code:
    @durque:~> sudo rpm -qa | grep "4.8.5"
    root's password:
    multipath-tools-0.4.8-57.1.i586
    libkexiv2-10-4.8.5-43.3.i586
    libmarblewidget13-4.8.5-62.18.i586
    kpartx-0.4.8-57.1.i586
    Then for locked packages
    Code:
    @durque:~> sudo zypper ll
    # | Name             | Type    | Repository
    --+------------------+---------+-----------
    1 | libbeagle1       | package | (any)     
    2 | beagle-firefox   | package | (any)     
    3 | beagle-google    | package | (any)     
    4 | beagle-gui       | package | (any)     
    5 | libbeagle-python | package | (any)     
    6 | beagle           | package | (any)     
    7 | kio_beagle       | package | (any)     
    8 | grub             | package | (any)
    @durque:~> rpm -q grub
    grub-0.97-175.176.1.i586
    I've kept grub because grub2 made a total mess of my boot. I'll take the leap at a later install. Beagle... Don't know why it's lock I don't have any Beagle on this system. Don't want to either.

    dbus seems to be running.
    Code:
    @durque:~> ps aux | grep dbus
    101       1138  0.0  0.0   3576  1516 ?        Ss   Apr12   0:01 /bin/dbus-daemon --system
    runar     4035  0.0  0.0   3444   744 ?        S    01:22   0:00 dbus-launch --sh-syntax --exit-with-session
    runar     4036  0.0  0.0   3976  1528 ?        Ss   01:22   0:01 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
    runar     7241  0.0  0.0   3684   764 pts/9    S+   09:32   0:00 grep dbus
    You could try to run:
    Code:
    sudo rpm -Va
    and post the output. This verifies all your installed packages. Note that this can take a while...
    Code:
    @durque:~> sudo rpm -Va
    .......T.    /var/lib/misc/PolicyKit.reload
    S.5......    /usr/lib/codecs/AvidQTAVUICodec.qtx
    .M.......    /usr/lib/codecs/atrc.so.6.0
    .M.......    /usr/lib/codecs/cook.so
    .M.......    /usr/lib/codecs/drvc.so
    missing     /usr/lib/codecs/dspr.so.6.0
    .M.......    /usr/lib/codecs/sipr.so.6.0
    missing     /usr/lib/codecs/tokf.so.6.0
    missing     /usr/lib/codecs/tokr.so.6.0
    .M.......    /usr/lib/codecs/vid_3ivX.xa
    S.5......    /usr/lib/codecs/voxmsdec.ax
    S.5....T.  c /usr/lib/jvm/java-1.7.0-openjdk-1.7.0/jre/lib/fontconfig.SuSE.properties
    ....L....  c /etc/pam.d/common-account
    ....L....  c /etc/pam.d/common-auth
    ....L....  c /etc/pam.d/common-password
    ....L....  c /etc/pam.d/common-session
    ..5....T.  c /etc/inittab
    S.5....T.  c /etc/mailcap
    S.5....T.  c /etc/mime.types
    S.5....T.  c /etc/sane.d/dll.conf
    ......G..    /etc/cups/cupsd.conf.default
    S.5....T.  c /etc/postfix/main.cf
    S.5....T.  c /etc/postfix/master.cf
    .......T.    /usr/lib/gconv/gconv-modules.cache
    .M.......    /usr/lib/codecs/cook.so.6.0
    missing     /usr/lib/codecs/ddnt.so.6.0
    missing     /usr/lib/codecs/divxdec.ax
    missing     /usr/lib/codecs/dnet.so.6.0
    .M.......    /usr/lib/codecs/drv2.so.6.0
    .M.......    /usr/lib/codecs/drv3.so.6.0
    .M.......    /usr/lib/codecs/drv4.so.6.0
    missing     /usr/lib/codecs/l3codecx.ax
    missing     /usr/lib/codecs/msg711.acm
    missing     /usr/lib/codecs/msrle32.dll
    S.5......    /usr/lib/codecs/msvidc32.dll
    .M.......    /usr/lib/codecs/vid_cvid.xa
    .M.......    /usr/lib/codecs/vid_cyuv.xa
    .M.......    /usr/lib/codecs/vid_h261.xa
    .M.......    /usr/lib/codecs/vid_h263.xa
    .M.......    /usr/lib/codecs/vid_iv32.xa
    .M.......    /usr/lib/codecs/vid_iv41.xa
    .M.......    /usr/lib/codecs/vid_iv50.xa
    .....U...    /var/cache/cups
    .....UG..    /usr/bin/adr2vcf
    .....UG..    /usr/bin/apoconv
    .....UG..    /usr/bin/scmxx
    .....UG..    /usr/bin/smi
    .....UG..    /usr/share/locale/de/LC_MESSAGES/scmxx.mo
    .....UG..    /usr/share/locale/fr/LC_MESSAGES/scmxx.mo
    .....UG..    /usr/share/locale/it/LC_MESSAGES/scmxx.mo
    .....UG..    /usr/share/locale/ru/LC_MESSAGES/scmxx.mo
    .....UG..  d /usr/share/man/de/man1/scmxx.1.gz
    .....UG..  d /usr/share/man/it/man1/scmxx.1.gz
    .....UG..  d /usr/share/man/man1/scmxx.1.gz
    .....UG..  d /usr/share/man/ru/man1/scmxx.1.gz
    S.5....T.  c /etc/pam.d/login
    Unsatisfied dependencies for siefs-0:0.5-1.i586:
            libfuse is needed by siefs-0:0.5-1.i586
    .M.......  c /etc/sysconfig/network/ifcfg-lo
    ....L....    /usr/lib/libva-egl.so.1
    ....L....    /usr/lib/libva-glx.so.1
    ....L....    /usr/lib/libva-x11.so.1
    .M.......    /etc/cups
    ....L....    /usr/local
    S.5....T.  c /etc/fonts/suse-font-dirs.conf
    S.5....T.  c /usr/share/fonts/encodings/encodings.dir
    S.5....T.  c /usr/share/fonts/misc/fonts.dir
    .......T.  c /usr/share/fonts/100dpi/fonts.dir
    S.5....T.  c /usr/share/fonts/Speedo/fonts.dir
    S.5....T.  c /usr/share/fonts/Speedo/fonts.scale
    S.5....T.  c /usr/share/fonts/Type1/fonts.dir
    S.5....T.  c /usr/share/fonts/Type1/fonts.scale
    .......T.  c /usr/share/fonts/cyrillic/fonts.dir
    S.5....T.  c /usr/share/fonts/truetype/fonts.dir
    S.5....T.  c /usr/share/fonts/truetype/fonts.scale
    S.5....T.  c /etc/splashy/config.xml
    S.5....T.  c /usr/share/kde4/config/kdm/kdmrc
    Unsatisfied dependencies for preload-kmp-desktop-1.2_k2.6.37.1_1.2-5.3.i586:
            kernel-desktop = 2.6.37.1-1.2 is needed by preload-kmp-desktop-1.2_k2.6.37.1_1.2-5.3.i586
    S.5....T.  c /etc/ntp.conf
    /usr/lib/kde4/libexec/kcheckpass should be root:shadow 4755. (wrong owner/group root:root)
    /usr/lib/kde4/libexec/kcheckpass should be root:shadow 4755. (wrong owner/group root:root)
    S.5....T.  c /etc/sysconfig/SuSEfirewall2
    S.5....T.    /usr/bin/X.x11-video-nvidia
    S.5....T.  c /usr/lib/libreoffice/program/fundamentalrc
    S.5....T.  c /usr/lib/libreoffice/share/config/javasettingsunopkginstall.xml
    S.5....T.  c /etc/xinetd.d/vnc
    S.5....T.  c /etc/sysctl.conf
    Unsatisfied dependencies for preload-kmp-default-1.2_k2.6.37.1_1.2-5.3.i586:
            kernel-default = 2.6.37.1-1.2 is needed by preload-kmp-default-1.2_k2.6.37.1_1.2-5.3.i586
    .......T.    /usr/lib/browser-plugins/skypebuttons.so
    S.5....T.  c /etc/maven/maven2-depmap.xml
    missing     /usr/lib/java-1.4.0
    missing     /usr/lib/java-1.4.1
    missing     /usr/lib/java-1.4.2
    missing     /usr/lib/java-1.5.0
    missing     /usr/lib/java-1.6.0
    @durque:~>
    I've created a new user for testing. Need to verify that by closing this session. Will get back on that one shortly.
    Thanks.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •