Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: New 12.3 cannot find the repositories

  1. #1

    Default New 12.3 cannot find the repositories

    Hello. I am a newcomer to OpenSuse. I have installed 12.3 KDE. I logged in for the first time this morning and the system did an "automatic configuration."

    I was then presented with a list of packages which need updating. When I applied the markings I got a series of messages indicating that the repositories cannot be found. That seems very strange because the version is so recent.

    I was also warned that the system must be updated.

    There was an internet connection.

    How do I fix this? I don't know what the problem is so I don't know what to search for.

  2. #2

    Default Re: New 12.3 cannot find the repositories

    There is a bugaboo with network connection settings in openSUSE.
    Here is how to solve it:
    Go to your menu and go to "system" and open up YaST
    In that go to "network devices" and from there click on "network settings"
    In the first tab switch to the option "user controlled with network manager"
    Hit ok and you are done

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: New 12.3 cannot find the repositories

    Quote Originally Posted by ender21 View Post
    Hello. I am a newcomer to OpenSuse. I have installed 12.3 KDE. I logged in for the first time this morning and the system did an "automatic configuration."

    I was then presented with a list of packages which need updating. When I applied the markings I got a series of messages indicating that the repositories cannot be found. That seems very strange because the version is so recent.

    I was also warned that the system must be updated.

    There was an internet connection.

    How do I fix this? I don't know what the problem is so I don't know what to search for.


    Your network may be Not Configured.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: New 12.3 cannot find the repositories

    Quote Originally Posted by ender21 View Post
    Hello. I am a newcomer to OpenSuse. I have installed 12.3 KDE. I logged in for the first time this morning and the system did an "automatic configuration."

    I was then presented with a list of packages which need updating. When I applied the markings I got a series of messages indicating that the repositories cannot be found. That seems very strange because the version is so recent.

    I was also warned that the system must be updated.

    There was an internet connection.

    How do I fix this? I don't know what the problem is so I don't know what to search for.
    open konsole and use the command
    Code:
    su -
    zypper clean --all
    zypper ref -f
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  5. #5

    Default Re: New 12.3 cannot find the repositories

    Thanks for the replies. I will try those fixes. I had trouble locating an iso file to download because the first published links I tried were incorrect and I wondered whether the repository locations may also have been incorrect.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,401

    Default Re: New 12.3 cannot find the repositories

    Quote Originally Posted by ender21 View Post
    Thanks for the replies. I will try those fixes. I had trouble locating an iso file to download because the first published links I tried were incorrect and I wondered whether the repository locations may also have been incorrect.
    Well, they may be correct or not. Pleas show them:
    Code:
    zypper lr -d
    In any case, do not forget to Disable the one that points to the dvd.
    Henk van Velden

  7. #7

    Default Re: New 12.3 cannot find the repositories

    Hello. Thanks to all. The procedure outlined by madmanRB got downloading working. I'll mark this particular issue solved. [EDIT: no can do] I ran the command suggested.

    ender@linux-mua2:/data/sets> zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+---------------------------+------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------
    1 | repo-debug | openSUSE-12.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/12.3/repo/oss |
    2 | repo-debug-update | openSUSE-12.3-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/12.3 |
    3 | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss | No | Yes | 99 | NONE | Index of /debug/update/12.3-non-oss |
    4 | repo-non-oss | openSUSE-12.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.3/repo/non-oss |
    5 | repo-oss | openSUSE-12.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/12.3/repo/oss |
    6 | repo-source | openSUSE-12.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/12.3/repo/oss |
    7 | repo-update | openSUSE-12.3-Update | Yes | Yes | 99 | rpm-md | Index of /update/12.3 |
    8 | repo-update-non-oss | openSUSE-12.3-Update-Non-Oss | Yes | Yes | 99 | rpm-md | Index of /update/12.3-non-oss

  8. #8

    Default Re: New 12.3 cannot find the repositories

    Glad to help, lemmie guess former Buntu user?
    Yeah its a shame you cant really mark threads as solved here.

  9. #9

    Default Re: New 12.3 cannot find the repositories

    No, no 'buntu, thanks.

    I'm still using another distro as my working one. I have other issues with OpenSuse which will take some time to resolve. I had to download and install an rpm manually earlier because neither Yast nor the other software application could find it.

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,401

    Default Re: New 12.3 cannot find the repositories

    Quote Originally Posted by MadmanRB View Post
    Yeah its a shame you cant really mark threads as solved here.
    Why? We simply do it different. When you think it is a shame, you are free to go elsewhere.
    Henk van Velden

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •