Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: BTNX autostart

  1. #1

    Default BTNX autostart

    Hello,

    I'm trying to add BTNX to autostart but due to the fact that i needs root privileges to run i am kinda stuck. I figured that if i can make it run as a normal user things should go smooth from there. So i edited /etc/sudoers to do :

    Code:
    %users ALL = (myusername)NOPASSWD: /etc/init.d/btnx
    However, running btnx on terminal as a normal user still pops up

    Code:
    Absolute path to 'btnx' is '/usr/sbin/btnx', so running it may require superuser privileges (eg. root).
    Any ideeas what i'm doing wrong ?

  2. #2
    dd NNTP User

    Default Re: BTNX autostart

    On 03/26/2013 04:36 PM, rbarsoianu wrote:
    > Any ideeas what i'm doing wrong ?


    what operating system? version?

    what desktop environment (if any)? version?

    how did you install BTNX?

    --
    dd

  3. #3

    Default Re: BTNX autostart

    Quote Originally Posted by dd View Post
    On 03/26/2013 04:36 PM, rbarsoianu wrote:
    > Any ideeas what i'm doing wrong ?


    what operating system? version?

    what desktop environment (if any)? version?

    how did you install BTNX?

    --
    dd
    OpenSuse 12.3, KDE. BTNX was installed from software.opensuse.org (both btnx and btnx-config). And BTNX is working as intended if i start it from root, keybind work in games via wine, no delay.

  4. #4
    dd NNTP User

    Default Re: BTNX autostart

    On 03/26/2013 06:06 PM, rbarsoianu wrote:
    > both btnx and btnx-config


    then i would have to assume* it runs as a service, like other
    daemons--so i'd expect if you opened YaST > System > System Services and
    -click on "Expert Mode" (you are an expert, right?)

    -scroll down to BTNX

    -click to start up in runlevel 2, 3 and 5

    -click the Start/Stop/Refresh button and select "Start now"

    -click the "Ok" button

    (i assume* because i have not installed it just so i can find and
    read the docs to see how they say to set it up--maybe what i write is
    not possible, but i think it should be if it is correctly installed
    by a well working one-click)

    --
    dd
    http://tinyurl.com/DD-Caveat

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: BTNX autostart

    On 2013-03-26 16:36, rbarsoianu wrote:

    > Any ideeas what i'm doing wrong ?


    You have to run:

    Code:
    sudo /usr/sbin/btnx
    
    or rather
    
    sudo /etc/init.d/btnx
    On the other hand, 'dd' is correct, being a system service you just
    activate it.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  6. #6

    Default Re: BTNX autostart

    Hello,

    Thx for the reply, DD's solutions seems rlly nice. And btw i'm not an expert . However in System Services i cannot select the runlevel, maybe it's a bug, therefore the service cannot autostart. Any ideeas ?

    View image: yast2 000

  7. #7

    Default Re: BTNX autostart

    Quote Originally Posted by robin_listas View Post
    On 2013-03-26 16:36, rbarsoianu wrote:

    > Any ideeas what i'm doing wrong ?


    You have to run:

    Code:
    sudo /usr/sbin/btnx
    
    or rather
    
    sudo /etc/init.d/btnx
    On the other hand, 'dd' is correct, being a system service you just
    activate it.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)
    I know what i have to run in order to start it, however i want it to autostart, without asking me for a password. That's why i thought sudoers might come in handy. However DD's solution seems rlly nice, it's just that the runlevels don't show up for some reason, check the print here : View image: yast2 000

  8. #8
    dd NNTP User

    Default Re: BTNX autostart

    On 03/28/2013 12:16 PM, rbarsoianu wrote:
    >
    > 'View image: yast2 000' (http://postimg.org/image/po7jlxuvv/)


    hmmmm...maybe this has something to do with this new systemD
    thing...in your image i can see a button named "Help" can you learn
    something in there? i would hope you can!!

    or, if you first push the "Start/Stop/Refresh" button....and if you
    selected to "Start now" *maybe* it will then either let you pick some
    runlevels or just ask something like "Start on boot every time" or
    something..

    or or maybe the Help button explains what that box next to that B is
    for, and maybe if you click it you house burns down, or something
    more smile producing--i do NOT know, so see the sig caveat before
    pushing anything other than that Help button!!

    or or or maybe if you push the "Set/Reset" button you can select to
    enable the service....and, maybe once you do that it will
    automatically always be enabled on every boot....like magic....and
    you don't even have to decide which runlevels to pick!!

    --
    dd
    http://tinyurl.com/DD-Caveat

  9. #9

    Default Re: BTNX autostart

    Quote Originally Posted by dd View Post
    On 03/28/2013 12:16 PM, rbarsoianu wrote:
    >
    > 'View image: yast2 000' (View image: yast2 000)


    hmmmm...maybe this has something to do with this new systemD
    thing...in your image i can see a button named "Help" can you learn
    something in there? i would hope you can!!

    or, if you first push the "Start/Stop/Refresh" button....and if you
    selected to "Start now" *maybe* it will then either let you pick some
    runlevels or just ask something like "Start on boot every time" or
    something..

    or or maybe the Help button explains what that box next to that B is
    for, and maybe if you click it you house burns down, or something
    more smile producing--i do NOT know, so see the sig caveat before
    pushing anything other than that Help button!!

    or or or maybe if you push the "Set/Reset" button you can select to
    enable the service....and, maybe once you do that it will
    automatically always be enabled on every boot....like magic....and
    you don't even have to decide which runlevels to pick!!

    --
    dd
    DD Caveat

    The b i think it's the argument it passes to btnx, for example it i run btnx -b (as su) it runs process as a background daemon. The start, restart and everything else, do start the process and it works, however it still dosn't solve my problem, since it dosn't autostart. I tried all, restarted the os, btnx is still not running. None of the other services lets me select the runlevel, that's why i thought it's a bug in the gui, since i think that in older versions it was there. Any other ideea how i can manually start it ?

  10. #10
    dd NNTP User

    Default Re: BTNX autostart

    On 03/28/2013 02:06 PM, rbarsoianu wrote:
    > Any other ideea how i can manually start it ?


    i guess you are saying that there was no help available from the
    "Help" button, right?

    if that is the case you need one of two things: 1) read enough to
    learn how to start services during boot in a systemd system, or 2)
    wait until someone finds your question and gives you the answer..

    [i do not know the answer, or i would tell you...i think i could tell
    you in a systemv system, but maybe not and for sure not in a systemd
    system...which is one reason i am still on 11.4--am waiting for
    'them' to fully incorporate systemd into openSUSE and YaST]

    --
    dd


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •