Results 1 to 2 of 2

Thread: TSIG rndc-key tsig verify failure (BADKEY)

  1. #1

    Default TSIG rndc-key tsig verify failure (BADKEY)


    I'm trying to configure a DHCP and DNS using a rndc-key, according to these tutorial:
    Dynamic-DNS with openSUSE 11.2 - YouTube!

    I could do it fine on a VM with openSUSE 12.2. I tried again with openSUSE 12.3 and I'm having these problem:
    named: request has invalid signatures: TSIG rndc-key tsig verify failure (BADKEY)

    How do I debug this type of error? I tried both creating a custom key and using the default /etc/rndc.key and with both approaches I'm having the same error.

    Any ideas?

    Thanks a lot!

  2. #2

    Default Re: TSIG rndc-key tsig verify failure (BADKEY)

    Had the same issue.
    For some reason (which is out of scope of my experience) the file /etc/named.conf.include is/remains empty in openSuSE 12.3.
    There should be the pointer to the .key file (e.g. include "/etc/named.keys";).

    Hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts