Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: VNC closes/crashes after log in

  1. #11

    Default Re: VNC closes/crashes after log in

    Was having the same exact issue with the vnc client disconnect after the disk icon solidifies on openSuse 13.1 x86_64. rrsilvanet's advice cured the disconnect and the session stays open, I just can't see it as the screen seems to hang on the login/splash screen and does not migrate to the KDE Desktop. I am dual screen with ATI video card and have recently migrated (clean install) from openSuse 12.2 using the fglrx-legacy video drivers in that build, now using the 'free radeon' drivers under 13.1 as fglrx-legacy is depreciated. To note, on the host machine screen 0, right after the disk icon solidifies the screen flashes (like a resolution switch) and the KDE desktop loads, I do not get to see the other icons load, nor is there a smooth fade to the KDE desktop... and this is where I'm loosing the vcn client. These icons do load however, and the fade transition does happen on the 2nd monitor, screen 1. I remember a similar 'flicker' between splash/login screen and KDE desktop in 12.2, but cured it ages ago and don't remember how. Any help much appreciated!

  2. #12

    Default Re: VNC closes/crashes after log in

    Did you ever get a resolution on this issue?

    I too can login authenticate but it just hangs on the default background.

  3. #13

    Default Re: VNC closes/crashes after log in

    Seems to be a problem with kdm multiple login ... see at /var/log/messages like ....
    ---- > kdm_config[28034]: Multiple occurrences of section [General] ...
    etc.

    I tried to solve by a logout at the vnc server system .... and it works with the remote vnc session :-)

  4. #14

    Default Re: VNC closes/crashes after log in

    Quote Originally Posted by fburzler View Post
    Seems to be a problem with kdm multiple login ... see at /var/log/messages like ....
    ---- > kdm_config[28034]: Multiple occurrences of section [General] ...
    etc.
    No, that's definitely not related to your problem.
    Those _warnings_ (those are no errors) are "normal" on openSUSE. They are caused by the way specific settings from /etc/sysconfig/ are added to the kdmrc.

    But that should cause no problem whatsoever.

    I cannot comment on your actual issue though.

  5. #15

    Default Re: VNC closes/crashes after log in

    Could you try different desktop environments at the login screen and see if you have the same issue with them? I have the same issue with 13.1 and I think it is something with the KDE environment.

    I managed to get around this issue by disabling IPv6 in network settings in YaST, so there seems to be something fishy with the IPv6 and KDE combined.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •